Jump to content

iveo

Members
  • Content count

    74
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Gerhard Wernigg
  1. iveo

    2 products per line

    that's easy - do it yourself - just go for product_listing.php and modify ;)
  2. I tried to change it like this, but it output the title twice instead of once, so I must be doing it wrong: What is the the correct way to revise it? this is the function from the html_output.php: function tep_image($src, $alt = '', $width = '', $height = '', $parameters = '', $res = 1, $addattribs = 1) so you see what you made wrong? so if you place an image with that function it looks like this: tep_image(>images adress< , >alt-text< , >width< , >height< , >parameters<) ;)
  3. iveo

    STS and Coolmenu

    got same problem...
  4. iveo

    STS and Categories Box Text Size

    look into your /includes/boxes/categories.php somewhere there you'll see the tags and the style that is called ;)
  5. iveo

    coolMenu

    anyone knows about the STS contrib? I'd like to run coolmenu together with that contrib, but the menudata fails to be where it should be... :o
  6. iveo

    STS Compatibility

    I'm looking for that too - and I am working on it - but till now I couldn't understand why it's not working...
  7. iveo

    Using Xsell with STS 2.01 Help

    you'll need to put the xsell stuff into a variable, capture it like other sts vars and then parse it through sts where you call it with the variable
  8. I worked around with the "coolmenu" distribution and still couldn't figure out, why it is not working... ...the coolmenu distrib works with a nice JS from: http://www.dhtmlcentral.com/projects/coolmenus/ this script is very very easy to customize... so what the distrib does is, that it builds the menu-content from the the categories database content - same as the normal categories script does - with the only difference that it puts javascript around everything - still shouldn't make a difference when i install the coolmenu it even displays a box and a box header which says "categories" - but somehow there is no content in that box - no menu maybe there is a problem with the JS code with STS? does sts have a problem with JS in the body? I hope j0ker can show me what he means soon! :o I really need to get this working, because the menu is blowing up my column left at the moment... @brian - I even think you should take a look at that contrib, because it would be a great addition to your contrib and I think it would benefit a lot from that! ;)
  9. don't know what this has to do with sts but: go to your index.php and look for: } elseif ($category_depth == 'products' || isset($HTTP_GET_VARS['manufacturers_id'])) { and beneath that find: <td class="pageHeading"><?php echo HEADING_TITLE; ?></td> and there change to that: <td class="pageHeading" align="center"><?php echo HEADING_TITLE; ?></td> ;)
  10. @brian - the capture didn't work - i tried it out - what the menu does is: it simply takes the data of the categories like the categories box usually does... ...the only thing it does differntly is, that it formats it into javascript instead of tables or breaks... ...so it should work, but it does not - somehow - I mean - maybe I made a mistake, but I saw some other people complaining and also that it's a feature request for sts - so I thought it wouldn't be my fault - I don't know what the exact problem is - very strange
  11. wow - sounds great! ...both ideas seem to be very good! @brian I'll try to capture it like you mentioned - maybe this will work but I think I'll have to put the whole javascript code in the head of my template.html - bec. otherwhise it wouldn't work - i think @joker looking forward to your reply - I'd really liket to see that! :rolleyes: :D to both: thanks for fast replys!!!
  12. Hi! I'd like to refer to my question, which hasn't been answered yet. http://forums.oscommerce.com/index.php?sho...00entry377057 I kindly ask someone to help out :rolleyes:
  13. iveo

    new box in sts

    first you have to add something like this in your includes/column_left.php: example comes from a box that i've added: require(DIR_WS_BOXES . 'featured.php'); // STS: ADD $sts_block_name = 'featuredbox'; require(STS_RESTART_CAPTURE); // STS: EOADD then in includes/sts_display_output.php around line 220 find: $template['breadcrumbs'] = $breadcrumb->trail(' » '); and after that you should place your box-heading definition somewhere - which should look like this: $template['featuredboxheading'] = TABLE_HEADING_FEATURED_PRODUCTS; then find this code around line 250: ///////////////////////////////////////////// ////// Create custom boxes ///////////////////////////////////////////// and after that somewhere place your box definistion which should look like that: $template['featuredbox'] = strip_unwanted_tags($sts_block['featuredbox'], 'featuredbox'); finally around line 330 find: // print column_left stuff there you specify in which column you box should appear - so under column left or column right you place your code: echo $sts_block['featuredbox']; and thats it for the STS - stuff - then just call $featuredbox in your template and it should be there - but don't forget that you have to have the right box in your includes/boxes/ folder !!! ;) - hope that helps you out PS: the heading must be specified in your language --> like in includes/languages/english.php you must have: define('TABLE_HEADING_FEATURED_PRODUCTS', 'Featured Products');
  14. Did you try putting the javascript for the click to enlarge directly in the sts_template.html file? I had that problem and it fixed it. Have you tried the debug features? You can turn the sts on and off with the debug on and get quite a bit of info on what is going on with your site. same for me - you have to put everything like css and javascript into the header of your template.html - otherwhise you'd have problems - had the same problem - that solved it... ;)
  15. Hi! I'd like to refer to my question, which hasn't been answered yet. http://forums.oscommerce.com/index.php?sho...00entry377057 I kindly ask someone to help out :rolleyes:
×