Latest News: (loading..)

BFkiUB

Members
  • Content count

    24
  • Joined

  • Last visited

1 Follower

About BFkiUB

Profile Information

  • Real Name
    Andrej
  1. Hi, I am using Ultimate Html Emails v2.1-2.3 for oSc 2.3.1. My Tell a Friend e-mail has no subject. How can I fix this? Thanks in advance, Andrej
  2. I installed this nice contribution, but I have one problem. The Shipping page is successfully bypassed, but Payment page is not bypassed. I followed the instructions: - In admin > payment I set "Free Product" as the first payment method. - In "catalog/checkout_payment.php" just before: require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_CHECKOUT_PAYMENT); I added: // BOF skip if only 1 payment method available. IF YOU HAVE 2 PAYMENT METHODS then "set tep_count_payment_modules() == 2" if (tep_count_payment_modules() == 1 ) { $payment_select = $payment_modules->selection(); $payment = $payment_select[0]['id']; if (!tep_session_is_registered('payment')) tep_session_register('payment'); tep_redirect(tep_href_link(FILENAME_CHECKOUT_CONFIRMATION, '', 'SSL')); } // EOF I put only one free product in my shopping cart, but when I click Checkout, the Payment page still opens :( How can I bypass Payment page? Best wishes, Andrej Kikelj
  3. Thanks a lot George, I applied only one modification of two, and now it works. In case that somebody else will use both Option Types and Ultimate HTML E-mails contributions - here's the applied change: In file \includes\modules\UHtmlEmails\Green\checkout_process.php ------------------------------------------------------------------------------ Find: $HTML_Email_product_attributes[$i] .= '<br /><em style="font-size:12px;"> -'. $attributes_values['products_options_name'] . ': ' . $attributes_values['products_options_values_name'] .'</em>'; Change with: $HTML_Email_product_attributes[$i] .= '<br /><em style="font-size:12px;"> -'. $attributes_values['products_options_name'] . ': ' . tep_decode_specialchars($order->products[$i]['attributes'][$j]['value']) .'</em>'; Regards, Andrej
  4. Hi, I have a problem with a combination with contribution Ultimate HTML E-mails. When customer recieves e-mail with order confirmation TEXT or TEXT AREA attributes are not listed; there is only CUSTOMER-INPUT text (see picture). Maybe I should somehow change checkout_process file from Ultimate HTML E-mails contribution - I attached it (The path is \includes\modules\UHtmlEmails\Green\checkout_process.php). I would appreciate if someone can solve this for me. Andrej checkout_process.php
  5. Hi Chris, I have one more question. In Admin / Configuration / Downloads / Order Status Value - the only value that works for me is 2. Is this OK or is it a problem? Because default is 10 and you said it should not be less than 10. What is actually "Order Status Value"? Andrej
  6. Thank you Chris for your answer. Button file is missing in your last contribution upload from 20 May 2011. I found it in your first upload from 21 Jan 2011. But still I get the same error. Then I followed previous suggestion in this thread to change the button to optional text rather than an image: catalog/includes/languages/english.php Find: define('IMAGE_BUTTON_DELETE', 'Delete'); Add the following after: define('IMAGE_BUTTON_DOWNLOAD', 'Download Now!'); Now it works and I can easily change the text for my three different languages. Best wishes, Andrej
  7. Hi, I installed this nice contribution, but I have one problem. On Checkout Success page a download button has this text: IMAGE_BUTTON_DOWNLOAD. See how it looks like in attachment. How can I correct this error for my multi-language shop? Thanks, Andrej
  8. OK Jim, thank you very much for your help! Andrej
  9. I see. Yes, I use more than one language - English, Croatian and Slovenian. I installed a contribution "Browser Language Redirection for Multilanguage Stores" (http://addons.oscommerce.com/info/6879). Does this contribution solve my encoding problem? My web page is http://shop.astronumero.org - if you care to test it a little. Best regards, Andrej
  10. Thank you Jim for your well intended advice. But such a big change is beyond my abilities and time. The author of Slovenian language contribution for oSc 2.3.1 says that "because of the problems with special characters it comes with the win-1250 coding table. I am sure UTF-8 would be better, but that should be made by some expert. I already installed many contributions and so far my web page is working quite nicely. What are the major problems I should expect with windows-1250 table? Best regards, Andrej
  11. Thank you Jim for your answers and advice. Unfortunately I must uninstall PDF Datasheet :( Best wishes, Andrej
  12. It seems that the problem is in fonts. If in description I use some special letters from Slovenian or Croatian alphabet, then the description in pdf datasheet is empty. (I use oSc contribution for Slovenian language which comes with the win 1250 coding table.) How shall I fix this? Regards, Andrej
  13. I have following modules installed: Description Fonts Header Initialize Product Page Link Title Please see the attachment. Best regards, Andrej
  14. Thank you Jim for your answer. With large images the error messages disappear. But created pdf is completely without description text - only header, footer and picture are shown. What shall I do that the product description will show properly? Thanks a lot for you help, Andrej
  15. Dear Jim, I installed your PDF Datasheet contribution, installed the modules without any modification, and got this error message: Notice: getimagesize() [function.getimagesize]: Read error! in /home/astronum/public_html/shop.astronumero.org/includes/modules/pdf_datasheet/pd_description.php on line 54 TCPDF ERROR: [image] Unable to get image: images/ Fatal error: Call to a member function store() on a non-object in /home/astronum/public_html/shop.astronumero.org/includes/modules/ultimate_seo_urls5/main/usu5.php on line 78 I read your discussions on similar problem, but I couldn't find a solution. Would appreciate if you could help me out. Andrej