Jump to content

behindtext

Members
  • Content count

    5
  • Joined

  • Last visited

  1. behindtext

    FedEx - Web Services v9

    i believe i have determined the source of the overcharging issue: the line in catalog/includes/modules/shipping/fedexwebservices.php where the PackagingType fedex variable is set. it defaults to YOUR_PACKAGING with the 9.4.2 files, which is obviously inaccurate for websites that ship products via fedex express with fedex-supplied packaging. i added some conditional handling for the PackagingType based on the shipping_weight variable and confirmed it does give the correct quotes.
  2. behindtext

    FedEx - Web Services v9

    further information that may be of use: this rate increase does not occur with all destination zipcodes, e.g. shipping from 60601 to 94109 gives the correct rate but shipping from 60601 to 03110 is off by about 30%. if there is a newer .wsdl file from fedex i will attempt to use that and see if it helps.
  3. behindtext

    FedEx - Web Services v9

    i have seen the same issue myself with version 9.4.2: overnight rates that are $6-15 over the rate that the web interface shows. we ship 100s of packages and customers have been complaining about this for the past ~3 weeks. it would be great if roaddoctor or another dev who is familiar with this contrib fixed this. one thing that could be responsible for this rate problem is the .wsdl file used: it's v9 and v10 is current, at least for the label printing. thx for reading :)
  4. behindtext

    Official Dwolla Support Thread

    did some further investigation myself, found that some $_POST variables were not carrying values correctly. seems that the accountId and paymentKey $_POST variables are unset when it gets to the before_process function in dwolla.php. just to be clear i have a checkout flow like checkout_shipping -> checkout_payment -> checkout_confirmation -> pay on other site, e.g. PP or dwolla and then it brings me back to the checkout_payment screen and complains about the account number being invalid.
  5. behindtext

    Official Dwolla Support Thread

    i recently added dwolla payment to my site using the Mar 9 version of this contrib. seems to mostly work until you try to complete checkout. customers see The Dwolla account ID specified is not the proper format (XXX-XXX-XXXX). despite it being entered properly. no useful information shows up in the logs, only [error] mod_ssl: SSL handshake interrupted by system [error] System: Connection reset by peer (errno: 54) any clues about debugging these errors would be helpful.
×