Latest News: (loading..)

Wes_SFLL

Members
  • Content count

    10
  • Joined

  • Last visited

1 Follower

About Wes_SFLL

Profile Information

  • Real Name
    Wes
  • Gender
    Male
  1. I have been trying to figure out if its even possible to send UPS.com's create a label page the ship to info like with the contribution for USPS called "USPS Shipping Labels". Has anyone figured anything out on this? I can only pass that page info using the web console in firefox to enter the info and thats a pain.
  2. Alright in orders.php under your admin folder find the old code for usps label shipping which should look like.... <a href="' . tep_href_link(FILENAME_ORDERS_USPS_SHIP, 'oID=' . $HTTP_GET_VARS['oID']) after that entire line but before the next occurrence of </td> add this: <? include('uspslabelfix.php');?> OR (the same thing can be done by adding include('uspslabelfix.php'); just before the ?> at the end of the line ) What you are doing is adding a button that has a bunch of hidden form elements to your orders.php file... Make sure to upload uspslabelfix.php from the contribution at http://addons.oscommerce.com/info/1498 to your admin folder. Doing it this way over replacing the filename for the usps label contribution is great just in case they switch back to the old way...
  3. I am still trying to figure out if we can override the preset return address from when your usps.com account was setup. I ship from 2 different sites and want the info to auto load but it sure looks like it doesn't wanna play fair. O well.... at least we can still use this to print labels... I like how much easier it is to print labels...available to print until midnight and the new pdf option sure is nice. NO MORE DOUBLE CHARGES so I hope.
  4. Oh sorry I have that function doing that when the order is placed...Trying to keep the DB trim! lol ....My bad
  5. In orders.php you should have: a href="' . tep_href_link(FILENAME_ORDERS_USPS_SHIP, 'oID=' . $HTTP_GET_VARS['oID']) . '" TARGET="_blank">' . Change it to: a href="' . tep_href_link('uspslabelfix.php', 'oID=' . $HTTP_GET_VARS['oID']) . '" TARGET="_blank">' . then just upload the new uspslabelfix file i made
  6. Ok After 14 hours of hacking that code apart I got it working.... all the code for the return address is hard coded so that I could get this working faster. I ended up using some code I found for the zen cart forum and did a include to the order.php to the new file that I created. I will try and update the usps shipping labels. Again its not really clean but I have 50 labels I need to print from the weekend and didn't want this problem to go on any longer. Maybe someone can add back in all the cool variables etc from the original one. All credit goes to the past authors.
  7. WTH!!! I can't believe that they did this...!!!! BAD start to a monday! I did a test on usps.com and now the link needs a label id which the oldway didn't need to get to the next page. Anyone got the hot fix?