Jump to content

dr_lucas

Members
  • Content count

    357
  • Joined

  • Last visited

  • Days Won

    7

Everything posted by dr_lucas

  1. dr_lucas

    SiteMonitor

    Jack already posted the link (https://apps.oscommerce.com/2W7tC&sitemonitor-v3-4) and it's working fine, the docs are there, so not sure what's the issue, Steve:
  2. dr_lucas

    NEW! Complete Order Editing Tool!

    My revised files contain proprietarty code, thus I can't share them as-is unfortunately. And it's not only edit_orders that was modified, but multiple files AFAICR. Trust me, if I could share them, I would have done so without being requested.
  3. dr_lucas

    NEW! Complete Order Editing Tool!

    It doesn't as I don't charge taxes, but my files do contain many fixes to other bugs including weight calculation bugs. I don't use the AJAX module either. Besides, I don't really have time to un-tailor code unfortunately. My advice is still a good one.
  4. dr_lucas

    NEW! Complete Order Editing Tool!

    But this is not something u must live with. You can either debug it and fix it for your own shop/s (as I did, but I can't share my fixes here as they are tailored for my needs) or hire someone to do it for you.
  5. @@stefan21 Thank You! Exactly what I was looking for... :)
  6. dr_lucas

    ULTIMATE Seo Urls 5 - by FWR Media

    Merry Christmas everyone! :) I have an issue with the period (.) character http://example.com//index.php?cPath=44_95&page=1&range=1.99_2.99 gets rewritten according to the rule and the 1.99_2.99 becomes 199_299 It doesn't happen when I turn off USU5 pro, so it's an issue with the module coding or .htaccess(?) How can I escape the period safely? (ie. without causing some random side effects)
  7. dr_lucas

    Google XML Sitemap SEO

    Correction, it seems all the version files show the same version 1.2, so I believe mine maybe a newer one - 1.4 or 1.5, if that makes any difference.
  8. dr_lucas

    Google XML Sitemap SEO

    @@Jack_mcs Yes, I did on my own site and it generated only 1 file of 50,000 products (out of the 90,000 I have). The file size was 12MB. I have an older version (1.2) so that is possibly the reason it did not generate the consecutive file, but still - 12MB form 50,000 products is larger than the allowed standard.
  9. dr_lucas

    Google XML Sitemap SEO

    Thanks, Jack. It seems google size limit is different than the standard, which is 10mb, and if we want sitemaps that can be read by all search spiders, it would be better to make the code check for that limit and create a new sitemap if reach the 10mb. More details here: https://productforums.google.com/forum/#!topic/webmasters/nd5RDhMMfhk
  10. dr_lucas

    Google XML Sitemap SEO

    @@Jack_mcs - first, thank you for the contribution! Sorry if the question was asked and answered before, but does this module support catalogs with over 50,000 products? Does it auto-generate additional sitemap files as required? Does it make sure the total file size of each sitemap is under 10mb?
  11. dr_lucas

    FedEx - Web Services v9

    If I read that right, FedEx will apply dimensional shipping to Freight and Ground services, but they will also keep the weight based shipping. This change to these 2 specific services seems to be USA exclusive and all other services are not affected anyway. As I do not personally ship inside the USA, do not use any of these mentioned services and always ship by weight only, I did not have the need to look into this and will not spend the time to modify the module, but it should be quite easy to modify it and add the dimension shipping or you can hire a freelancer to modify it for you from places like http://www.freelancer.com
  12. dr_lucas

    SiteMonitor

    Great contribution! Thanks Jack! :) Does it work on 2.2 MS2a? Also, in this post: http://forums.oscommerce.com/topic/221438-sitemonitor/page-108#entry1684558, you mentioned an upcoming version which will allow excluding some lines of code. Is it coming soon?
  13. dr_lucas

    FedEx - Web Services v9

    in your catalog/includes/modules/shipping/fedexwebservices.php Try this: Find: if($ShipmentRateDetail->ShipmentRateDetail->RateType=='PAYOR_LIST_PACKAGE') // if($ShipmentRateDetail->ShipmentRateDetail->RateType==('PAYOR_LIST_PACKAGE' || 'PAYOR_LIST_SHIPMENT')) // try this if having international quoting errors Change to: // if($ShipmentRateDetail->ShipmentRateDetail->RateType=='PAYOR_LIST_PACKAGE') if($ShipmentRateDetail->ShipmentRateDetail->RateType==('PAYOR_LIST_PACKAGE' || 'PAYOR_LIST_SHIPMENT')) // try this if having international quoting errors
  14. dr_lucas

    FedEx - Web Services v9

    Most importantly, what do you have set under Currency Exchange Rates Conversion? And what happens when you try "ACCOUNT" instead of "LIST" rates?
  15. dr_lucas

    FedEx - Web Services v9

    You are missing a few. Please take a moment to write and post the full list 1 by 1.
  16. dr_lucas

    FedEx - Web Services v9

    What are your fedex module's settings, 1 by 1, except for the 4 credentials settings (ie. except for FedEx Web Services Key, FedEx Web Services Password etc.)?
  17. dr_lucas

    FedEx - Web Services v9

    @@Gyakutsuki The request and response you sent me via PM do seem to work as intended. What is the issue?
  18. dr_lucas

    FedEx - Web Services v9

    What you wrote is just a line from a request. To debug, I must see and test your FULL exact request, otherwise there isn't much I can do. For security reasons, please send it via PM, unedited.
  19. dr_lucas

    FedEx - Web Services v9

    Note, if you change the wsdl address from test to production server and vice versa, it would also be best if you put 2 wsdl files in separate folders and point to each separately, depends on the status of your site (production or test), this is to avoid possible caching problems of the wsdl which may still continue using the production or test servers despite the editing of the wsdl file. for example: for test point to /catalog/includes/wsdl/test/rateService_V9.wsdl and for production point to /catalog/includes/wsdl/production/rateService_V9.wsdl Regarding the actual SOAP response you got, if you want me to debug it, I will need to see the full exact request, please send it to me untouched (as is) via PM, including the full credentials.
  20. dr_lucas

    FedEx - Web Services v9

    Cool. Let me know how it works after you get and use the new credentials.
  21. dr_lucas

    FedEx - Web Services v9

    The response shows errror 1000 authentication failed, so I assume there is some mistake with your provided credentials. You probably have missing or wrong credentials, such as missing the authentication key from fedex. Does it give you any shipping quotation for other destinations at all?
  22. dr_lucas

    Fedex Thermal labels not printing

    For anyone still looking for a java applet/plugin to print EPL/ZPL: http://qzindustries.com/
  23. dr_lucas

    NEW! Complete Order Editing Tool!

    I guess u didn't accurately do what I wrote...probably left out the } at the bottom of the function (under the last return $tax_data;) copy and paste it EXACTLY as I wrote, and it won't error.
  24. dr_lucas

    NEW! Complete Order Editing Tool!

    Cool. Did u try editing the file I suggested?
  25. dr_lucas

    NEW! Complete Order Editing Tool!

    By the way, thinking again, I am pretty sure that your configure.php in the /includes and /admin/includes are pointing to a different DIR_WS_MODULES directory, I bet one is to modules and the other one to mod, which is incorrect and should be the same in both of the configuration files and of course should match your directory tree. So, check this first...
×