Jump to content

RicherD

Members
  • Content count

    19
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    RicherD
  • Website
  1. For the & redirection problems you can try this in: /includes/functions/general.php //// // Redirect to another page or site function tep_redirect($url) { if ( (strstr($url, "\n") != false) || (strstr($url, "\r") != false) ) { tep_redirect(tep_href_link(FILENAME_DEFAULT, '', 'NONSSL', false)); } if ( (ENABLE_SSL == true) && (getenv('HTTPS') == 'on') ) { // We are loading an SSL page if (substr($url, 0, strlen(HTTP_SERVER)) == HTTP_SERVER) { // NONSSL url $url = HTTPS_SERVER . substr($url, strlen(HTTP_SERVER)); // Change it to SSL } } /////////////// add this line below ///////////// $url = preg_replace('/&/','&',$url); ///////////////////////////////////////////////// header('Location: ' . $url); tep_exit(); } //// Not the most effecient way of doing it but it should do the trick.
  2. RicherD

    XHTML oscommerce available

    I've just tried this contrib, and it does work. You need to upload and run the patch in the folder above the "catalog" folder, ie: public_html/temp/catalog/ You would upload to the temp folder and execute it from there... seems with a few mods to the header tags the code validates.
  3. RicherD

    Browse by Categories

    Straider, Thanks for your speedy response - I've managed to remove the extra <TR>'s by commenting out the code you highlighted. On the site I'm using BBC 2.5, with icons set to "Image with Caption" and Sub Category links "off" - it's just a list of category images essentially. Seems the problem area was around: if ($arr_sub_category_mode[0] == 'right') { <SNIPPED> } else { $content_box_contents[$row + 1][$col] = array('align' => 'left', 'params' => 'class="smallText" valign="top" width="' . $table_cell_width . '"', 'text' => ($sub_category_links == '' && BRWCAT_SUBCAT_MODE != 'off') ? ' ' : $sub_category_links); I guess as you pointed out passing the triggers the new empty table row... I commented out those few lines and it works perfectly... Thanks again! :)
  4. RicherD

    Browse by Categories

    Hi All, First like to say thanks for the great mod - it's really a great enhancement over the default osC layout! I have a very slight problem that I can't seem to get to the bottom of - when using BBC with Sub-Category Link Mode set to "off" - I get a suprious table row underneath the main boxes - </tr> // begin here <tr> </tr> // end here </table> </td> </tr> </table> <!-- browse_categories_eof !--> Can anyone think of a reason why? Obviously it's not critial - just shows a annoying line I'd like to remove... Thanks
  5. Hi, I've installed the Big Images contribution on my site, and it works like a charm... My question - Is it possible to make the 'click to enlarge' link on the product info page appear *only* if a larger image is present? We don't have larger images for every product - therefore on some products the 'enlarge' link pops up with the small image again. I'm sure it's possible by adapting the product_info page, but it's quite tricky - was hoping someone out there had a 'canned' version ready to roll! Thanks :)
×