Jump to content

Matjaz

Members
  • Content count

    25
  • Joined

  • Last visited

Profile Information

Recent Profile Visitors

10,120 profile views
  1. Nothing is noted in administration and database. Ordering process stops on .../checkout_confirmation.php and warning appears : There was a problem processing the card. Please try again and if problems persist, please contact us or try another payment card or method.
  2. I have been using Braintree module for some years now. Just some days ago I set 3D secure in module. When I did this some troubles with payments appeared. I asked Braintree for help and they explained: I took a look at our server logs and found validation error 91585, Amount must match the 3D Secure authorization amount, is being returned from your integration. This error occurs when the amount specified when the customer is put through 3D Secure does not match the amount used for the actual transaction request.Below is a snippet of the parameters sent for one of the transactions that resulted in an error. "Parameters: {"transaction"=>{"type"=>"sale", "payment_method_nonce"=>"c58cdac7-00c6-1258-578f-e9c612fd507c", "amount"=>"5.30", "merchant_account_id"=>"mymerchantsi", "customer"=>{"first_name"=>"Boris" [...] Now here is a snippet of the 3D Secure request sent by your integration. "Parameters: {"amount"=>4.4, "braintreeLibraryVersion"=>"braintree/web/3.2.0", [...] During the 3D Secure authentication, an amount of €4.4 was authenticated. After the 3D Secure authentication, a transaction request of €5.30 was created, leading to the error. I checked the amounts of a few other requests that resulted in the same error and found that the amount is always off by 90 cents. Since you are using OSCommerce to integrate with Braintree, we do not have insight into the client-side code that specifies the amount of the 3D Secure or transaction requests as Braintree did not build that plug-in. I recommend reaching out to OSCommerce directly to see why the 3D Secure amount does not match the transaction's amount. Did anyone had such problems and how to fix them?
  3. In September in EU comes in action Strong Consumer Authentication (SCA). We will have to any change Braintree module because if it? https://www.braintreepayments.com/blog/getting-up-to-speed-on-psd2-regulation-2/?_ga=1.263201612.1986673433.1566304981
  4. I have last version of paypal appv5018. If a buyer makes his first shopping with paypal express without registration in osc store, buyers data do sign in from paypal in a database as we can see in a table customers. It saves also encrypted password. There are no problems in first shopping. But in the next shopping, when paypal page brings customer back on oscommerce login.php password from paypal is not correct and buyer has to, if he wants to sign in, go through a procedure as he is forgotten password (password_forgotten.php). When we make a reconstruction of a password (we put the same one as in paypal account) we are redirected while shopping to mypage/express.php?osC Action=retrieve token=EC-5C42...... instead of on mypage/checkout_confirmation. Did I miss something in admin settings, is there a problem in password encryption method?
  5. Matjaz

    ULTIMATE Seo Urls 5 - by FWR Media

    Some days ago I downloaded certificate TLS. Somehow I managed to make site work but I have a problem. If I have on Enable SEO URLs 5 while turning pages on product listing all web site crashes down. When I jump on next page I get url line "https://www.mydomain.comdir_wss_http_catalogcategoryname-c-341.html/?page=2&sort=2a"andbrowser comment ERR_NAME_NOT_RESOLVED​.When I turn module off SEO URL works fine. I deleted all cache. Whats wrong? my configure.php: ..... efine('HTTP_SERVER', 'https://www.mydomain.com'); define('HTTPS_SERVER', 'https://www.mydomain.com'); define('ENABLE_SSL', true); define('HTTP_COOKIE_DOMAIN', 'www.mydomain.com'); define('HTTPS_COOKIE_DOMAIN', 'www.mydomain.com'); define('HTTP_COOKIE_PATH', '/'); define('HTTPS_COOKIE_PATH', '/'); define('DIR_WS_HTTP_CATALOG', '/'); define('DIR_WS_HTTPS_CATALOG', '/'); ........etc and .htaccess: RewriteEngine On RewriteCond %{HTTPS} off RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L] # If you are getting errors you may need to comment this out like .. # Options +FollowSymLinks Options +SymLinksIfOwnerMatch <IfModule mod_rewrite.c> RewriteEngine On # RewriteBase instructions # Change RewriteBase dependent on how your shop is accessed as below. # http://www.mysite.com = RewriteBase / # http://www.mysite.com/catalog/ = RewriteBase /catalog/ # http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/ # Change RewriteBase using the instructions above RewriteBase / RewriteRule ^([a-z0-9/-]+)-p-([0-9]+).html$ product_info.php [NC,L,QSA] RewriteRule ^([a-z0-9/-]+)-c-([0-9_]+).html$ index.php [NC,L,QSA] RewriteRule ^([a-z0-9/-]+)-m-([0-9]+).html$ index.php [NC,L,QSA] RewriteRule ^([a-z0-9/-]+)-pi-([0-9]+).html$ popup_image.php [NC,L,QSA] RewriteRule ^([a-z0-9/-]+)-pr-([0-9]+).html$ product_reviews.php [NC,L,QSA] RewriteRule ^([a-z0-9/-]+)-pri-([0-9]+).html$ product_reviews_info.php [NC,L,QSA] # Articles contribution RewriteRule ^([a-z0-9/-]+)-t-([0-9_]+).html$ articles.php [NC,L,QSA] RewriteRule ^([a-z0-9/-]+)-au-([0-9]+).html$ articles.php [NC,L,QSA] RewriteRule ^([a-z0-9/-]+)-a-([0-9]+).html$ article_info.php [NC,L,QSA] # Information pages RewriteRule ^([a-z0-9/-]+)-i-([0-9]+).html$ information.php [NC,L,QSA] # Links contribution RewriteRule ^([a-z0-9/-]+)-links-([0-9_]+).html$ links.php [NC,L,QSA] # Newsdesk contribution RewriteRule ^([a-z0-9/-]+)-n-([0-9]+).html$ newsdesk_info.php [NC,L,QSA] RewriteRule ^([a-z0-9/-]+)-nc-([0-9]+).html$ newsdesk_index.php [NC,L,QSA] RewriteRule ^([a-z0-9/-]+)-nri-([0-9]+).html$ newsdesk_reviews_info.php [NC,L,QSA] RewriteRule ^([a-z0-9/-]+)-nra-([0-9]+).html$ newsdesk_reviews_article.php [NC,L,QSA] </IfModule>
  6. When I go Google webmasters and other statistic page, I see blank page with error 500 when I click broken link. Is this correct now?
  7. Rainer and other what is your opinion about this ? redirectCancelled=true with canonical on mobile page. Recomendation from Google is that rel=”canonical” tag on the mobile URL pointing to the desktop page is required. I checked some source of other web pages and they have on desktop and on mobile version the same cannonical. jack_mcs @ in mobile/header.php I added your add-ons Header Tags SEO. It worked but I moved it away because of caution and because there is so many unknown things around this. What do you think or suggest it makes sense at all that mobile version is connected to this your perfect addons that I am using from beginning for many years now?
  8. When I start from the mobile version I have lost from 20 to 100 positions on Google. I think that is the cause of this and incorrect settings robots. http://shrani.si/f/3V/XI/9U78On3/1/serp-checker1.png
  9. Google say:https://developers.google.com/webmasters/mobile-sites/mobile-seo/configurations/separate-urls
  10. Am I looking proper for KissIT_image_thumbnailer_r9? This I cannot find in my mobile file. I have osc 2.3.4 Thanks 1. in: mobile/product_info.php OsCommerce 2.3. 2 same entries: a. *** FIND line 73: $pi_entry .= '" target="_blank">' . tep_image(DIR_WS_IMAGES . $pi['image'], $product_info['products_name'], MOBILE_PRODUCT_IMAGE_WIDTH, MOBILE_PRODUCT_IMAGE_HEIGHT) . ''; *** CHANGE TO: $pi_entry .= '" target="_blank">' . tep_image(DIR_WS_IMAGES . $pi['image'], $product_info['products_name'], KISSIT_MAIN_PRODUCT_IMAGE_WIDTH/2, KISSIT_MAIN_PRODUCT_IMAGE_HEIGHT/2) . ''; b. *** FIND line 88: <?php echo '' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], addslashes($product_info['products_name']), MOBILE_PRODUCT_IMAGE_WIDTH, MOBILE_PRODUCT_IMAGE_HEIGHT) . ''; ?> *** CHANGE TO: <?php echo '' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], addslashes($product_info['products_name']), KISSIT_MAIN_PRODUCT_IMAGE_WIDTH/2, KISSIT_MAIN_PRODUCT_IMAGE_HEIGHT/2) . ''; ?> b. *** FIND line 192: $pi_entry .= '" target="_blank">' . tep_image(DIR_WS_IMAGES . $pi['image'], $product_info['products_name'], MOBILE_PRODUCT_IMAGE_WIDTH, MOBILE_PRODUCT_IMAGE_HEIGHT) . ''; *** CHANGE TO: $pi_entry .= '" target="_blank">' . tep_image(DIR_WS_IMAGES . $pi['image'], $product_info['products_name'], KISSIT_MAIN_PRODUCT_IMAGE_WIDTH/2, KISSIT_MAIN_PRODUCT_IMAGE_HEIGHT/2) . ''; 2. in: mobile/includes/modules/product_header.php OsCommerce 2.2. and OsCommerce 2.3 a. *** FIND: echo ' ' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], $product_info['products_name'], MOBILE_PRODUCT_IMAGE_WIDTH, MOBILE_PRODUCT_IMAGE_HEIGHT) . ' '; *** CHANGE TO: echo ' ' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], $product_info['products_name'], KISSIT_MAIN_PRODUCT_IMAGE_WIDTH, KISSIT_MAIN_PRODUCT_IMAGE_HEIGHT, '') . ' '; -------------------------------------------------------------------------------------------------------------- 3. in: mobile/includes/header.php *** FIND: ' . tep_image(DIR_WS_HTTP_MOBILE . DIR_MOBILE_IMAGES . 'store_logo.png', STORE_NAME) . ' *** CHANGE TO: ' . tep_image(DIR_WS_HTTP_MOBILE . DIR_MOBILE_IMAGES . 'store_logo.png', STORE_NAME, MOBILE_LOGO_WIDTH, MOBILE_LOGO_HEIGHT) . ' -------------------------------------------------------------------------------------------------------------- 4. in: includes/catalog_mb.php *** FIND (inside other code): $img = strlen($item['categories_image']) > 0 ? tep_image(DIR_WS_IMAGES . $item['categories_image'], $item['categories_name']) : tep_image(DIR_MOBILE_IMAGES . 'placeholder_trans.gif') ; *** CHANGE TO: $img = strlen($item['categories_image']) > 0 ? tep_image(DIR_WS_IMAGES . $item['categories_image'], $item['categories_name'], KISSIT_MAIN_PRODUCT_IMAGE_WIDTH/2, KISSIT_MAIN_PRODUCT_IMAGE_HEIGHT/2) : tep_image(DIR_MOBILE_IMAGES . 'placeholder_trans.gif') ; -------------------------------------------------------------------------------------------------------------- 5a. in: includes/configure.php *** FIND: // Width and height of the main product_info.php image define ( 'KISSIT_MAIN_PRODUCT_IMAGE_WIDTH', 300 ); define ( 'KISSIT_MAIN_PRODUCT_IMAGE_HEIGHT', 200 ); *** ADD BELOW: define ( 'MOBILE_LOGO_WIDTH', '' ); define ( 'MOBILE_LOGO_HEIGHT', 50 ); -------------------------------------------------------------------------------------------------------------- 5b. in: includes/configure.php NOTE: This modification works for mobile installation in subdirectory. If your mobile site is installed under subdomain leave the standard setting and try. If it doesn't work try another thumbnail add-on. *** FIND: (defined('MOBILE_SESSION') ? define('DIR_WS_IMAGES', HTTP_SERVER . DIR_WS_HTTP_CATALOG . 'images/') : define('DIR_WS_IMAGES', 'images/')); *** CHANGE TO: (defined('MOBILE_SESSION') ? define('DIR_WS_IMAGES', '../images/') : define('DIR_WS_IMAGES', 'images/'));
  11. I did not. Is this to http://addons.oscommerce.com/info/8578 ?
  12. I have a problem. I have version 2.3.4. and for some years also SEO Urls 5. If I don't delete application.php : /** * ULTIMATE Seo Urls 5 PRO by FWR Media */ Usu_Main::i()->setVar( 'languages_id', $languages_id ) ->setVar( 'request_type', $request_type ) ->setVar( 'session_started', $session_started ) ->setVar( 'sid', $SID ) ->setVar( 'language', $language ) ->setVar( 'filename', $PHP_SELF ) ->initiate( ( isset( $lng ) && ( $lng instanceof language ) ) ? $lng : array(), $languages_id, $language ); and until I dont delete in html_output.php; /** * ULTIMATE Seo Urls 5 PRO by FWR Media * Replacement for osCommerce href link wrapper function */ require_once DIR_WS_MODULES . 'ultimate_seo_urls5/main/usu5.php'; function tep_href_link( $page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = true ) { return Usu_Main::i()->hrefLink( $page, $parameters, $connection, $add_session_id, $search_engine_safe ); } my web site does not work properly in mobile way. When I add original not corrected html_output.php files mobile supplement: defined('MOBILE_SESSION') ? $mobile_directory = HTTP_MOBILE_SERVER . DIR_WS_HTTP_MOBILE : $mobile_directory = HTTP_SERVER . DIR_WS_HTTP_CATALOG; defined('MOBILE_SESSION') ? $mobile_secure_directory = HTTPS_MOBILE_SERVER . DIR_WS_HTTPS_MOBILE : $mobile_secure_directory = HTTPS_SERVER . DIR_WS_HTTPS_CATALOG; if ($connection == 'NONSSL') { $link = $mobile_directory; } elseif ($connection == 'SSL') { if (ENABLE_SSL == true) { $link = $mobile_secure_directory; } else { $link = $mobile_directory; mobile works without any problem. What I have missed? How to install SEO Urls 5 code that I had to delete so that SEO Urls 5 works again?
  13. Matjaz

    PayPal Standard - writes to db at checkout_payment

    PayPal express does not keep language of a web-store. I am using osCommerce Online Merchant in 2.3.4 and I have Paypal business account, I installed module of PayPal express /app-paypal-4_039/. My web store runs in two languages, Slovene (default) and English. If buyer chooses English language while shopping, paypal directs him back on checkout_confirmation in Slovene language and it doesn't matter which language I have in default in any browser. How to fix this?
  14. In account _history_info.php and print_my-invoice.php I have reference number for payment in which I would also like to put customer id. Code now looks like this: ...<td> <b><?php echo ENTRY_PAYMENT_METHOD; ?></b> <?php echo $order->info['payment_method']; ?></td> <td> <b><?php echo INVOICE_TEXT_REF ?></b> <?php echo date("y"); ?>-070-<?php echo $HTTP_GET_VARS['order_id']; ?></td> .... instead of fixed -070- I would like to have customer id that would look like this: year-customer_id-order_id
  15. Matjaz

    Header Tags SEO

    Yes, problem was in this. It work correctly only if Keyword Highlighter is off. In other two options of highlighter links do not work. Thank you.
×