JoshBowe

Members
  • Content count

    49
  • Joined

  • Last visited

Community Reputation

1 Neutral

1 Follower

About JoshBowe

Profile Information

  • Real Name
    Josh Bowe
  1. No, it's just the odd customer. It's happened twice in maybe a year or so, but even if it's very rare it can have bad consequences. Yes, SagePay returns to checkout_confirmation.php I believe but should maybe double check.
  2. Hi, this is a rare occurrence but it's happened a couple of times now and it's resulted in a customer not receiving their order. The module we are using is SagePay Form 1.2. What has happened is the customer has gone to place their order and checked out as normal, we've received the payment from the customer but order hasn't appeared on our admin orders page and the customers basket is still full of what they intended to buy. Has this ever happened to anyone else, and does anyone know a solution? Thanks.
  3. Hi everyone, I noticed that we'd been getting quite a lot of PayPal eCheque payments of late, this isn't a problem but it's often easy to miss that it's an eCheque as when paying using an eCheque the payment goes into the 'Pending' status along with all of the other fully completed payments. I was wondering if it was possible for just eCheque payments to be put into a status of their own 'Pending eCheques' automatically, then when the eCheque clears, for the status to be updated to 'Pending' so it goes in with the rest of the completed payments? If anyone has any ideas it would be appreciated. Thanks.
  4. Anyone have any idea why?
  5. Anyone got any ideas?
  6. Hi guys, I've read a few threads on this but all the problems/solutions were for 2.2 and wouldn't work with my 2.3.1 install. What is happening is, when a customer who doesn't have an account pays using the PayPal Express checkout, it's not including the second address line (the optional one). I've read this thread on it: http://forums.oscommerce.com/topic/345559-paypal-express-missing-address-line/ And their solution was to change 'suburb' => '', to 'suburb' => $response_array['SHIPTOSTREET2'], in ext/modules/payment/paypal/express.php, however this doesn't work in osCommerce 2.3.1. Is their a similar tweak for osCommerce 2.3.1 to fix this issue? Thank you.
  7. It's a shame as it works very well on a fresh install. :( There is a contribution for 2.2 that works with 2.3.1. The only thing you can't do is edit your billing/shipping address when you go to checkout.
  8. I had a go at installing this on my modified osCommerce, I found that it didn't work well because of how modified the template was. Here's a list of the files that I found were modified: account_history_info.php checkout_confirmation.php checkout_payment.php checkout_payment_address.php checkout_shipping.php checkout_shipping_address.php stylesheet.css includes/configure.php includes/footer.php includes/header.php includes/template_bottom.php includes/template_top.php There could be more files that were modified, but I couldn't find them if that was the case. If there's more files that are modified from standard, please let me know as I really want this working on my store. :)
  9. /catalog/ is just a typo. It should be uploaded to /admin/ as you assumed. The second one with the flag images is not a typo though.
  10. Hi guys, I'm getting a MySQL error when a customer visits the site and their location contains an apostrophe, such as: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ka Oblast'', 'Kharkov', '', '','/','/index.php','2012-02-23 11:36:33','2012-02-2' at line 1 INSERT INTO `supertracker` (`ip_address`, `browser_string`, `country_code`, `country_name`, `country_region`, `country_city`, `referrer`,`referrer_query_string`,`landing_page`,`exit_page`,`time_arrived`,`last_click`,`browser`) VALUES ('193.178.250.242','Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.56 Safari/535.11','ua', 'Ukraine', 'Kharkivs'ka Oblast'', 'Kharkov', '', '','/','/index.php','2012-02-23 11:36:33','2012-02-23 11:36:33','Safari') [TEP STOP] Has anyone got a solution? Thanks.
  11. Hi, I'm having a bit of a problem with order_editor for osCommerce 2.3. The contribution itself works great, however when a customer enters an address with an apostrophe in it, for example "Val D'Oise" I get the following mySql error: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Oise' OR zone_code = 'Val D'Oise')' at line 1 select zone_id from zones where zone_country_id = '73' and (zone_name = 'Val D'Oise' OR zone_code = 'Val D'Oise') [TEP STOP] I'm not so hot on PHP, but is there any way I can stop names/addresses with an apostrophe in them causing this error? Thanks. :)
  12. Hi, Just installed PHPIDS on 2.3.1 and can't seem to get it to work. As soon as I turn it on through the admin control panel my website front page just won't load. :( I've followed the steps exactly as they are in the install guide, my "phpids" file was uploaded to website.com/includes/phpids without the catalog part. Could that be causing the problem? Otherwise I did everything as it said. Any help would be appreciated, cheers.