Latest News: (loading..)

alsmith

Members
  • Content count

    143
  • Joined

  • Last visited

1 Follower

About alsmith

Profile Information

  • Real Name
    Al Smith
  • Location
    Kennesaw, Georgia
  1. I just installed it and all works but I do not see a discount applied anywhere when I go to check out.
  2. With a new install of osc I completed the install and all went well until I select the "Choose File" in the product editor. The popup errors with Forbidden You don't have permission to access /osc/admin/includes/filebrowser/index.php on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. I checked the permissions on the index.php in the filebrowser folder as well as the folder itself. they are the same as all other index.php files in oscommerce install. The website comes up and so does the admin, What else to check. I FOUND THIS in the .htaccess file in the admin/includes folder #<Files *.php> #Order Deny,Allow #Deny from all #</Files>
  3. I tried a brand new install also and the AIM method will not work however the SIM does work. I tested curl using (from SSH) curl https://secure.authorize.net and get the proper return so I do no think it is a curl or server issue. #curl https://secure.authorize.net <html> <HEAD><TITLE>Authorize.Net</TITLE> <META NAME="Authorize.Net -- Enabling more businesses to process transactions wor ldwide"> </HEAD> <FRAMESET ROWS="100%,*" BORDER=0 FRAMEBORDER=0 FRAMESPACING=0> <FRAME NAME="top" SRC="https://Account.authorize.net/ui/themes/anet/merch.app" NOR ESIZE> </FRAMESET> </HTML> Looking for help also.
  4. Think I found it looking into the code includes/modules/sts_inc I needed to use $cataloglogo and also place my image into the templatefolder/images/english since the general.php has the language folder referenced I also needed to name the image header_logo.gif and not store_logo.png So I ended up with putting $cataloglogo instead of <img border="0" src="images/store_logo.png"> in the template (sts_template.html of index.php.html in my case) and also created the image and placed it in includes/sts_templates/test/images/english naming it header_logo.gif to match the code $sts->template['cataloglogo'] = '<a href="' . tep_href_link(FILENAME_DEFAULT). '">' . tep_image(STS_TEMPLATE_DIR.'images/'.$language . '/header_logo.gif', STORE_NAME) . '</a>'; // Modified in v4.3 Great contribution.
  5. I posted question in http://forums.oscommerce.com/index.php?showtopic=285293 (working from this post now sorry) I have uploaded the html_output.php into the includes/functions (after trying to edit by hand) Same status, I placed the logo in the template folder/images and it does not appear on the site. I moved the origional from the /images to keep it from appearing also. Am I reading this right that I should be putting my images in the templatefolder/images for this to work.
  6. I am trying to take advantage of images in the template folder using this step in the installation: 2.6.7 includes/functions/html_output.php Note: the modifications in this file allows to use images located in the templates folder instead of the in the original catalog/images folder. This is done by checking if the image exists or not in the templates folder, and to use it if yes. If you are not going to use this feature, you don't need to modify this file Find: function tep_image($src, $alt = '', $width = '', $height = '', $parameters = '') { Add after: // START STS v4.4: global $sts; $sts->image($src); // Take image from template folder if exists. // END STS v4.4 I take it the Add after goes within the function between the { and } If I put it after the function I get Fatal error: Call to a member function on a non-object in /home/ugi/public_html/shop/includes/functions/html_output.php on line 116 however if I put it function tep_image($src, $alt = '', $width = '', $height = '', $parameters = '') { // START STS v4.4: global $sts; $sts->image($src); // Take image from template folder if exists. // END STS v4.4 if ( (empty($src) || ($src == DIR_WS_IMAGES)) && (IMAGE_REQUIRED == 'false') ) { return false; } // alt is added to the img tag even if it is null to prevent browsers from outputt ing // the image filename as default $image = '<img src="' . tep_output_string($src) . '" border="0" alt="' . tep_o utput_string($alt) . '"'; if (tep_not_null($alt)) { $image .= ' title=" ' . tep_output_string($alt) . ' "'; } if ( (CONFIG_CALCULATE_IMAGE_SIZE == 'true') && (empty($width) || empty($heigh t)) ) { if ($image_size = @getimagesize($src)) { if (empty($width) && tep_not_null($height)) { $ratio = $height / $image_size[1]; $width = intval($image_size[0] * $ratio); } elseif (tep_not_null($width) && empty($height)) { $ratio = $width / $image_size[0]; $height = intval($image_size[1] * $ratio); } elseif (empty($width) && empty($height)) { $width = $image_size[0]; $height = $image_size[1]; } } elseif (IMAGE_REQUIRED == 'false') { return false; } } if (tep_not_null($width) && tep_not_null($height)) { $image .= ' width="' . tep_output_string($width) . '" height="' . tep_output _string($height) . '"'; } if (tep_not_null($parameters)) $image .= ' ' . $parameters; $image .= '>'; return $image; } Then in my template folder I place my own store_logo.png the template system does not seem to pick it up, still using the one in the catalog/images folder has anyone accomplished this.
  7. Multi-Stores with current version osCommerce Online Merchant v2.2 Release Candidate 1 Has anyone installed this recently with osCommerce Online Merchant v2.2 Release Candidate 1 I am stating after reading this thread for a whiile.
  8. I get when I enter a valid login and password. 1054 - Unknown column 'createaccount' in 'where clause' select customers_id, customers_firstname, customers_password, customers_email_address, customers_default_address_id from customers where customers_email_address = 'al@heretohost.com'AND createaccount='Y'
  9. I have a new install of osCommerce, Can I just drop this contribution into place? Also, will this work with the STS template system.
  10. What do you need to download here tohave the latest greatest for this contribution? Does anyone have it packaged as a single zip? http://www.oscommerce.com/community/contributions,1524
  11. Just download the newest OSC then installed. Tested and worked as advertised. Then I download the STS Template System and installed using METHOD ----------------------------------------------------------------------------- HOW TO INSTALL (EASY): ----------------------------------------------------------------------------- Install a clean version of the osCommerce Milestone 2.2 Release (OSC 2.2MS2), run the install program and verify that everything works. (If you have already added other contributions, it may not work the Easy way and you may have to use the Advanced method. Then copy the following files into your /catalog/includes directory. application_top.php header.php column_left.php column_right.php footer.php application_bottom.php sts_start_capture.php sts_stop_capture.php sts_restart_capture.php sts_display_output.php sts_user_code.php sts_template.html configure-SAMPLE.php <----- See note below! <--------- NOTE: configure-SAMPLE.php is included in the ZIP file, but you will have to reenter all your configuration settings if you use it. It is easier to just add the STS lines at the bottom of the file to the bottom of your existing /catalog/includes/configure.php file. Add these lines to your /catalog/includes/configure.php script. These lines should go before the final line with the ?> characters on it. // STS: ADD: Define Simple Template System files define('STS_START_CAPTURE', DIR_WS_INCLUDES . 'sts_start_capture.php'); define('STS_STOP_CAPTURE', DIR_WS_INCLUDES . 'sts_stop_capture.php'); define('STS_RESTART_CAPTURE', DIR_WS_INCLUDES . 'sts_restart_capture.php'); define('STS_TEMPLATE_DIR', DIR_WS_INCLUDES . 'sts_templates/'); define('STS_DEFAULT_TEMPLATE', DIR_WS_INCLUDES . 'sts_template.html'); define('STS_DISPLAY_OUTPUT', DIR_WS_INCLUDES . 'sts_display_output.php'); define('STS_USER_CODE', DIR_WS_INCLUDES . 'sts_user_code.php'); define('STS_PRODUCT_INFO', DIR_WS_INCLUDES . 'sts_product_info.php'); // STS: EOADD And now I get this error: Fatal error: Cannot instantiate non-existent class: currencies in /home/joanw/public_html/catalog/includes/application_top.php on line 258 complaining about currencies -Al
  12. I have a customer that is offering a FREE download product and we are noticing that people are over and over processing a new order to download the same FREE download. Is there a way to determine if this person has previously ordered the FREE download to inform them they have already purchased the product or to limit their ordering of the same product over and over. They really only need one FREE download since it is the same product each time they place an order. I know frustrated once again, but I am sure there is a solution.
  13. Absolutely, the origional gave both the ability but I modified it just allowing the extras to get the link. The person using the link will need the a admin login and password. You cannot keep them out with this if they are smart enough to change the URL. These people all work for me and may have need anyway. You can make diff logins if you wish.
  14. Just uploads a small contribution that allows you to place a link to Print Invoice in the email that the Send Extra Order Emails To recieves. I use this to allow my shipper to include the invoice with the shipment. http://www.oscommerce.com/community/contributions,1488 -Al
  15. I have a script I get the full list of contributions, see http://heretohost.com/os.html Just what descriptions can we get. This script provides the full list with the link to the contribution. I use it to help in my searches. DO not have it ready for a contribution at this time but you can check it out.