Jump to content

nobodyfamous

Members
  • Content count

    103
  • Joined

  • Last visited

  • Days Won

    1

nobodyfamous last won the day on July 20 2012

nobodyfamous had the most liked content!

1 Follower

Profile Information

  • Real Name
    Chad Meyers
  1. nobodyfamous

    Canada Post Automatic Labels

    I didn't look at your code, but try this http://addons.oscommerce.com/info/8887
  2. nobodyfamous

    canada post XML parsing error (GoDaddy)

    SOLVED!!! turns out it was a session error. the osCid was being passed in the URL all the time, and this began blocking the AJAX from getting the right session values, ex. cartID.
  3. nobodyfamous

    canada post XML parsing error (GoDaddy)

    I turned on full error reporting and get ideas?
  4. nobodyfamous

    canada post XML parsing error (GoDaddy)

    I have further refined the problem to an empty array. again, at the top of the page, AKA at the time of loading this arry is right $products_array = $cart->get_products(); Array ( [0] => Array ( [id] => 291{2}4 [name] => All Canadian Farmer men’s tee [model] => [image] => All Canadian Farmer.PNG [price] => 22.9900 [quantity] => 1 [weight] => 1.54 [length] => 11.50 [width] => 9.00 [height] => 9.00 [ready_to_ship] => [final_price] => 22.99 [tax_class_id] => 1 [attributes] => Array ( [2] => 4 ) )) Yet down the page (I assume, is after it is refreshed via AJAX) I get this for the same array array() It is empty. Why is that?
  5. nobodyfamous

    canada post XML parsing error (GoDaddy)

    why might this be happening? I added the line print_r($this->quotes); just before return $this->quotes; in the canadapost.php function quote so I could see what is being returned. At the very top of the site, before any code is output I get this (which is correct) Array ( [id] => canadapost [module] => Canada Post [1 box(es) to be shipped]<br>medium - 6.55(kg) [methods] => Array ( [0] => Array ( [id] => Priority [title] => Priority, <acronym title='Estimated Delivery Date'>EDD</acronym>: February 24, 2014 [cost] => 27.32 ) [1] => Array ( [id] => Expedited [title] => Expedited, <acronym title='Estimated Delivery Date'>EDD</acronym>: February 25, 2014 [cost] => 13.72 ) [2] => Array ( [id] => Regular [title] => Regular, <acronym title='Estimated Delivery Date'>EDD</acronym>: February 26, 2014 [cost] => 13.72 ) ) [icon] => <br><img src="images/icons/shipping_canadapost.gif" width="145" height="37" border="0" alt="Canada Post" title="Canada Post"> ) But, then what is just below the title Shipping Method I get Array ( [module] => Canada Post [error] => XML parsing error. <br>If you prefer to use canadapost as your shipping method, please contact the Bits N Bridles via <a href="mailto:info@bitsnbridles.ca"><u>Email</u></a>. [icon] => <br><img src="images/icons/shipping_canadapost.gif" width="145" height="37" border="0" alt="Canada Post" title="Canada Post"> )
  6. nobodyfamous

    canada post XML parsing error (GoDaddy)

    so GoDaddy's response was useless. So back to my issue. . . any ideas?
  7. nobodyfamous

    canada post XML parsing error (GoDaddy)

    still waiting on GoDaddy - I mirrored the site to my custom server, out there on the internet, and had the same problem. So I downloaded all the files again and ran them through a file compare program. The files are identical. . . :wacko:
  8. nobodyfamous

    canada post XML parsing error (GoDaddy)

    I have opened a support ticket to see. The site has been fine for the last 6 months or so. . .
  9. nobodyfamous

    Troubles with shipping module

    not sure if you created your zone right. goto Locations / Taxes -> Tax Zones click insert enter the name and description you want. ex. Netherlands, click Save now click on the name of the zone you just created click on insert Select Country: Netherlands & Zone: All Zones Now when you set the shipping zone as Netherland (or whatever you called it) that option will only be available to those who are in the zones in the zone. Its confusing, but will make sense once you go through it.
  10. this site http://www.bitsnbridles.ca/ is live. All of a sudden the Canada Post shipping module is not working. It works on my local MAMP fine. (I hate GoDaddy, but it's where the client has the site) I have tracked the error down as far as where XML data is missing. In /includes/modules/shipping/canadapost.php around line 244 the function _canadapostGetQuote() is not returning any data for the lines inside <lineItems> Further it would seem that the function (around line 190) _addItem ($quantity, $rate, $weight, $length, $width, $height, $description, $ready_to_ship) is not being called. again, the $canadapostQuote array is full at the top of the page, but empty when the module is displayed. I am lost, this only happens on the GoDaddy Server. Any ideas?
  11. nobodyfamous

    Canada Post Automatic Labels

    It seems as though Canada Post is offering the old Sell Online Accounts again - I still think it would be better to have a working REST module though.
  12. nobodyfamous

    Canada Post Automatic Labels

    Does anyone have anything to share/download I would love to start from a good base and begin building a new 2.3.3 Canada Post shipping module and integrate some of the great features seen on modules like UPSXML with dimensional shipping support, per item exclusions etc. I am on no position to build something from scratch though. . . As an open source user, it would also be offered as open source. Anything would be of value. you can email me echo "chad".'@'."noboyfamous".".ca";
  13. nobodyfamous

    [Addon] Categories Accordion Box for 2.3.1

    I just downloaded the lates full package, and it contains a few errors 1. It will not install - I had to download the "icon_selectro.php fix" version and replace the file 2. The sql query contains a c.retail = '1' This is not part of the stock 2.3.3 osC. I simply had to delete the line in 2 places in the getData() function.
  14. @@g2777 thanks for the heads up on better checkout - I like it, already sent an email. This one page is way too buggy. Next time around I think I will look into some other carts - there are so many options. I hope 3.0 will be much better! I have been using osC for a long time now, but every cart just never seems to be finished. . .
  15. so I came up with a total hack to temporaray fix my issue. Is no one else having the same issue with addresses not poulating? All I can figure is happening is after you "create a new account" the $customer_id is being populated with a number, but $sendto and $billto are remaining empty, but are required for the lines; tep_address_label($customer_id, $sendto, true, ' ', '<br />'); and tep_address_label($customer_id, $billto, true, ' ', '<br />'); So my hack was to insert this around line 530 before the template_top.php is included. if(isset($customer_id) && !isset($sendto)) echo '<meta http-equiv="refresh" content="0">'; // hack to fix missing addresses This sucks, but works for now. I feel the error is that the address handeling code is being skipped, or loaded too soon. I do not understand and have not looked at the functions yet for tep_session_is_registered(), & tep_session_register() Any Ideas?
×