Jump to content

skylinemarket

Members
  • Content count

    4
  • Joined

  • Last visited

Posts posted by skylinemarket


  1. Can anyone please help!!

     

    My admin/includes/boxes/catalog.php file looks like this:

     

    <?php
    /*
     $Id: catalog.php 1739 2007-12-20 00:52:16Z hpdl $
     osCommerce, Open Source E-Commerce Solutions
     http://www.oscommerce.com
     Copyright (c) 2002 osCommerce
     Released under the GNU General Public License
    */
    ?>
    
    <!-- catalog //-->
    	  <tr>
    		<td>
    <?php
     $heading = array();
     $contents = array();
     $heading[] = array('text'  => BOX_HEADING_CATALOG,
    				 'link'  => tep_href_link(FILENAME_CATEGORIES, 'selected_box=catalog'));
     if ($selected_box == 'catalog') {
    $contents[] = array('text'  => '<a href="' . tep_href_link(FILENAME_CATEGORIES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS . '</a><br>' .
    							   '<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' .
    							   '<a href="' . tep_href_link(FILENAME_MANUFACTURERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_MANUFACTURERS . '</a><br>' .
    							   '<a href="' . tep_href_link(FILENAME_REVIEWS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_REVIEWS . '</a><br>' .
    							   '<a href="' . tep_href_link(FILENAME_SPECIALS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_SPECIALS . '</a><br>' .
    							   '<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a>');
    }
     $box = new box;
     echo $box->menuBox($heading, $contents);
    ?>
    		</td>
    	  </tr>
    <!-- catalog_eof //-->
    

     

    whereas the file included implies it should look like this!

     

    <?php
    /*
     $Id$
     osCommerce, Open Source E-Commerce Solutions
     http://www.oscommerce.com
     Copyright (c) 2010 osCommerce
     Released under the GNU General Public License
    */
     $cl_box_groups[] = array(
    'heading' => BOX_HEADING_CATALOG,
    'apps' => array(
      array(
    	'code' => FILENAME_CATEGORIES,
    	'title' => BOX_CATALOG_CATEGORIES_PRODUCTS,
    	'link' => tep_href_link(FILENAME_CATEGORIES)
      ),
      array(
    	'code' => FILENAME_PRODUCTS_ATTRIBUTES,
    	'title' => BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES,
    	'link' => tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES)
      ),
      array(
    	'code' => FILENAME_MANUFACTURERS,
    	'title' => BOX_CATALOG_MANUFACTURERS,
    	'link' => tep_href_link(FILENAME_MANUFACTURERS)
      ),
      array(
    	'code' => FILENAME_REVIEWS,
    	'title' => BOX_CATALOG_REVIEWS,
    	'link' => tep_href_link(FILENAME_REVIEWS)
      ),
      array(
    	'code' => FILENAME_SPECIALS,
    	'title' => BOX_CATALOG_SPECIALS,
    	'link' => tep_href_link(FILENAME_SPECIALS)
      ),
      array(
    	'code' => FILENAME_PRODUCTS_EXPECTED,
    	'title' => BOX_CATALOG_PRODUCTS_EXPECTED,
    	'link' => tep_href_link(FILENAME_PRODUCTS_EXPECTED)
      ),
      array(
    	'code' => FILENAME_SPECIALSBYCAT,
    	'title' => BOX_CATALOG_SPECIALSBYCAT,
    	'link' => tep_href_link(FILENAME_SPECIALSBYCAT, '', 'NONSSL')
      )
    )
     );
    ?>
    

     

     

    I get a 500 server error if I try and edit the top section of code to include the missing array, and if I upload the bottom bit of code instead the catalog part of the admin box just doesn't appear !

     

    Somebody please help! I am running v2.2 RC2 if that is the issue??


  2. Hi, I seem to be getting an error with this part of the instructions:

     

     

    2. In admin/includes/boxes/catalog.php add: with the last declared

     

    array(

    'code' => FILENAME_SPECIALSBYCAT,

    'title' => BOX_CATALOG_SPECIALSBYCAT,

    'link' => tep_href_link(FILENAME_SPECIALSBYCAT, '', 'NONSSL')

    )

     

     

    Here is my catalog.php but I don't know where to put it:

     

    -------------

     

    <?php

    $heading = array();

    $contents = array();

     

    $heading[] = array('text' => BOX_HEADING_CATALOG,

    'link' => tep_href_link(FILENAME_CATEGORIES, 'selected_box=catalog'));

     

     

    if ($selected_box == 'catalog') {

    $contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_CATEGORIES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_MANUFACTURERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_MANUFACTURERS . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_REVIEWS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_REVIEWS . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_SPECIALS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_SPECIALS . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a>');

     

     

    }

     

    $box = new box;

    echo $box->menuBox($heading, $contents);

     

    ?>

    -------------

     

    Many thanks.


  3. Hi,

     

    New user, so please be gentle!

     

    In the instructions it says: Run the included google_xml_sitemap_seo.sql file using phpmyadmin.

     

    I have created a new db and attempted to import the .sql file using phpmyadmin but get the following error:

     

     

     

     

    Thanks.

     

    Without wanting to sounds like a total noob, could someone explain what is meant in the instructions by:

     

    "Run the included google_xml_sitemap_seo.sql file using phpmyadmin."


  4. Hi,

     

    New user, so please be gentle!

     

    In the instructions it says: Run the included google_xml_sitemap_seo.sql file using phpmyadmin.

     

    I have created a new db and attempted to import the .sql file using phpmyadmin but get the following error:

     

     

    Error

    SQL query:

     

    INSERT INTO configuration_group( configuration_group_id, configuration_group_title, configuration_group_description, sort_order, visible )

    VALUES (

     

    '289', 'Google XML SEO', 'Google XML Sitemap SEO Options', '29', '1'

    );

     

    MySQL said:

     

    #1146 - Table 'web101-skyline.configuration_group' doesn't exist

     

    Thanks.

×