Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

mvanderhoff

Members
  • Content count

    80
  • Joined

  • Last visited

Posts posted by mvanderhoff


  1. Having a rather weird problem on one of my ecommerce websites.

     

    The first one (indicated by threaddoctor-paypal.jpg) correctly pushes the selected shipping to PayPal and shows even before logging in.

     

    However, on our second ecommerce website this does not happen as shown by picture mtnb-paypal.jpg. Even before logging it will only show the Item total and no shipping.

     

    Then when you log in it appears to quickly show you the selected shipping method from the ecommerce website (shown in mtnb-paypal2.jpg)

     

    But then quickly reverts to the lowest shipping cost (shown in mtnb-paypal3.jpg)

     

    Any suggestions would be greatly appreciated.

     

    Also these two websites use the same PayPal account for processing so it shouldnt be anything to do with the internal settings of the PayPal account.

     

    Thank you in advance for any information or suggestions.

    post-290961-0-92404400-1413556038_thumb.jpg

    post-290961-0-81722600-1413556046_thumb.jpg


  2. Dears,

    Now USPS can work, but no weight display 0.00 lbs , only display like the following . would you please help to give suggestion? All setting is okay from admin now.

     

    United States Postal Service (1 pkg, 0.00 lbs total)

     

    Did you adjust settings or add another addon after yours was working?

     

    No issues on my site at all.


  3. I am using osCommerce 2.3.3 (used to be osCommerce 2.3.1) and PayPal Payments Advanced is not working.

     

    It was an easy installation and followed the steps provided by PayPal's YouTube video; also found that some of that information was wrong and corrected it.

     

    However, upon receiving an order it completes the transaction but there is no information shown on the osC 2.3.3 order page nor do we (or the customer) receive a notification that order was processed.

     

    We are using PayPal Payments Pro currently which works fantastic but would love to be able to use the PayPal Payments Advanced because we do not use a virtual terminal to do transactions.

     

    Any help is greatly appreciated!


  4. I can't imagine why it would work and then stop if no other changes were made. There is a javascript error in IE when the arrow is clicked so maybe there is some error in the code, though I don't see it.

     

    Figured it out.

     

    Someone removed the sitemap.js out of the <catalog root>/javascript folder


  5. All of a sudden the Sitemap SEO product add-ons do not work (ie: Related Products & Related Manufactures)

     

    When you click on them they do not expand.

     

    There has not been any add-ons except for new products and manufactures but no source code edits.

     

    You can take a look here - http://www.emergencyoutdoors.com/flashlights-fenix-ld10-led-flashlight-p-74.html

     

    Also the Sitemap is perfectly fine when you click on Hide / Show Products


  6. I installed CKEditor and noticed it was adding <p>'s all over my product descriptions when I went into Source.

     

    I would rather have it do <br> or <br /> instead.

     

    I found code here: http://stackoverflow.com/questions/1977791/turn-off-enclosing-p-tags-in-ckeditor-3-0

     

    And placed the code

     

    <script type="text/javascript" src="/js/ckeditor/ckeditor.js"></script>
    <script type="text/javascript" src="/js/ckeditor/adapters/jquery.js"></script>
    <script type="text/javascript">
    $(function() {
       $('#your_textarea').ckeditor({
           toolbar: 'Full',
           enterMode : CKEDITOR.ENTER_BR,
           shiftEnterMode: CKEDITOR.ENTER_BR
       });
    });
    </script>

     

    Within the Admin - Includes - Template Top PHP file.

     

    Any other suggestions to rectify this problem?


  7. Check the Default Title in Page Control for index.php.

     

    Okay I see that but maybe I was not clear about what I am trying to accomplish.

     

    In Index.php you can enter the Title, Keywords, Description, Logo Text it shows the Title, Keywords, Description and Logo Text on the main page http://www.yourdomain.com/index.php

     

    But what I want is to have the Categories show <Categories> + <New Text Ending>

     

    In example - Index.php title is: Emergency Outdoors - Outdoor, Camping, Survival and Preparedness Gear

     

    When I check Categories - 1 it will show <Category> Emergency Outdoors - Outdoor, Camping, Survival and Preparedness Gear

     

    But what I want it to show when you are looking at a Category is <Category> - Emergency Outdoors and that is it, not additional - Outdoor, Camping, Survival and Preparedness Gear.

     

    Is that possible?


  8. On my own personal oscommerce page that I sell a few items having issues with the Categories.

     

    My store uses categories_listing.php an categories_nested.php for Categories but when I edit those within Header Tags SEO inside the Control Panel it does not change them.

     

    Changing the Title/Description/Keywords within Categories/Products for the appropriate category it changes it but I want the ability to add the Default Title to the Category string without having to add it manually so it wont affect the Breadcrumbs.

     

    Similar to how you can add Default Title to the end of a product title within Products.php in the Header Tags SEO page and it will not effect the breadcrumbs but will show up in the Title of the page.

     

    Thanks in advance.


  9. It sounds like there is an installation problem. All I can suggest is that you upgrade it to the latest version and go from there.

     

    Thanks Jack. Will do the full upgrade on the code and see what happens.

     

    This is why developers should backup! Really wish the old developer had a backup :(


  10. Okay I got the index.php to work properly.

     

    But now the inputted data into index.php within Header Tags SEO in the Administration shows in Product_Info.php, even if I change Product_Info.php fields within the Header Tags SEO Admin section.

×