Jump to content

webmasterpitoyo

Members
  • Content count

    30
  • Joined

  • Last visited

Everything posted by webmasterpitoyo

  1. webmasterpitoyo

    [Contribution] Option Types v2

    Helo @@Tsimi kindly ask your opinion.. is this addon somehow can work together with the modular product page addon http://addons.oscommerce.com/info/9453 ? or is it too long way to go? rgds, pit
  2. @@Tsimi oh OK... I saw that at the expires_date row... Null column is set to Yes I think its OK then thanks, rgds pit
  3. @@Tsimi actually I dont really understand what your question mean .. this attached I show you the dump sgl file for featured table.. -- phpMyAdmin SQL Dump -- version 4.0.10.14 -- http://www.phpmyadmin.net -- -- Host: localhost:3306 -- Generation Time: Jul 13, 2016 at 09:32 PM -- Server version: 5.6.30 -- PHP Version: 5.4.31 SET SQL_MODE = "NO_AUTO_VALUE_ON_ZERO"; SET time_zone = "+00:00"; CREATE TABLE IF NOT EXISTS `featured` ( `featured_id` int(11) NOT NULL AUTO_INCREMENT, `products_id` int(11) NOT NULL DEFAULT '0', `featured_date_added` datetime DEFAULT NULL, `featured_last_modified` datetime DEFAULT NULL, `expires_date` datetime DEFAULT NULL, `date_status_change` datetime DEFAULT NULL, `status` int(1) DEFAULT '1', PRIMARY KEY (`featured_id`), KEY `idx_products_id` (`products_id`) ) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci AUTO_INCREMENT=12 ; INSERT INTO `featured` (`featured_id`, `products_id`, `featured_date_added`, `featured_last_modified`, `expires_date`, `date_status_change`, `status`) VALUES (9, 51, '2016-07-13 14:37:16', '2016-07-13 21:13:01', NULL, NULL, 1), (10, 54, '2016-07-13 16:52:11', NULL, NULL, NULL, 1), (11, 61, '2016-07-13 21:12:51', NULL, NULL, NULL, 1); rgds, pit
  4. I check the database for last success simulaton resulting NULL in field expres_date
  5. Dear @@Tsimi I tried your suggestion above changing line 36 and 53.. but both not work.. still error coming whether it is a new featured product or updating the expiry date.. I just try my way (only I dont now if this changing is a good solution or not), with: on line 42 tep_db_query("insert into featured (products_id, featured_date_added, expires_date, status) values ('" . $_POST['products_id'] . "', now(), '" . $expires_date . "', '1')"); change with tep_db_query("insert into featured (products_id, featured_date_added, expires_date, status) values ('" . $_POST['products_id'] . "', now(), " . (tep_not_null($expires_date) ? "'" . tep_db_input($expires_date) . "'" : 'null') . ", '1')"); and for updating on line 54 tep_db_query("update featured set featured_last_modified = now(), expires_date = '" . $expires_date . "' where featured_id = '" . $_POST['featured_id'] . "'"); change with tep_db_query("update featured set featured_last_modified = now(), expires_date = " . (tep_not_null($expires_date) ? "'" . tep_db_input($expires_date) . "'" : 'null') . " where featured_id = '" . $_POST['featured_id'] . "'"); with this changing.. I try to simulate for a new featured product or an updating with an empty expiry date, both is working fine.. pls comment for this, thanks, rgds, pit
  6. sorry.. I am not try yet this change.. I have something to do first.. back maybe in some hours.. rgds, pit
  7. dear @@Tsimi yes! for a new featured product.. this solution is solve.. but I try for an updating one featured product and revise expiry date with an empty fill, there is an error: ---- 1292 - Incorrect datetime value: '' for column 'expires_date' at row 1 update featured set featured_last_modified = now(), expires_date = '' where featured_id = '9' [TEP STOP] ------ thanks, rgds, pit
  8. dear @@Tsimi Im sorry maybe Im still in 'elementery school' for this php things :) , but I just comparing the file between catalog/admin/featured.php (from this add on) and catalog/admin/specials.php (from native osc2.3.4 BS edge).. there is a different script for handling inserting value to the db table for expiry date (I put it on bold): in featured.php: tep_db_query("insert into featured (products_id, featured_date_added, expires_date, status) values ('" . $_POST['products_id'] . "', now(), '" . $expires_date . "', '1')"); in specials.php: tep_db_query("insert into " . TABLE_SPECIALS . " (products_id, specials_new_products_price, specials_date_added, expires_date, status) values ('" . (int)$products_id . "', '" . tep_db_input($specials_price) . "', now(), " . (tep_not_null($expires_date) ? "'" . tep_db_input($expires_date) . "'" : 'null') . ", '1')"); does it have any correlation with the error I get? kindly advise, thanks, rgds, pit
  9. @@Tsimi .. tx for the info.. I try to uninstall v1.1 and install the new v1.2... still everythin ok when I put some expiry date for assign featured product.. but when I leave it empty still the error message coming... maybe its not about this addon.. still try to figure it out.. maybe conflicting with other addon.. anyway, thanks for your kind support.. rgds, pit
  10. @@Tsimi , tx for the respons If I leave the expiry date empty, then the whole admin page become blank and get the error: --------------- 1292 - Incorrect datetime value: '' for column 'expires_date' at row 1 insert into featured (products_id, featured_date_added, expires_date, status) values ('39', now(), '', '1') [TEP STOP] ------------------ I use the OSC 2.3.4 BS Edge download at jun 2016. thanks, rgds, pit
  11. hello @@Tsimi what am I supposed to fill in Expiry date for Featured Product if I want to make some product will featured forever. I try to put it blank like we use to do in special product but some error message coming.. rgds, pit
  12. webmasterpitoyo

    [Addon] Modular Product Page (Bootstrap)

    thanks Jim, I just try this addon also at the GOLD version, but the same thing happen... product title not showing at the browser tag, and also I just found out that the product name also not shows at the breadcrumb trail regards, pit
  13. webmasterpitoyo

    [Addon] Modular Product Page (Bootstrap)

    the special price seems OK using @@katapofatico 's suggestion at the first place .. thanks.. one thing that still missing is the product tittle.. seems like these module make the Product Tittle module on header tags does not works... so when I show product page we cannot see product name on a tittle at a browser tag Is there any solution for this? rgds pit
  14. helo @@auzStar, Im installing this addon v1.1.. only if the product has a special price,.. it is only shows the new price... I think put the original price with strikethrough above new price like it used to be is more attractive for costumer. rgds, pit
  15. webmasterpitoyo

    [Addon] Modular Product Page (Bootstrap)

    Dear @@kymation @@katapofatico just asking is there any fix solution about special price bug above? I just installed this addon ver1.1 but resulting 0,- price for a product with a specials price thanks, rgds. pit
  16. helo @@auzStar I like the appearance of the carousel .. even I think with jQuery Owl Carousel give a better handling especially in smartphone or tablet view. I just wonder that the 'Featured product carousel' idea will use the jQuery Owl Carousel also. I think the idea of featured product in front page is something that we all need. There is an addon available in http://addons.oscommerce.com/info/9439 .. but I hope there will be a jQuery Owl Carousel version for a better look.. thanks, pit
  17. webmasterpitoyo

    [Addon} Modular Front Page

    Dear @@kymation I just installed the modul.. everything's fine except that I cannot change the 'Easing' option.. the default is 'swing'... when I try to assign other option (jswing for instance).. after I saved the change.. the setting for 'Easing' still on 'swing'.. rgrds, pit
  18. webmasterpitoyo

    [Addon} Modular Front Page

    thanks Jim, the module works fine now with some modification you suggest.. rgds, Pit
  19. webmasterpitoyo

    [Addon} Modular Front Page

    I found the change-log for removing tep_customer_greeting here: https://github.com/gburton/Responsive-osCommerce/commit/a5b1acf175fb3ad12c08bf97d0d996744b049fd3 is there something can be done on the Modular Front Page add-on? rgds, pit
  20. webmasterpitoyo

    [Addon} Modular Front Page

    OK, then.. I'll try to figure something else.. :) thanks anyway for your kind support.. rgds, pit
  21. webmasterpitoyo

    [Addon} Modular Front Page

    Thank for the advise, Jim.. Herewith I copy the page when costumer_greeting module set to true: <!DOCTYPE html> <html dir="ltr" lang="id"> <head> <meta charset="utf-8"> <meta http-equiv="X-UA-Compatible" content="IE=edge"> <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"> <title>Pitoyo.com Webstore</title> <base href="http://pitoyo.com/webstore3/"> <link href="ext/bootstrap/css/bootstrap.min.css" rel="stylesheet"> <!-- font awesome --> <link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/font-awesome/4.6.1/css/font-awesome.min.css"> <link href="custom.css" rel="stylesheet"> <link href="user.css" rel="stylesheet"> <!--[if lt IE 9]> <script src="ext/js/html5shiv.js"></script> <script src="ext/js/respond.min.js"></script> <script src="ext/js/excanvas.min.js"></script> <![endif]--> <script src="ext/jquery/jquery-2.2.3.min.js"></script> <noscript><div class="no-script"><div class="no-script-inner"><p><strong>JavaScript seems to be disabled in your browser.</strong></p><p>You must have JavaScript enabled in your browser to utilize the functionality of this website. <a href="http://www.enable-javascript.com/" target="_blank" rel="nofollow">Click here for instructions on enabling javascript in your browser</a>.</div></div></noscript> <style>.no-script { border: 1px solid #ddd; border-width: 0 0 1px; background: #ffff90; font: 14px verdana; line-height: 2; text-align: center; color: #2f2f2f; } .no-script .no-script-inner { margin: 0 auto; padding: 5px; } .no-script p { margin: 0; }</style></head> <body> <nav class="navbar navbar-inverse navbar-no-corners navbar-custom" role="navigation"> <div class="container-fluid"> <div class="navbar-header"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target="#bs-navbar-collapse-core-nav"> <span class="sr-only">Toggle Navigation</span> <span class="icon-bar"></span><span class="icon-bar"></span><span class="icon-bar"></span></button> <a class="navbar-brand" href="http://pitoyo.com/webstore3/index.php">Pitoyo.com Webstore</a></div> <div class="collapse navbar-collapse" id="bs-navbar-collapse-core-nav"> <ul class="nav navbar-nav navbar-right"> <li class="nav navbar-text"><i class="fa fa-shopping-cart"></i> 0 items</li></ul> </div> </div> </nav> <div id="bodyWrapper" class="container-fluid"> <div class="row"> <div class="modular-header"> <div id="storeLogo" class="col-sm-6"> <a href="http://pitoyo.com/webstore3/index.php"><img src="images/store_logo.png" alt="Pitoyo.com Webstore" title="Pitoyo.com Webstore" width="200" height="50" class="img-responsive" /></a></div> <div class="col-sm-6"> <div class="searchbox-margin"><form name="quick_find" action="http://pitoyo.com/webstore3/advanced_search_result.php" method="get" class="form-horizontal"> <div class="input-group"><input type="search" name="keywords" required placeholder="Cari" class="form-control" /><span class="input-group-btn"><button type="submit" class="btn btn-info"><i class="fa fa-search"></i></button></span> </div></form></div></div> <div class="col-sm-12"> <ol itemscope itemtype="http://schema.org/BreadcrumbList" class="breadcrumb"><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="http://www.pitoyo.com/webstore3/" itemprop="item"><span itemprop="name"><i class="fa fa-home"><span class="sr-only">Home</span></i></span></a><meta itemprop="position" content="1" /></li> <li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="http://pitoyo.com/webstore3/index.php" itemprop="item"><span itemprop="name">Katalog</span></a><meta itemprop="position" content="2" /></li> </ol></div> </div> <div class="clearfix"></div> <div class="body-sans-header clearfix"> <div id="bodyContent" class="col-md-8 col-md-push-2"> <div class="row"> <!-- Start cm_fp_customer_greeting module --> <div id="customer_greeting" class="col-sm-12"> <div class="alert alert-info"> seems like it couldn't find tep_customer_greeting.. ? Tx, rgds, Pit
  22. webmasterpitoyo

    [Addon} Modular Front Page

    Helo Jim, Tx for the respon I use two languages: English and Indonesia... the catalog/include/languages/<language>/module/content/front_page/<all module> I put them on both language.. I use the fresh Bootstrap EDGE: https://github.com/g...hive/master.zip and so far I just only made a change adding the add-on: - State Selector BS 1.2 - Admin Login Group for OSC2.3 - Bank Trasnfer Payment Module - Multi GeoZone and MultiTable the Indonesia language module, I made myself just by copying all from folder english on new forder indonesia, as well as english.php duplicating to indonesia.php and editing all script inside which has to translate between tag ' - '. Did I missed something? tx, rgds Pit
  23. webmasterpitoyo

    [Addon} Modular Front Page

    Helo there, I use the OSC 2.3.4 bootstrap so I installed the addon from the Oscommerce_responsive module folder. Everything seems OK, only the costumer_greetings module that not worked. everytime I assign this module 'true', so the store page become blank only the header tag shows, even left and right column are missing too. The rest of the module works fine I double check everything, seems nothing wrong with my installation... any suggestion? In the mean time, I put back on the original index.php.. with the native index content module thanks rgds pit
  24. Hello Eric, At the moment I've also some problem with Paypal Express Checkout Module (native payment module on v2.3) which is not work in mobile after page mobile_checkout_payment.php which is not redirecting to paypal website. Seems like I have similar problem you had. Kindly ask you step by step the modification you've done to this add-on so the Paypal Express Checkout works also in mobile version? rgds, pit
  25. webmasterpitoyo

    PayPal with other currency

    I had a similar problem with Paypal Website Standard Module... since I use the IDR as my default currency and Paypal still doesn't support IDR.. Do you already got a solution for this situation?.. kindly let me know.. :) ... At the moment I get back to use the Paypal module .. only with this module .. I still have buyer returning problem.. so the order not show at the admin page.. Any idea..?
×