Jump to content

deepfreeze

Members
  • Content count

    32
  • Joined

  • Last visited

Posts posted by deepfreeze


  1. Further to my post above;

     

    1054 - Unknown column 'p.products_id' in 'on clause'

     

    select distinct p.products_id, p.products_image, p.products_tax_class_id, IF(s.status = '1' AND s.stores_id = '1', s.specials_new_products_price, p.products_price) as products_price from products p left join specials s on p.products_id = s.products_id and s.stores_id = '1', products_to_categories p2c, categories c INNER JOIN products_to_stores p2s ON p.products_id = p2s.products_id where p2s.stores_id = '1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and c.parent_id = '90' and p.products_status = '1' order by p.products_date_added desc limit 9

     

    [TEP STOP]

     

     

     

    I now understand the problem and this was me setting my database on a server with SQL 5.0.19 running. After version 5.0.12 the SQL syntax changed to bring it into line with the 2003 standards. This resulted in the error above as the structure of JOIN, SELECT AND ON has changed and therefore the code used above in Multi Stores will not work.

     

    This is not meant to be critical of this superb Contribution - just a warning to any one looking to use it and also to future proof it.


  2. Have tested MS and works fine so placed files on live server and hit problem when going to look at products with following error;

     

    1054 - Unknown column 'p.products_id' in 'on clause'

     

    select distinct p.products_id, p.products_image, p.products_tax_class_id, IF(s.status = '1' AND s.stores_id = '1', s.specials_new_products_price, p.products_price) as products_price from products p left join specials s on p.products_id = s.products_id and s.stores_id = '1', products_to_categories p2c, categories c INNER JOIN products_to_stores p2s ON p.products_id = p2s.products_id where p2s.stores_id = '1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and c.parent_id = '90' and p.products_status = '1' order by p.products_date_added desc limit 9

     

    [TEP STOP]

     

    Have reloaded database and checked files but at a loss or not seeing wood for trees.

     

    Any ideas would be welcome.

     

    Many thanks :blush:


  3. Have found a weird problem and can't seem to see the solution. I have installed Admin Access With Levels 1.6 contrib and also have edit orders contrib. As main admin I have no problem with anything - it all works great.

     

    However, when i create a user all works well except they can not print an invoice or packing slip (they have been setup to access this area :rolleyes: ).

     

    Is this a permissions problem or me being my usual stupid self and missing that one little thing?? :huh:

     

    Install on MS2 - invoice button is looking for the following link;

     

    http://localhost/oscommerce/catalog/admin/invoice.php?oID=6

     

    Result is new window comes up "page cannot be displayed".

     

    Invoice.php exists in this directory

     

    Appreciate your help on this.


  4. Superb! Have installed this contrib and the parse times on admin have improved on a huge scale.

     

    Question - Is this contrib supposed to work on the catalog side of the system as I have noticed no difference on this side.

     

    Keep up the good work

     

    Regards

     

    Andy


  5. Why do you need this? The card type is be automatically detected based on the number.

     

    If you really wanted this, then I suppose you would add a selection field to the cc.php module and then compare the value with what was returned by cc_validation.php. Seems pointless to me, except for it telling your users which cards you accept, which you can do in other ways. You can edit cc_validation.php to reject card types you don't accept.

    We have the choice with credit cards but how will the system handle debit cards like switch?

     

    Regards


  6. Steve.

     

    You know when anyone writes a topic, they say "i'm not sure if this has been asked or mentioned before", it means i have not checked and here goes! :P

     

    Well here it is - Have used the latest update (country-state-selector_1_2_3_4.zip) and the last instruction reads "catalog/includes/modules" no file name. I assume you mean the "checkout_new_address.php".

     

    Not too important but thought i would let you know - keep up the good work.

     

    Andy


  7. You know when anyone writes a topic, they say "i'm not sure if this has been asked or mentioned before", it means i have not checked and here goes! :P

     

    Well here it is - Have used the latest update (country-state-selector_1_2_3_4.zip) and the last instruction reads "catalog/includes/modules" no file name. I assume you mean the "checkout_new_address.php".

     

    Not too important but thought i would let you know - keep up the good work.

     

    Andy

    Ignore this ended up on the main board and should have been under country state selector.

     

    GUESSS I DID NOT CHECK!!!!!!!


  8. You know when anyone writes a topic, they say "i'm not sure if this has been asked or mentioned before", it means i have not checked and here goes! :P

     

    Well here it is - Have used the latest update (country-state-selector_1_2_3_4.zip) and the last instruction reads "catalog/includes/modules" no file name. I assume you mean the "checkout_new_address.php".

     

    Not too important but thought i would let you know - keep up the good work.

     

    Andy


  9. Superb contribution, this is just what I'm looking for.

     

    However, I'm having the same problems as above but i did not cut from HTML I opened your file in MacroMedia so I could just cut the text as is.

     

    My parse error was line 196 unexpected } when this was removed as described above I too get blank entries whether trying to edit or delete.

     

    Loaded version 1.03

    Well sorry for this , it would seem i missed the deletion of a little code on the line 100 replacement - alls seems to be okily dockily :D

     

    Regards

     

    Andy


  10. Superb contribution, this is just what I'm looking for.

     

    However, I'm having the same problems as above but i did not cut from HTML I opened your file in MacroMedia so I could just cut the text as is.

     

    My parse error was line 196 unexpected } when this was removed as described above I too get blank entries whether trying to edit or delete.

     

    Loaded version 1.03

×