Jump to content

BenjaminJ.Gremillion

Members
  • Content count

    14
  • Joined

  • Last visited

Posts posted by BenjaminJ.Gremillion


  1. If anyone is interested in the solution:

     

    add to application_top.php (after case buy_now...break;)

    // <!-- Wish List -->
    case 'add_to_wishlist' : if (isset($HTTP_GET_VARS['products_id'])) {
    if (tep_has_product_attributes($HTTP_GET_VARS['products_id'])) {
    tep_redirect(tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $HTTP_GET_VARS['products_id']));
    } else {
    $wishList->add_wishList($HTTP_GET_VARS['products_id'], '');
    }
    }
    tep_redirect(tep_href_link('wishlist.php', tep_get_all_get_params($parameters)));
    break;
    // <!-- /Wish List -->
    

     

    And to product_listing.php (somewhere near the buy now button)

    tep_draw_button(IMAGE_BUTTON_WISHLIST, '', tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action')) . 'action=add_to_wishlist&products_id=' . $listing['products_id']), 'primary')
    


  2. Just installed featured products and I'm getting a SQL error:

     

    1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-0, MAX_DISPLAY_FEATURED_PRODUCTS' at line 6

     

    select p.products_id, pd.products_name, p.products_image, p.products_price, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, p.products_date_added, m.manufacturers_name from products p left join manufacturers m on p.manufacturers_id = m.manufacturers_id left join products_description pd on p.products_id = pd.products_id and pd.language_id = '1' left join specials s on p.products_id = s.products_id left join featured f on p.products_id = f.products_id where p.products_status = '1' and f.status = '1' order by p.products_date_added DESC, pd.products_name limit -0, MAX_DISPLAY_FEATURED_PRODUCTS

     

    Also, there's no listing for Featured under admin/configuration after the install.

     

    Any ideas on what I may have done wrong?

×