Latest News: (loading..)

RCHobbyAddict

Members
  • Content count

    54
  • Joined

  • Last visited

1 Follower

About RCHobbyAddict

Profile Information

  • Real Name
    Anam Aggarwal
  1. I installed Unique order number addon. But now when I use the Manual order creator to create an order, it is picking up the order number as 0. What should I do?
  2. I am also facing the problem. The problem is occuring even when a customer signs into his account. If a cart is created without signing in, and when he signs in for checkout, the cart is deleted.
  3. Hello, I have edited the file to work with Points and Reward system. It is working but some more improvements are needed which I will take some more time. Additions to language file of checkout.php will be needed as per the points and reward system instructions. All other steps remain the same. Files covered from points and reward system installation instruction: catalog/checkout_confirmation.php catalog/checkout_payment.php catalog/checkout_process.php I was unable to make the code compatible with auto update when the "USE POINTS" box was checked, using AJAX. Still working on that. checkout.php
  4. Ok. It is not working... how to get it to work...? This is a really good contribution and I need it. Also, I am having one more problem. In the checkout.php, it shows the summary of the cart. There if I have 5 items, then the remove icon is not scrolling. I get 5 remove icons which are comming out of the box. Have a look at the screenshot. Running on Firefox
  5. Hello, I am trying to modify it according to the Points and Reward system. I am stuck at the part where I need to modify checkout_process.php I am stuck for the following modification and cannot find where to put the additional code in checkout.php --------------------------------------------------------------------------------------------------- Find this.... (start at aprox. line no.134) tep_db_perform(TABLE_ORDERS_TOTAL, $sql_data_array); } .. and add this after... #### Points/Rewards Module V2.1beta balance customer points BOF #### if ((USE_POINTS_SYSTEM == 'true') && (USE_REDEEM_SYSTEM == 'true')) { // customer pending points added if ($order->info['total'] > 0) { $points_toadd = get_points_toadd($order); $points_comment = 'TEXT_DEFAULT_COMMENT'; $points_type = 'SP'; if ((get_redemption_awards($customer_shopping_points_spending) == true) && ($points_toadd >0)) { tep_add_pending_points($customer_id, $insert_id, $points_toadd, $points_comment, $points_type); } } // customer referral points added if ((tep_session_is_registered('customer_referral')) && (tep_not_null(USE_REFERRAL_SYSTEM))) { $referral_twice_query = tep_db_query("select unique_id from " . TABLE_CUSTOMERS_POINTS_PENDING . " where orders_id = '". (int)$insert_id ."' and points_type = 'RF' limit 1"); if (!tep_db_num_rows($referral_twice_query)) { $points_toadd = USE_REFERRAL_SYSTEM; $points_comment = 'TEXT_DEFAULT_REFERRAL'; $points_type = 'RF'; tep_add_pending_points($customer_referral, $insert_id, $points_toadd, $points_comment, $points_type); } } // customer shoppping points account balanced if ($customer_shopping_points_spending) { tep_redeemed_points($customer_id, $insert_id, $customer_shopping_points_spending); } } #### Points/Rewards Module V2.1beta balance customer points EOF ####*/ ---------------------------------------------------------------------------------------------------
  6. In the latest version of Modular front page, there is a problem: In catalog/includes/modules/front_page/New_Products.php, in some places you have given "TITLE_" inplace of "TITLE". That needs to be replaced. Also, in the admin section, I am facing an issue: When I click on Front Page under modules go to the page to install new front page module, I am getting the following error: Warning: include(/XXX/XXX/public_html/includes/languages/english/modules/front_page/function.php) [function.include]: failed to open stream: No such file or directory in /XXX/XXX/public_html/XXX/modules.php on line 129 Warning: include() [function.include]: Failed opening '/XXX/XXX/public_html/includes/languages/english/modules/front_page/function.php' for inclusion (include_path='.:/usr/lib/php') in /XXX/XXX/public_html/XXX/modules.php on line 129
  7. Hi spooks, Just for your information, I have updated my auto backup version and now I am not facing any issues regarding the Auto Backup Delete feature! Thank you... :)
  8. The "removed_backup.log" file is being updated. So there is no problem regarding the accessibility. But I still cannot figure out the problem. This problem has been comming up only after I updated the auto backup. Just a thought, did the previous version had some modifications to be done to the general.php file?
  9. When a customer is trying to edit an address in the address book, he is getting the following error: Fatal error: Call to undefined function ajax_get_zones_html() in /home/XXX/public_html/includes/modules/address_fields.php on line 47 Also, the create account page is comming completely unformatted, i.e. the side boxes have moved down.
  10. The permissions to that file is 644. Is that ok? And I also have an htaccess file in that folder. Can that cause any problems?
  11. I have the 4.1 version of auto backup installed. When I log into the admin, sometimes I get an error: WARNING: Cannot modify header information - headers already sent by (output started at /home/XXXX/public_html/XXXX/includes/auto_backup_delete.php:111) in /home/XXXX/public_html/XXXX/includes/functions/general.php on line 34 My auto backup settings are as follows: Auto Backup Interval- 120 Backup Archive Interval- 24 GZip Backups- gzip Split Backups On Timeout- extend Auto Backup Displayed Time Format- true Auto Run Auto Backup Delete- true Email Cron Backups- false Backup Delete Interval- 2 Please help.
  12. Yes. That is the smae problem I was going to report... After doing all the calculations, and entering them, I had to redo them again...
  13. I am facing a problem. I have created 2 customer groups. But when a customer from any of the groups place an order, no tax is added to it. But is a customer who is not under any group places an order, the tax is added to the items in his cart. How to fix that? I am running OSC 2.3.1
  14. Hello, This error occurs when you already have a class with this name declared in anywhere else on your website. Any other addon using the same class name. You can try replicating this error by just writing the whole class part in the same file itself.
  15. Hello, I am running osc 2.3.1. How can I display the weight remaining in the shopping cart page? For Example, I want that if the total weight of the in cart items is 250 grams and the nearest shipping method is for 300grams, then the shopping cart should show 50grams remaining.