Latest News: (loading..)

rundlegd

Members
  • Content count

    4
  • Joined

  • Last visited

2 Followers

About rundlegd

Profile Information

  • Real Name
    Rodney Shaver
  1. Gergely, I just found the problem Your modifications were missing '$$' on the writing to the tables. The code that seems to work is : // upgrade method only. Note: if you upgrades more and more the id number will be hihger. I suggest that picture upgrades use last // or delete always v_products_images_image_1 column to prevent effect if (EP_PRODUCTS_IMAGES == true) { if (isset($filelayout['v_products_images_image_1'])) { tep_db_query("delete from " . TABLE_PRODUCTS_IMAGES . " where products_id = '" . (int)$v_products_id . "'"); for ($i=1;$i<=EP_PRODUCTS_IMAGES_MAX;$i++) { $pi_htmlcontent_var = 'v_products_images_htmlcontent_'.$i; $pi_image_var = 'v_products_images_image_'.$i; if (!empty($$pi_image_var) || !empty($$pi_htmlcontent_var)) { tep_db_query("insert into " . TABLE_PRODUCTS_IMAGES . " (products_id, image, htmlcontent, sort_order) values ('" . (int)$v_products_id . "', '" . tep_db_input($$pi_image_var) . "', '" . tep_db_input($$pi_htmlcontent_var) . "', '" . tep_db_input($$i) . "')"); } } } }
  2. Gergely, Thanks for getting back to me. I have checked my code again, comparing it to yours but can not see where the problem is. I did put the new code in after the code for the EP_ADDITIONAL_IMAGES. I have checked that if I manually input a large image, I am able to export the data to a csv file with no problem, including the place holders for all six of the large images. It is just the import part that does not seem to work putting in the 'field name' for the value for every record. Is there any chance that I can send you my easypopulate.php file to look over? Thanks Rodney
  3. I have just gone through and added all the code for the large Product images as you indicated in the your memo. I was able to get it to export to a csv file showing the correct columns and image names for the "v_products_images_image_1" etc fields. However when I try to import the same csv file back into the database using Easypopulate 2.76i-231 the imported values for fields have the field names from the csv file only. ie large image 1 name is "v_products_images_image_1" and html1 is "v_products_images_htmlcontent_1"; large image 2 is ""v_products_images_image_2" and html2 is "v_products_images_htmlcontent_2". Do you have any suggestions of what I need to look for in my changes to fix this? Thanks Rodney
  4. I am a new user with OSC 2.3.1 and am trying to install EP_v2_76i_MS2. I am also having propblems with: "Add a link in the Admin Panel. Edit file "/catalog/admin/incudes/boxes/catalog.php" " my catalog.php file looks like: <?php /* $Id$ osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright © 2010 osCommerce Released under the GNU General Public License */ $cl_box_groups[] = array( 'heading' => BOX_HEADING_CATALOG, 'apps' => array( array( 'code' => FILENAME_CATEGORIES, 'title' => BOX_CATALOG_CATEGORIES_PRODUCTS, 'link' => tep_href_link(FILENAME_CATEGORIES) ), array( 'code' => FILENAME_PRODUCTS_ATTRIBUTES, 'title' => BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES, 'link' => tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES) ), array( 'code' => FILENAME_MANUFACTURERS, 'title' => BOX_CATALOG_MANUFACTURERS, 'link' => tep_href_link(FILENAME_MANUFACTURERS) ), array( 'code' => FILENAME_REVIEWS, 'title' => BOX_CATALOG_REVIEWS, 'link' => tep_href_link(FILENAME_REVIEWS) ), array( 'code' => FILENAME_SPECIALS, 'title' => BOX_CATALOG_SPECIALS, 'link' => tep_href_link(FILENAME_SPECIALS) ), array( 'code' => FILENAME_PRODUCTS_EXPECTED, 'title' => BOX_CATALOG_PRODUCTS_EXPECTED, 'link' => tep_href_link(FILENAME_PRODUCTS_EXPECTED) ) ) ); ?> It does not have any of the usually referred to lines: '<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' . How do I add the link for EasyPopulate link in this case. Thanks.