Jump to content
Latest News: (loading..)

gadlol

Members
  • Content count

    231
  • Joined

  • Last visited

  • Days Won

    13

gadlol last won the day on July 13 2017

gadlol had the most liked content!

Profile Information

Recent Profile Visitors

14,855 profile views
  1. Problem fixed. Its a bug when the store has ONLY ONE category. osCommercians who have only one category and using Seo Friendly Urls must go and comment the line 308 //elseif($citems==1) $children[] = $items[$clang]; //in case we have one category item without subcategories, rare but possible In the next upcoming update this will be fixed... @wHiTeHaT I asked from @Stephan Gebbers to send me info in PM because I knew that I had to investigate the problem on his live website.... After the bug fix I would ( as I did ) post the solution... About $ - who fixes it, it's another story but it would be nice to see if there would be anyone here that could fix it... :-)
  2. Hi @Stephan Gebbers By default the main language is set not to appear in the url but you can change that by altering the option "Display default language alias?" About the categories not being aliased there something must be happening I must check it by myself. Is it possible to send me via PM live link and more info so to check? About clearing the cache: you must clear the cache only when you manually change the alias or products are made - deleted or modified their names.
  3. So I guess osCommerce is dead... Am I right? What will be the next stage that @JcMagpie is saying?
  4. @RAC I actually don't know. If you put in content it needs changes to the class. So it is better to place it in the boxes for now. If I find some free time I will coded it the right way..
  5. Hi @RAC Right now the one I have uploaded in the first post of this thread uses bm_product_next_previous. I don't know how the newer version has changed in terms on modulating (is this the right word?) I think that the module should be in content and not in box: includes/modules/content/product_info/cm_pi_next_previous.php includes/modules/content/product_info/templates/next_previous.php
  6. You are welcome @janeyred
  7. Did you changed in the index.php the require('includes/application_top.php'); to require_once('includes/application_top.php'); ???
  8. Hi... blank home page can mean lots o fthings. Maybe you did something wrong during installation. Maybe this is probably the htaccess file. Does your server produce any error logs (apache error logs)? Are all the pages blank or the homepage only? Can you give me the url so to check it?
  9. Would you be interested in creating an API for osCommerce?

    1. Show previous comments  1 more
    2. gadlol

      gadlol

      Hmmm.

      Imagine having all the sql queries somewhere centralized and having a system to fetch us the data. For example: in the specials.php I would need no more to have a tep_db_query just

      $listing = $osc_api->specials(); 

      And now $listing has the data in array so to be used in the specials.php.

      Another useful thing about osc API is that you can make your website data available outside of your osc installation and so it would be easy to create mobile applications e.t.c. For example:

      $osc_api->specials()->toJSON();

      will produce a json specials in json format..

       

    3. beerbee

      beerbee

      Yes! We'd need it for a life interface to our ERP system.

    4. burt

      burt

      Maybe make a more detailed post regarding your ideas?

      In principle:  excellent idea

  10. Hi... the XML sitemap generator (http://addons.oscommerce.com/info/6583) does not use the oscommerce tep_href_link instead it uses a class method hrefLink. Thats why that addon does not work with the Seo Friendly Urls. I dont know if there is any sitemap addon that uses the osc default functions for generating the urls....
  11. Hmmmm, i dont know about that.... Maybe there are conflictions between addons....
  12. Hi @@aurelou .... You may edit the seo_friendly_urls.php class and try to change all the $HTTP_GET_VARS to $_GET and find all the FILENAME_ defines and replace them with the file. In example: FILENAME_DEFAULT => 'index.php'
  13. Hi @@29gk Glad it works..... Hope you like my addon... P.S. Γεια σου πατριώτη...
  14. In order for the SEO FRIENDLY URLS to be uninstalled you must use the uninstall option then go to the front store so that option - action run. Then If you refresh the page the SEO FRIENDLY URLS will auto install again. But I dont know what will happen if some of the configurations is corrupted. In general I would suggest to go to the configuration table and remove all the keys that start with SEO_FRIENDLY_URLS_ and then go to the front store and seo frendly urls will auto install....
  15. Hi Richard. 404 not found is not an easy task, at least in oscommerce. So in order not to have that white page, create an 404.php page but without oscommerce code and then go to admin and edit the option Handle not found urls as 404 include page? (404 status code) set to 404.php and then you will get the 404.php displayed. Unfortunately there is not an easy way to make an oscommerce page as a 404 not found. In the next version I ll try to implement that. But for now the solution is to create a custom 404 page...
×