Jump to content

nockemout

Members
  • Content count

    20
  • Joined

  • Last visited

Everything posted by nockemout

  1. nockemout

    [contribution] Simple Template System (sts)

    Update: I fixed the footer text, it seems like manual install works better. However I still get the menu text and removing the code added by STS does not fix it. Please advise. Thanks
  2. nockemout

    [contribution] Simple Template System (sts)

    Hello, I searched for my answer but couldn't find it. This is urgent.. Im using STS 4.6__1 and OSC 2.2RC2a Followed the install directions to the T. (uploaded files) When in Admin user dashboard I have broken pieces of PHP code showing, such as: in Menu: ) . '" class="menuBoxContentLink">' . BOX_MODULES_ORDER_TOTAL . ''); } $box = new box; echo $box->menuBox($heading, $contents); ?> in Footer: INFO_VERSION . ' ' . $sversion . ' (' . TEXT_INFO_ONLINE_STATUS . ')'); } $contents[] = array('text' => ' ' . $mInfo->description); } break; } if ( (tep_not_null($heading)) && (tep_not_null($contents)) ) { echo ' ' . "\n"; $box = new box; echo $box->infoBox($heading, $contents); echo ' ' . "\n"; } ?> Here's my admin/includes/boxes/modules.php: <?php /* $Id: modules.php 1739 2007-12-20 00:52:16Z hpdl $ osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2002 osCommerce Released under the GNU General Public License */ ?> <!-- modules //--> <tr> <td> <?php $heading = array(); $contents = array(); $heading[] = array('text' => BOX_HEADING_MODULES, 'link' => tep_href_link(FILENAME_MODULES, 'set=payment&selected_box=modules')); if ($selected_box == 'modules') { $contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_MODULES, 'set=payment', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_MODULES_PAYMENT . '</a><br>' . '<a href="' . tep_href_link(FILENAME_MODULES, 'set=shipping', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_MODULES_SHIPPING . '</a><br>' . // START STS 4.1 '<a href="' . tep_href_link(FILENAME_MODULES, 'set=sts', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_MODULES_STS . '</a><br>' . // END STS 4.1 '<a href="' . tep_href_link(FILENAME_MODULES, 'set=ordertotal', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_MODULES_ORDER_TOTAL . '</a>'); } $box = new box; echo $box->menuBox($heading, $contents); ?> </td> </tr> <!-- modules_eof //--> and no STS option under modules. I am looking into my modules.php page. If there's any need info I can provide for your assistance I will gladly share. Thanks
×