Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

hfs3

Members
  • Content count

    13
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Henry Spadoni
  1. hfs3

    Multi_Vendor_Shipping new thread

    Jim, Thanks for the pointers! I'll keep you posted. ;) Henry
  2. hfs3

    Multi_Vendor_Shipping new thread

    Jim, That sounds reasonable, except I really don't know where to start! The ship estimator works just fine without vendor shipping enabled... Henry
  3. hfs3

    Multi_Vendor_Shipping new thread

    Jim, I agree with you. I ran the mvs.sql code (copy/paste to command line in mySQL 4.1.14). Is there a better way, or should I re-run? Henry
  4. hfs3

    Multi_Vendor_Shipping new thread

    Jim, I believe I have the right version: $Mod: MVS V1.2 2009/02/28 JCK/CWG $ I'm not sure what to do next... Henry
  5. hfs3

    Multi_Vendor_Shipping new thread

    Jim, it appears the drop down box in the prods_by_vendor.php does not change the vendor filter. For example, if I select Product Reports from the side menu the URL looks like this: /admin/prods_by_vendor.php. However, when I select a vendor in Vendor Manager then click on "Click here for Products Report" in the box to the right with the buttons, the URL reads admin/prods_by_vendor.php?&vendors_id=1, and the correct products appear. Not sure how to fix that one... Still, I don't think that has anything to do with the issue I am having regarding the absence of Ship Methods on the checkout_shipping.php page. I'll try uploading the page again to see if that helps. It does function properly when Vendor Shipping is disabled.
  6. hfs3

    Multi_Vendor_Shipping new thread

    I noticed when accessing the Vendor Products Report from the menu that all products were available from all vendors. However, accessing the VPR from the box with the edit/delete/manage/new vendor/orders buttons returned the correct values. Hmmmm.... I clicked on an item in the primary vendor (our store), which brought me to the product edit page. I selected one of our vendors and clicked update. Looking back at the VPR for the primary vendor, the item was gone from the list. Looking at the VPR for the vendor I assigned came up empty. It was the same product list as the primary vendor. A quick check revealed the product list for all three vendors were identical. Items I assigned to outside vendors did not appear on any of the VPRs. What could cause this? Henry
  7. hfs3

    Multi_Vendor_Shipping new thread

    Flat Rate addition did not work, no shipping methods appear. Guess I have to look at the files I uploaded again! Henry
  8. hfs3

    Multi_Vendor_Shipping new thread

    I set up several test items and assigned them to specific vendors, then created an order with some of those items. The shipping_info.php page shows them properly grouped by vendor, but no shipping options show below the text title indicating shipping options. My install consisted of copying the files over and running the mvs.sql script. There were only minor mods to the install, which were easy to re-edit. I'll check all the data, but think my problem is with the install...
  9. hfs3

    Multi_Vendor_Shipping new thread

    That's what I'm not sure about! At present, the regular shipping modules are in place (Flat Rate, Per Item, Table Rate, United Parcel Service, USPS, & Zone Rates). Only UPS is enabled at this point. The Two vendors are setup as UPS, one is setup for TNT Road Express, all enabled. I'm not sure what I *should* do?
  10. hfs3

    Multi_Vendor_Shipping new thread

    Yes, I did that - setup two vendors (our warehouse and the distributor) as UPS shippers. I set up a few items for each vendor and added to my cart. When I get to the checkout_shipping part, the products are correctly separated by vendor. The message "This is currently the only shipping method available to use on this order." shows, but the UPS shipping methods do not appear below. When vendor shipping is turned off, all items appear in one group with the appropriate UPS methods available. In the CP under shipping modules, the UPS module is enabled. Should that be on or off? The vendors have the same UPS options enabled.
  11. hfs3

    Multi_Vendor_Shipping new thread

    I recently installed MVS into a fairly stock 2.2 site, but ran into a small hitch in the checkout process. On the shipping_info page, no shipping methods appear to select from. Any attempt to proceed with checkout fails and this lovely message displays across the screen: Error: You have not selected a shipping method for all groups of products. Please select one shipping method for each group of products below. I used one item and setup the MVS vendor to ship via several UPS options. When MVS is toggled off, the shipping_info page shows the appropriate UPS options, however, once MVS is turned on no shipping options are available. Any thoughts?
×