Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

pdcelec

Members
  • Content count

    594
  • Joined

  • Last visited

  • Days Won

    3

Posts posted by pdcelec


  1. Hi guys. What a breath of fresh air this conversion is! I've just installed it along with the 'securityPro' contribution. I've found though that both the 'buy now' and 'add to cart' buttons do not seem to do anything. They do not add anything to the cart nor does the json cart pop up.

     

    I'm not able to post a link as I'm working on localhost.

     

    Does anyone have any ideas as to what's going wrong?

     

     

    Are you connected to the internet whilst on localhost as the jquery library is called from google (see the install for application_top.php)


  2. I have been testing usu5 pro with RC2.3 and can find no issues apart from XHTML validation. (I altered $parameters in USU_main and it now validates). I like the Google xml addition and it works fine. I have tried this with the enable/disable categories contrib and I get the correct results also. I would have reported back earlier but I have no issues to report.


  3. Hi

    I have found a bug in products_new.php in this section

     

     

    <div class="pl-dateadded">

    <?php // echo TEXT_DATE_ADDED . ' ' . tep_date_short($products_new['products_date_added']);?>

    <?php echo '<span class="smalltext">Added ' . tep_date_short($products_new['products_date_added'].'</span class="smalltext"');?>

    </div>

     

    should be (note the position of the closing) after ($products_new['products_date_added']).

    <div class="pl-dateadded">

    <?php // echo TEXT_DATE_ADDED . ' ' . tep_date_short($products_new['products_date_added']);?>

    <?php echo '<span class="smalltext">Added ' . tep_date_short($products_new['products_date_added']).'</span class="smalltext"';?>

    </div>


  4. Feedback:

     

    First Impressions:

    Installation was easy and it integrates seamlessly into RC2.3. I have tried the variations of URI cbmp etc. I tried cbmpmpcbmp and it still operates.

    The one problem that I am getting is with the new manufacturers box not changing (I believe it may be a javascript conflict). My old manufacturers box produces URI's as expected.

    I am getting ?language=xx apended to the URI's when I change language, is this correct?.

    I will try some of the other features today.

     

    I solved this one. I had 2 language boxes, yours plus the original. This now does not occur


  5. Hi Leonardo,

     

    I have run across the magnifying glass issue on my site as well. Here is the solution:

    Add this to a stylesheet:

    input.search-field{ /*input field */ 
    float: left; }
    

     

    This will float the two elements, the searchbox and the image horizontally

     

    To solve this on my site, I wrapped them in <p></p> tags (which is also a requirement for XHTML 1.0 Strict)

     

    $info_box_contents = array();

    $info_box_contents[] = array('text' => BOX_HEADING_SEARCH);

     

    new cssinfoBoxHeading($info_box_contents, false, false);

     

    $info_box_contents = array();

    $info_box_contents[] = array(//'form' => tep_draw_form('quick_find', tep_href_link(FILENAME_ADVANCED_SEARCH_RESULT, '', 'NONSSL', false), 'get'),

     

    'text' => '<div>' . tep_draw_form('quick_find', tep_href_link(FILENAME_ADVANCED_SEARCH_RESULT, '', 'SSL', false), 'get').'<div class="search-box"><p>'.tep_draw_input_field('keywords', '', 'size="10" maxlength="25" class="search-field" value="Search..." onfocus="clearDefault(this)" onblur="Default(this)"').'<input type="hidden" name="search_in_description" value="1" /><input type="hidden" name="inc_subcat" value="1" />'.tep_hide_session_id() .'<input type="submit" name="search" value="" class="search-go" /></p></div></form></div><a href="' . tep_href_link(FILENAME_ADVANCED_SEARCH) . '">' . BOX_SEARCH_ADVANCED_SEARCH . '</a>');

     

    new cssinfoBox($info_box_contents);


  6. Hi everyone,

     

    I'm installing the anti hacker account mod. But at step "Open product_reviews_write.php AND tell_a_friend.php AND any other files you have accepting post vars not included here" I got stuck with a question: Do I just have to open all the files in the catalog and search for $HTTP_POST_VARS? And if this string is in the document, add the lines

     

    // anti-hacker account	
      require('includes/functions/account_secure.php');
      clean_post ();
    // EOF anti-hacker account

     

    Or am I just misunderstanding this.

     

    Thanks in advance

     

    Yes that is correct (I use WINgrep on a downloaded copy of my site to find the files and then edit them)


  7. I have jquery add to cart installed. I am getting this error when USU5 PRO is enabled

     

    The add to cart functions correctly in index.php but when in product_info.php I get this error

     

    Error Type: [E_NOTICE] Undefined index: id

    On line 44

    File actions.php

    -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

     

    This occurs whichever setting USU 5 PRO is on on.

     

    Otherwise the URI's seem to be performing ok


  8. Feedback:

     

    First Impressions:

    Installation was easy and it integrates seamlessly into RC2.3. I have tried the variations of URI cbmp etc. I tried cbmpmpcbmp and it still operates.

    The one problem that I am getting is with the new manufacturers box not changing (I believe it may be a javascript conflict). My old manufacturers box produces URI's as expected.

    I am getting ?language=xx apended to the URI's when I change language, is this correct?.

    I will try some of the other features today.


  9. Thanks! That's quite a list, geez.

    Here is the method that I used.

     

    1. Install RC2.3

    2. Overwrite catalog with CSS V2

    3. Apply RC2.3 changes to catalog with file compare (applying all changes at once)

    4. Install latest commits, including jquery buttons and other updates

    5. Re install contribs

    6. Go to pub for a well earned beer


  10. Hi Paul,

     

    Can you provide a link or instructions to the 2.3 upgrade files? I'm not finding anything that says something like 'upgrade to 2.2 a to 2.3'.

     

    Thanks!

     

    For the files:

    http://github.com/osCommerce/oscommerce2/tree/upgrade23

     

    For the instructions

    http://www.oscommerce.info/confluence/display/OSCOM23/Upgrade+Guide

     

    I have just checked and HDPL is adding the 960 grid to all files (note that the 2.3 download does not include this as of yet). Looks very interesting


  11. Wow, that seems kind of like driving two blocks to the corner store in your new BMW for a soda. But it probably works really well.

    I does work. Here is a snippet of index.php

     

    <div class="grid_4 alpha">

    <script type="text/javascript"><!--

    $(document).ready(function(){

    $("a.target_blank").click(function(){

    window.open(this.href);

    return false;

    });

    });

    //--></script>

    <h4>960 Grid System</h4>

    This new version, v2.0,

    incorporates the

    <!--<a href="http://960.gs/" target="blank">960 grid system</a>.-->

    <a href="http://960.gs/" class="target_blank">960 grid system</a>.

    The 960 grid system greatly facilitates alignment, proportion and

    layout issues. It speeds up design, creates consistency and solves

    cross browser problems.</div>


  12. The 'target' is no big deal, and there must surely be an updated version of 'target' that validates. Check google. Target="blank" for example simple opens the link in a new window, a really common function. If you took out all the instances of target from the OSC to CSS nothing integral or important to OSC to CSS would be changed.

     

     

    this is how Drupal does it

    create a file named target-blank.js (Jquery)

     

    $(document).ready(function(){

    $("a.target_blank").click(function(){

    window.open(this.href);

    return false;

    });

    });

     

    and add class="target_blank" to the anchor tag.

     

    I will have a look at this tomorrow, but I am no expert in this type of stuff


  13. Thanks!

    converting to 2.3: Impressive! You are inspiring me to get this done as well as the W3 validation, and it is nice to know it can be done.

     

    I have reverted back to XHTML Transitional as Strict does not allow Target="" (they recommend a workaround using javascript)

     

    The W3C CSS2.1 does not like the MOZ kit for the buttons but I believe Harald is adding UI buttons to V2.3 at the moment so that may fix that one.


  14. got it, thanks!

     

    wait, wasn't there some errors in the header related to stuff like <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" > and such?

     

    replace with

    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

    and

    <base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">

    replace with

    <base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>" />


  15. Hi all!

     

    I had a problem to decompress the last full package of OSC2CSS with winrar (and also with other stuff). Did you recognize this issue? I have just downloaded it many times but the result was the same, no succesful unpack at all ( path not found 1132 times on the archive)

     

    Thanks,

    FG

     

    I had the same, but I think it is referring to the MACOS files, as I have it successfully installed


  16. I have successfully upgraded osc to css V2 to RC2.3. It took alot of time but there are not really that many changes. Mainly little alterations here and there. I have yet to implement the new header tags module and other modules, but after 14 hours of changes, I have had enough for one day


  17. It only happens if I turn off the search box in column left. I assume that the form is not ending

     

    I have solved that one. It was a misiing </form> (which I had taken out)

     

    I have a problem now with column right. I have put a bar going across the page and noticed that column right is lower than column left. I have searched for possible reasons and cannot seem to find the answer


  18. I have something strange happening. The sign in button takes me to advanced search result. I am trying to backtrack on some changes but everything else seems ok.

     

    It only happens if I turn off the search box in column left. I assume that the form is not ending

×