Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

pdcelec

Members
  • Content count

    594
  • Joined

  • Last visited

  • Days Won

    3

Posts posted by pdcelec


  1. Thank you again. Does it matter if the following lines are addedd to the beginning or end of the filenames.php file?

     

    Manual Edits

    Step 3:

    Add the following lines to /catalog/admin/includes/filenames.php:

     

    // BOF: Featured Products

    define('FILENAME_FEATURED', 'featured.php');

    define('FILENAME_FEATURED_PRODUCTS', 'featured_products.php');

    define('FILENAME_SELECT_FEATURED', 'select_featured.php');

     

    Thanks in advance..

     

    Best,

     

    Christopher

     

    It does not matter whether the lines are added to the beginning or end of the file HOWEVER, the convention is to add them to END of the file BEFORE the closing ?>


  2. Ok I am very very new to this; I am a quick learner and a do-it-yourselfer, which is why now I am asking for help with what i screwed up. I have a couple other questions as well; which if I can get this website up and going it might save my marriage; my husband is tired of me spending all hours of the night on here trying to fix it....

     

     

    On my front page it is showing "FOOTER_TEXT_BODY" on the bottom instead of the actual content as well as other places like TEXT_GREETING_GUEST

     

    my site is www.myband-it.com

     

    Issue 1

     

    Can someone tell me what i did to cause this? Yes, this is the first of my issues, but I am trying to work through it. I spent 4 hours last night searching for the answer, I must not know the correct terminology because I can't image this is a difficult problem and I expected to find an answer on the forum. I'm sorry if it is posted on here already I just could not find it.

     

     

     

    Issue 2

    Is there a good add on to allow pricing differences? My prices are 1/$7 2/$11 and 4/$20 I'm not sure how to set that up! I looked through the add on's but I'm not sure which one would be best.

     

    Issue 3

    What is the best add on to bypass shipping and payment? I have local friends who I just take cash from and hand deliver.

     

     

     

    Any help is greatly appreciated and many thanks to anyone who can help me

     

    Issue 1

    catalog/includes/english.php is where these definiitions come from


  3. hi,

     

    After installing ULTIMATE SEO URLS 5 PRO, I tried to setup the htaccess, the contribution is working fine, but when I try to mod the htaccess, look like is not working.

     

    One of my question is; I know that

    * I access my site as www.mysite.com/ - RewriteBase /

    * I access my site as www.mysite.com/catalog/ - RewriteBase /catalog/

    * I access my site as www.mysite.com/catalog/shop/ - RewriteBase /catalog/shop/

     

    but in my case I am working local server and to access to the store I write; http://192.168.1.1/osc2.3.1/catalog/

     

    so, in this case how it will be my RewriteBase????

     

    Any advice

     

     

    Alex

    RewriteBase /catalog/


  4. i have been using oscmax but i couldn't find the answers from their forums regarding installing product tabs addons.

     

    i have followed all installation process except that SQL gave me an error. the sql installed was:

     

    ALTER TABLE `products_description` ADD `products_spec` TEXT DEFAULT NULL AFTER `products_description`;

    ALTER TABLE `products_description` ADD `products_musthave` TEXT DEFAULT NULL AFTER `products_description`;

    ALTER TABLE `products_description` ADD `products_extraimage` TEXT DEFAULT NULL AFTER `products_description`;

    ALTER TABLE `products_description` ADD `products_manual` TEXT DEFAULT NULL AFTER `products_description`;

    ALTER TABLE `products_description` ADD `products_extra1` TEXT DEFAULT NULL AFTER `products_description`;

    ALTER TABLE `products_description` ADD `products_moreinfo` TEXT DEFAULT NULL AFTER `products_description`;

     

     

    It gave me an error that says:

     

    Error

    SQL query:

     

    ALTER TABLE `products_description` ADD `products_spec` TEXT DEFAULT NULL AFTER `products_description` ;

     

     

    MySQL said:

     

    #1060 - Duplicate column name 'products_spec'

     

    what does this mean?

     

    thanks for the help.

     

    It means that you already have a column with the name 'products_spec' in the database


  5. Hi. I have just effected a new install and getting this dreaded 1054 error - c.categories_status

    I see that pdcelec gave a solutions: c.categories_status is not standard code. It comes from the contribution, enable/disable categories

     

    I'm new to oscommerce, can someone please explain how I can rectify this problem.

     

    Thanks

    Replace

    SELECT p.products_id as pID, p.products_date_added as date_added, p.products_last_modified as last_mod, p.products_ordered
    FROM products p, categories c, products_to_categories p2c 
    where c.categories_status='1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p.products_status='1'
    ORDER BY products_ordered DESC

    To

    SELECT p.products_id as pID, p.products_date_added as date_added, p.products_last_modified as last_mod, p.products_ordered
    FROM products p, categories c, products_to_categories p2c 
    where p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p.products_status='1'
    ORDER BY products_ordered DESC

     

    Alternatively, install enable/disable categories


  6. I'm pretty much a php n00b and have been trying to google/find how to sort out my ereg depreciatation problems but I have no idea what I'm doing. I've uploaded OSC V2.2 RC2a PHP 5.3 compatible files downloaded from the contributions. I have also installed the product listing contribution to make it list the product horizontally.

     

    http://shop.beckyliu.com/index.php?cPath=3_10&sort=2a&filter_id=4

     

    This is the error I'm getting on that page above

     

    Deprecated: Function ereg() is deprecated in /srv/disk3/548372/www/shop.beckyliu.com/index.php on line 195
    

     

    Line 195

     

       if ( (!isset($HTTP_GET_VARS['sort'])) || (!ereg('^[1-8][ad]$', $HTTP_GET_VARS['sort'])) || (substr($HTTP_GET_VARS['sort'], 0, 1) > sizeof($column_list)) ) {
         for ($i=0, $n=sizeof($column_list); $i<$n; $i++) {
           if ($column_list[$i] == 'PRODUCT_LIST_NAME') {
             $HTTP_GET_VARS['sort'] = $i+1 . 'a';
             $listing_sql .= " order by pd.products_name";
             break;

     

    Really annoyed and worried this is going to keep happening and I'll find more errors. Thanks!

     

    Change that piece of code with

     

       if ( (!isset($_GET['sort'])) || (!preg_match('/^[1-8][ad]$/', $_GET['sort'])) || (substr($_GET['sort'], 0, 1) > sizeof($column_list)) ) {
         for ($i=0, $n=sizeof($column_list); $i<$n; $i++) {
           if ($column_list[$i] == 'PRODUCT_LIST_NAME') {
             $_GET['sort'] = $i+1 . 'a';
             $listing_sql .= " order by pd.products_name";
             break;
    


  7. Hi,

     

    I have looked through this thread but I dont seem to be able to find the correct answer.

     

    I have made all the document changes ok, no header tag errors etc

     

    But i dont think i can get the .htaccess file correct, think it is the filepath.

     

    the site is www.tanglessalon.co.uk/oscommerce/catalog/

     

     

    What would i write for the correct path? i have just been putting "RewriteBase /catalog/" but it doesnt seem to work and i get a 404 error each time i click on a product. the homepage works ok but none of the product links are working. Been bashing my head againstg wall for hours.

     

    Any help would be great

     

     

    # RewriteBase instructions

    # Change RewriteBase dependent on how your shop is accessed as below.

    # http://www.mysite.com = RewriteBase /

    # http://www.mysite.com/catalog/ = RewriteBase /catalog/

    # http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

     

    # Change the following line using the instructions above

     

    RewriteBase /YOU HAVE TO CHANGE ME/

     

    Which URL rewriter are you using?


  8. Hello :)

     

    I have an oscommerce craft shop which a web person has done for me. If I find a practical problem when selling things I usually find an add on that I think will fix it and the web person puts on the add on (ie read from all of that i'm not technical i'm just trying to sell stuff!).

     

    My problem is that I have 1000's of products and I want to select different products that work well together eg Fabric A coordinates with Fabric B and also Ribbon C. I have Related Products on my site but it is far too time consuming to select each product and coordinating product.

     

    I thought i'd finally found the answer with a Family Product module which seemed to allow me to:

    - Quickly select products from different categories (hopefully a check box system);

    - Create them as a family (I assumed I could name them family 1, 2 etc so I could have lots of different families); and

    - The products in each 'family' will then show up on each others' pages much like Related Products are displayed.

     

    Unfortunately the web person tells me it cant be install as it is based upon the STS (Simple Template System) framework and my site isn't built on STS.

     

    Is there anything else out there that I can use to group products from different categories together easily which is not based on STS?

     

    Any info or leads I can look into gratefully received x

     

    Master products maybe

    http://addons.oscommerce.com/info/1681 for RC2.2a

    http://addons.oscommerce.com/info/7738 for 2.3.x


  9. I cannot figure out how anyone installed this. Copy file /catalog/admin/easypopulate.php into /catalog/admin/ or whatever folder you have placed the osCommerce admin. Copy file /catalog/admin/easypopulate_functions.php into /catalog/admin/ folder.

    Copy file /catalog/admin/includes/classes/table_block.php into /catalog/admin/ folder. Copy the /catalog/admin/EPDocumentation/ folder (3 files) into your /catalog/admin/ folder.

     

    if you take these instruction literally then you have copied the catalog/admin/ to your admin folder 4 times??? If you take just the contents

    and put the first 2 php fils in the root of admin

    easypopulate.php

    easypopulate_functions.php

    then the, table_block.php into the classes, but you have to replace this file because there is already a file that exists in the admin/includes/classes with the same name

    and as far as the EPDocumentation do you take the whole folder into the admin and just drop it or do you take the all the contents out of the EPDocumentation and drop it in the admin root????

    The temp folder I am not sure?? If I do not drop the catalog admin folder from the install into the store admin, the the temp must go in the store root, but if the catalog from the install get dropped in the admin root then I am not sure where to put the temp folder in the store root or the admin root or leave it in the catalog root??? When I say catalog root I mean the installed easy populate catalog not the oscommerce which I have changed its name to port.

     

    Which now brings me to configuration .php files. Will this stay catalog or will I change it to port define ('EP_TEMP_DIRECTORY', DIR_FS_CATALOG . 'temp/'); since my store root is in a folder called port not catalog. So my direct path to the store admin is localhost/port/admin

    The catalog/admin/incudes/boxes/catalog.php" ??? The install instructions say to put this 'Easy Populate' . directly afer '' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '' . The dot suggests that it goes on the same line but not sure. To make matter worse what is in this folder are arrays which looks like they have been defined and the links looked defined as well so how does just dropping this 'Easy Populate' . do anything. By the way I tried it clearly no name or link appears in the products catalog.

     

    Any help greatly appreciated.

    You seem to be creating problems that dont exist. I installed this in about 2 minutes.


  10. Hi there!

     

    I just installed the Google Feeder contri (GoogleFeeder_V_2.8 EU_1_2) wich can be found here; http://addons.oscommerce.com/info/4513

     

    It seems to have installed just fine, i see the option in my admin, it also creates, saves and uploads a feed to Google.

    However, this feed does not contain any articles?

     

    it only shows:

     

    ****

    link title description price image_link id condition expiration_date payment_accepted mpn product_type tax

    ****

     

    Anybody can help me with this ?

    Google shows that the file is recieved however 'no articles are inserted' wich isnt suprising since there are no articles in the feed.txt ?

     

    Any help is welcome, if more info is needed kindly let me know.

     

    many thanks in advance!

     

    regards,

     

    Rayen

    As far as I am aware, only products are listed in the feed not articles


  11. Sorry for the typo it should be as it reads in the breadcrumb trail so it is included in the <title> tag with the site name first then category and then product name.

    In application_top change this bit

    // add the products model to the breadcrumb trail
    to
    // add the products name to the breadcrumb trail
    and the bit below
     if (isset($_GET['products_id'])) {
       $name_query = tep_db_query("select products_name from " . TABLE_PRODUCTS_DESCRIPTION . " where products_id = '" . (int)$_GET['products_id'] . "' AND language_id=" . (int)$languages_id . "");
       if (tep_db_num_rows($name_query)) {
         $name = tep_db_fetch_array($name_query);
         $breadcrumb->add($name['products_name'], tep_href_link(FILENAME_PRODUCT_INFO, 'cPath=' . $cPath . '&products_id=' . $_GET['products_id']));
       }
     }
    


  12. This feeder file is creating standard URLs ["product_info.php?products_id=**"] only even with default ('SEO_ENABLED','true') setting. How to get SEO URLs? Please let us know.

     

    Thanks.

    line 11 shows

    define('SEO_ENABLED','true'); //Change to 'false' to disable if Ultimate SEO URLs is not installed


  13. Dear Mr. Rob,

     

    We just installed this in our website in lieu of Chemo's Ultimate_SEO_URLs.

     

    After this installation, we called a modified googlefeeder.php file for generating the google feed in our website and it started showing the '0' [zero] price for all the products in our website. We had to restore the old db backup due to this.

     

    We had changed the following code in googlefeeder.php

     include_once('includes/classes/seo.class.php');
     $seo_urls = new SEO_URL($languages_id);
    
     function tep_href_link($page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = true) {
        global $seo_urls;
        return $seo_urls->href_link($page, $parameters, $connection, $add_session_id);
     }
    }
    

     

    to

     require_once 'includes/application_top.php';
    

     

     

    We have tried with the following code:

    if (! function_exists("tep_not_null")) {
      function tep_not_null($value) {
         if (is_array($value)) {
            return ((sizeof($value) > 0) ? true : false);
         } else {
            return  ((($value != '') && (strtolower($value) != 'null') && (strlen(trim($value)) > 0)) ? true : false);
         }
      }
    }
    
    if(SEO_ENABLED=='true'){
     require_once DIR_WS_MODULES . 'ultimate_seo_urls5/main/usu5.php';
    
     function tep_href_link( $page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = true ) {
       return Usu_Main::i()->hrefLink( $page, $parameters, $connection, $add_session_id, $search_engine_safe );
     }
    }
    
    if(SEO_ENABLED=='true'){
      $productURL = 'product_info.php'; 
      $productParam = "products_id=";   
    }else{
      $productURL = HTTP_SERVER.'/product_info.php/products_id/';
    }
    

     

    and got the following error message:

    Fatal error: Call to undefined function tep_output_string() in ....../public_html/includes/modules/ultimate_seo_urls5/includes/usu_general_functions.php on line 64
    

     

    Kindly guide us as to what to do in this regard.

     

    Thanks,

     

    Lakshmanan

    Try

    http://addons.oscommerce.com/info/4513 and download 4th January 2010 by FWR media

     

    It works as required


  14. I checked everything and I did everything by the book, I mean by instructions provided with package I downloaded. These instructions says that link should look like www.mysite.com/catalog/index.php/hardware-c-1, but like I wrote above, my link looks like:

    www.mysite.com/product_info.php/hardware-c-1 and actually when you click on it, page without product appears saying Product not found and in browser address but it is displayed like following: www.mysite.com/product_info.php/index.php

     

    Anyone know what is it about and how to fix this please?

    Which download did you use?. The version that I downloaded produces nothing like yours


  15. Google XML Sitemap SEO doesn't work on 2 different servers.

     

    When I run it in CRON or in Task Scheduler on IIS server the following error appears:

     

    Fatal error: Call to a member function retrieveDependencies() on a non-object in

    mysitedir\includes\modules\ultimate_seo_urls5\uri_modules\osc_experimental.php on line 51

     

    I search all the topic about retrieveDependencies problem and see that many people have it. Does anyone have a solution?

     

    do you have USU5 installed?


  16. I just installed this plugin but I ran into some problems right away.

    When I go mouseover product link than I would get this link for example:

     

    www.mysite.com/product_info.php/printer-lexmark-e120

     

    but when I click on it to see product detail then result is that Product is not found, and URL in the browser is following:

     

    www.mysite.com/product_info.php/index.php

     

    and I can not go back with browser back button as it will keep loading this latest page

     

    How to fix this ?

     

    check that you have installed it correctly and read and understood the instructions provided HTH


  17. I am getting the same error. Anyone figured this one out?

     

    1054 - Unknown column 'c.categories_status' in 'where clause'
    
    SELECT p.products_id as pID, p.products_date_added as date_added, p.products_last_modified as last_mod, p.products_ordered
    FROM products p, categories c, products_to_categories p2c where c.categories_status='1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p.products_status='1'
    ORDER BY products_ordered DESC
    
    [TEP STOP]

    c.categories_status is not standard code. It comes from the contribution, enable/disable categories

×