Jump to content

farbor

Members
  • Content count

    28
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Lele
  1. farbor

    One Page Checkout Support

    Hi guys, I have almost complete the implementation of OPC. Unfortunately I am still having few issues. My OPC include the add-on UK Postcode Address Finder provided by craftyclicks http://www.oscommerce.com/community/contributions,6322 Everything seems work fine but once you search for the address using the postcode and then select the correct one, the fields Street Address and City get filled but OPC does not check them. If I finalize the checkout I get the error message saying that the Billing Addrees has not been inserted. The workaround that I have found require to simply click on the form Street Address and the click on another form. I suspect that the Javascript that get trigger once you type in, does not get trigger when select the address for UK Postcode Address FInder contribution. Can anyone point me out in where I can find the code that trigger the check and verify if the address inserted is valid? Any ideas on how to fix this? Thanks in advance for your help. Kind Regards JK
  2. farbor

    [Addon} Modular Front Page

    Hi Jim, Thanks for the upload. The changes fix the original problem but generate another one: E_NOTICE Error Count: 1 Error: Undefined variable: cPath File: includes/modules/front_page/heading_title.php Line: 34 I guess something is still missing. Any ideas? Kind Regards JK
  3. farbor

    [Addon} Modular Front Page

    No worries mate, Anytime. By the way. I think I have found another problem. If you browse in the product_info page everything work but an error is thrown: E_NOTICE Error Count: 2 Error: Use of undefined constant HEADING_TITLE - assumed 'HEADING_TITLE' File: includes/modules/front_page/heading_title.php Line: 36 Any ideas? Cheers JK
  4. farbor

    [Addon} Modular Front Page

    Hi guys, I have installed this contribution on OC2.3.1. Everything seems working fine but I have noticed that there are two errors in the following files: Error: Undefined index: tax_id File: includes/modules/front_page/featured.php Line: 84 Error: Undefined variable: header File: includes/modules/front_page/scroller.php Line: 47 Has anyone seen this before? Any ideas? Regards JK
  5. And that is the issue!!!! If you don't specify the width of the empty tab the extra white space appears. Setting the width fix the problem (although is still clickable...not sure why...) As an extra I have fixed the product info to show the botton Write Review under the Review tab and as well the NO_REVIEW_TEXT. I attach the code to add product_info for everyone else (of course is an example and has not been heavily tested): //PRONUX TMS BEGIN require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_PRODUCT_REVIEWS); $reviewTabContent = ''; $reviews_query_raw = "select r.reviews_id, left(rd.reviews_text, 100) as reviews_text, r.reviews_rating, r.date_added, r.customers_name from " . TABLE_REVIEWS . " r, " . TABLE_REVIEWS_DESCRIPTION . " rd where r.products_id = '" . (int)$product_info['products_id'] . "' and r.reviews_id = rd.reviews_id and rd.languages_id = '" . (int)$languages_id . "' and r.reviews_status = 1 order by r.reviews_id desc"; $reviews_split = new splitPageResults($reviews_query_raw, MAX_DISPLAY_NEW_REVIEWS); if ($reviews_split->number_of_rows > 0) { if ((PREV_NEXT_BAR_LOCATION == '1') || (PREV_NEXT_BAR_LOCATION == '3')) { $reviewTabContent = ' <div class="contentText"> <p style="float: right;">'. TEXT_RESULT_PAGE . ' ' . $reviews_split->display_links(MAX_DISPLAY_PAGE_LINKS, tep_get_all_get_params(array('page', 'info'))) .'</p> <p>'. $reviews_split->display_count(TEXT_DISPLAY_NUMBER_OF_REVIEWS) .'</p> </div> <br />'; } $reviews_query = tep_db_query($reviews_split->sql_query); while ($reviews = tep_db_fetch_array($reviews_query)) { $reviewTabContent .= ' <div> <span style="float: right;">'.sprintf(TEXT_REVIEW_DATE_ADDED, tep_date_long($reviews['date_added'])) .'</span> <h2><a href="' . tep_href_link(FILENAME_PRODUCT_REVIEWS_INFO, 'products_id=' . $product_info['products_id'] . '&reviews_id=' . $reviews['reviews_id']) . '">' . sprintf(TEXT_REVIEW_BY, tep_output_string_protected($reviews['customers_name'])) . '</a> </h2> </div> <div class="contentText"> '. tep_break_string(tep_output_string_protected($reviews['reviews_text']), 60, '-<br />') . ((strlen($reviews['reviews_text']) >= 100) ? '..' : '') . '<br /><br /><i>' . sprintf(TEXT_REVIEW_RATING, tep_image(DIR_WS_IMAGES . 'stars_' . $reviews['reviews_rating'] . '.gif', sprintf(TEXT_OF_5_STARS, $reviews['reviews_rating'])), sprintf(TEXT_OF_5_STARS, $reviews['reviews_rating'])) . '</i> </div> <div class="buttonSet"> <span class="buttonAction">' .tep_draw_button(IMAGE_BUTTON_WRITE_REVIEW, 'comment', tep_href_link(FILENAME_PRODUCT_REVIEWS_WRITE, tep_get_all_get_params()), 'primary'). '</span> </div>'; } } else { $reviewTabContent = ' <div class="contentText">'.TEXT_NO_REVIEWS.' </div> <div class="buttonSet"> <span class="buttonAction">' .tep_draw_button(IMAGE_BUTTON_WRITE_REVIEW, 'comment', tep_href_link(FILENAME_PRODUCT_REVIEWS_WRITE, tep_get_all_get_params()), 'primary'). '</span> </div>'; } $TMS->tab[1]['content'] = $product_info['products_card']; $TMS->tab[2]['content'] = $reviewTabContent; $TMS->tab[3]['content'] = $product_info['products_feature']; $TMS->tab[4]['content'] = $product_info['products_use']; $TMS->setLanguage('', $_SESSION['language']); $TMS->generateTabMenuSection(true); //PRONUX TMS END ?> Hope this helps. Cheers JK
  6. I think I found the root of the problem!!! Nothing to do with your code but something stupid that I have done or a bug not sure. In the Conf.php I have added this line: $reviews_query = tep_db_query("select count(*) as count from " . TABLE_REVIEWS . " r, " . TABLE_REVIEWS_DESCRIPTION . " rd where products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and r.reviews_status = 1 and r.reviews_id = rd.reviews_id and rd.languages_id = '" . (int)$languages_id . "'"); $reviews = tep_db_fetch_array($reviews_query); $CONF['tabs']['en'][2] = 'Reviews('.$reviews['count'].')'; To populate the name of the second tab with Reviews(x) The tab is populated correctly but there is an extra white row between the tab header and the tab body (for all the tabs). If I change to $CONF['tabs']['en'][2] = 'Reviews'; The layout issue is gone and the tab shows correctly (last tab is still selectable though!) Am I concatenate the strings uncorrectly? Does $reviews['count'] need to be cast in some way? Problem is easily reproducible just adding the above code. Please let me know if you have any idea? Kind Regards JK
  7. Thanks for the reply, I am now testing 2.3.1 to see if I can move the image application on my website. Unfortunately I have noticed something weird that I did not noticed yesterday.... Same problem reproducible in both my 2.2 and 2.3.1 clean install. 3 Issues: 1) Just below the tabs before the content there is a white section....not sure where that come from 2) The last tab on the right (horizontal alignment) is missing the right border 3) If you have an empty tab as last tab, this is still selectable. The demo site is not affected by any of the above problem (http://oscommerce.pronux.ch/product_info.php?products_id=28). I wonder if there is something different in the files uploaded in the contributions or I am doing something fondamentally wrong.... Any ideas? Kind Regards JK
  8. LOL That's annoying as I am on 2.2 and I cannot upgrade right now. Do you know a similar contribution for 2.2? Thanks in advance for the help. Kind Regards JK
  9. farbor

    ULTIMATE Seo Urls 5 - by FWR Media

    Hi Mate, Thanks for your hint on the www redirect...it works perfectly. Just an extra question (hopefully the last). I noticed that under extra in this release there is a sitemap functionality that generate index,categories,product and manufacturer. This almost replace completely the add-on Google XML Sitemap. If that is the case I would be happy to drop that add-on completely. My only corcern is that looking into the code I cannot see a sitemap generated for the pages. Is there a reason for that? Please let me know. Thanks in advance for your helpful support. Happy New Year!!! Cheers JK
  10. farbor

    ULTIMATE Seo Urls 5 - by FWR Media

    M8, That works perfectly...I realised there was an extra / on my configure.php....GOOD SPOT!!!! Can I ask you an unrelated question? What rules can I add to redirect any http://organiculture.co.uk to http://www.organiculture.co.uk ? Thanks again to check my site and solve the problem. Really appreciated! Cheers JK
  11. farbor

    ULTIMATE Seo Urls 5 - by FWR Media

    Hi, I have just upgrade my Ultimate SEO from Chemos original Ultimate Seo Urls version 2 ( including modifications by jackmcs to v22d_10) to the latest release. I have as well apply the changes to fix the two bug discovered after the release. Unfortunately even though the installation seems completed succesfully the redirections failing now. Let me clarify: I can access succesfully my index.php but it fails to redirect if selecting any categories or products with the following error: The page isn't redirecting properly Firefox has detected that the server is redirecting the request for this address in a way that will never complete. Any ideas? Previous version was working fine. Another thing I have notice is if I switch to true redirection for index.php, if I access www.mywebsite.co.uk/index.php it does not redirect to www.mywebsite.co.uk. Is it normal? Thanks in advance for your help. Kind Regards JK
  12. farbor

    NEW! Complete Order Editing Tool!

    Hi RusNN, Thanks for your feedback. It is really appreciated. I saw those two threads already but were not really applicable in my case. I agree with you that CCGV does so many checks that implements the same functionality in the back-end will be too complicated. In the other hand I do not think a shop administrator would really need the same type of functionality. It would be enough for me for example, to find a way to subtract from the subtotal: in that way you could easily simulate a gift, a discount coupon or a free shipping coupon. Maybe set a variable to 0 and when calculate the order total always substract that variable. If a discount is not applied then the total would remain the same (-0) if some discount is applied the the variable will be substract to the subtotal simulating the discount. I supposed it could be simply done with: if (var is set) then var=value else var=0; ordert_total=subtotal-var Does it make any sense? Do you know which part of the code I should change to get that type of functionality? Do you know any other possible workaround? Thanks in advance for your feedback. Cheers JK
  13. farbor

    NEW! Complete Order Editing Tool!

    Hi guys, I apologize in advance if this question has been already answered. I have been through the thread and I have found many other person with similar problem, but I could not find a proper solution. I have CCGV add-on deployed on my website (ot_coupon, ot_gv) unfortunately when I add a new product using order editor and then update, my discount is not applied at all(it is not sum up either though). i.e. Subtotal 36.50 Discount 3.28 Shipping 5.10 Total 41.60 Are those kind of coupon supposed to work out of the box? In the description of this add on seems so: " PLUS! The ability to add products to an existing order, reliably update order totals, insert coupons & discounts & extra fees, update tax on individual products, edit product information on individual orders, update product quantities, product prices, and more!" Is there anything that need to be change other than what is described on the instructions? Can anyone point out where should I look to fix this issue? Thanks in advance for your help. Kind Regards JK
  14. Guys, Quick question regarding something that I have noticed testing the app. If you select free shipping it simply ignores the coupon amount, making impossible to have free shipping + a discount on the product. Is that normal? Anyone noticed this? Thanks in advance for your help. Cheers JK
  15. farbor

    Header Tags SEO

    Hi Jack_mcs, Thanks for your quick reply. I could not see anything wrong in the install itself: I have review the code multiple time and again if all the metatag are filled I suspect that the code is fine. Is there any particular settings that need to be enable on the server? My PHP version is 5.2.14. Another problem that I have noticed in the test is the following: Title length warning: (Suggested range is 60 to 120 characters) explain for English The Title for Argan Oil LIP BALM - 5.7 ml - I Provenzali Bio may be too short. It is 46 characters long. for English The Title for Pure Argan OIL - 50 ml - I Provenzali Bio may be too short. It is 41 characters long. The Title for Organic EXTRA VIRGIN OLIVE OIL "Zahir" - 0.5 l - San Comaio may be too short. It is 59 characters long. The Title for Organic BODY OIL -125 ml - NATURAL SENSE' for your Bebe' may be too short. It is 56 characters long. The Title for Delicate LAUNDRY - 1000 ml - NATURAL SENSE' for your Bebe' may be too short. It is 58 characters long. The Title for Organic BATH FOAM - 200ml - NATURAL SENSE' for your Bebe' may be too short. It is 57 characters long. The Title for Organic SHAMPOO - 200 ml - NATURAL SENSE' for your Bebe' may be too short. It is 56 characters long. The Title for DISHES & TABLEWARE Detergent - 1000 ml - Folia may be too short. It is 46 characters long. The Title for DISHWASHER Detergent - 1000 ml - Folia may be too short. It is 38 characters long. The Title for FLOORS & HARD SURFACES Detergent - 1000 ml - Folia may be too short. It is 50 characters long. The Title for HANDWASH & WASHING MACHINE Detergent - 2000 ml - Folia may be too short. It is 54 characters long. The Title for Multiuse with Active Oxygen may be too short. It is 27 characters long. The Title for "Fiori d'Arancia" MARMALADE - 240 gr - BioAgricola Ferraro may be too short. It is 58 characters long. The Title for Argan Oil BEAUTY SOAP - 250 gr - I Provenzali Bio may be too short. It is 49 characters long. The Title for Argan Oil BODY GEL - 125 ml - I Provenzali Bio may be too short. It is 46 characters long. The Title for Pure Argan BUTTER - 75 ml - I Provenzali Bio may be too short. It is 44 characters long. Meta Description length warning: (Suggested range is 15 to 300 characters) explain for English The Meta Description for Pure Argan OIL - 50 ml - I Provenzali Bio may be too long. It is 351 characters long. for English The Meta Description for Organic EXTRA VIRGIN OLIVE OIL "Zahir" - Special Edition - 0.5 l - San Comaio may be too long. It is 304 characters long. The Meta Description for Organic RED PESTO in Extra Virgin Olive Oil - 180 gr - Artigiana Genovese may be too long. It is 305 characters long. The Meta Description for Organic SHAMPOO - 200 ml - NATURAL SENSE' for your Bebe' may be too long. It is 383 characters long. The Meta Description for Organic GENOESE PESTO in Extra Virgin Olive Oil - 180 gr - Artigiana Genovese may be too long. It is 349 characters long. The Meta Description for Argan Oil BEAUTY SOAP - 250 gr - I Provenzali Bio may be too long. It is 324 characters long. If you actually count the number of char, it does not match the number of char shown by the test. Is this a known issue? Any ideas on where to check? Thanks again in advance for all your help. Cheers JK
×