Jump to content
Latest News: (loading..)

zpupster

Members
  • Content count

    339
  • Joined

  • Last visited

Everything posted by zpupster

  1. zpupster

    Header Tags SEO

    thanks for the help-14 steve 14. that fixed that problem. but when i try the link--error Not Found The requested URL /stead/cpanel/FILENAME_HEADER_TAGS_KEYWORDS was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. header_tags_seo_keywords.php is there under cpanel. this is what is on admin/includes/languages/english.php // header_tags_seo text in includes/boxes/header_tags_seo.php define('BOX_HEADING_HEADER_TAGS_SEO', 'Header Tags SEO'); define('BOX_HEADER_TAGS_ADD_A_PAGE', 'Page Control'); define('BOX_HEADER_TAGS_SILO', 'Silo Control'); define('BOX_HEADER_TAGS_FILL_TAGS', 'Fill Tags'); define('BOX_HEADER_TAGS_KEYWORDS', 'Keywords'); define('BOX_HEADER_TAGS_TEST', 'Test'); /*** End Header Tags SEO ***/ ok i got the link to work by adding----define('FILENAME_HEADER_TAGS_KEYWORDS', 'header_tags_seo_keywords.php'); to admin/includes/filenames /*** Begin Header Tags SEO ***/ define('FILENAME_HEADER_TAGS_SEO', 'header_tags_seo.php'); define('FILENAME_HEADER_TAGS_SILO', 'header_tags_seo_silo.php'); define('FILENAME_HEADER_TAGS_KEYWORDS', 'header_tags_seo_keywords.php'); define('FILENAME_HEADER_TAGS_FILL_TAGS', 'header_tags_fill_tags.php'); define('FILENAME_HEADER_TAGS_TEST', 'header_tags_test.php'); /*** End Header Tags SEO ***/ new error: 1146 - Table 'comta3_osc23.TABLE_HEADERTAGS_KEYWORDS' doesn't exist select * from TABLE_HEADERTAGS_KEYWORDS order by language_id, found DESC, keyword ASC here i am confused it looks like a database error--isee now same error as Adamanto75. somewhere it is not referencing the table, but where??? off to look can someone help? thanks, craig
  2. zpupster

    Header Tags SEO

    hello, this is an amazing add on , just what we need for our site. thank you, jack_mcs. i had a heavily modded socomm 2.2 site and i could never get this to install, close but not quite. i am in the process of upgrading to 2.3 and when we added headertags 3.27. i have a few issues. in the screen shot in the admin section under the Header Tags SEO. there is: Page Control Fill Tags Test under my Header Tags Seo: Page Control Silo Control BOX_HEADER_TAGS_KEYWORDS Fill Tags Test BOX_HEADER_TAGS_KEYWORDS is probably wrong i searched my site and can not find this referenced. could you please comment on this. thanks, craig
  3. zpupster

    reports

    hello forum, has any body used a report add on that will-- list product-- price --qty-- wt i searched for a while and did not see what i need, thought i would ask the community. thanks, craig
  4. zpupster

    Automatically send data feed to Froogle

    jack, i changed that code without the comma, saved it, ran another google feed and the commas are still present in the price. any ideas?? craig
  5. zpupster

    Automatically send data feed to Froogle

    hey jack, for some reason google is rejectingmy googlefeed for all my products with price over 1000.00 us dollars. i believe it is becasue of the comma. ie 1,400.00. should be 1400.00 i think it is from this code in google feeder where the comma is added, but i do not know how to get rid of the comma. if ( $row->prodStatus == 1 ) { if (CONVERT_CURRENCY) { $row->price = preg_replace("/[^.0-9]/", "", $row->price); $row->price = $row->price * $row3->curUSD; $row->price = number_format($row->price, 2, '.', ','); } could you please help? craig
  6. zpupster

    Automatically send data feed to Froogle

    hello jack, i need to have the product_category for google done. i can use the AddMoreFields_V_1.2.zip to add a field product_category in the let's say --products table ( haven't decided yet) now on to googlefeeder.php version 2.8 the latest. i tried to follow along with BRAND column and added Products category throughout the script have to add to /*************** BEGIN MASTER SETTINGS ******************/ define('OPTIONS_ENABLED_PRODUCT_CATEGORY', 1); and then //the following only matter if the matching option is enabled above. define('OPTIONS_AGE_RANGE', '20-90 years'); define('OPTIONS_Product_CATEGORY', category>subcategories>subsub'); and then later $extraFields = ''; if (OPTIONS_ENABLED_PRODUCT_CATEGORY == 1 && strlen(OPTIONS_PRODUCT_CATEGORY) == 0) { //PRODUCT_CATEGORY is enabled but not set so load from database $extraFields .= ' products.products_category as products_category, '; //create optional section if(OPTIONS_ENABLED == 1) { if(OPTIONS_ENABLED_PRODUCT_CATEGORY== 1) $output .= "\ products_category"; //optional values section if(OPTIONS_ENABLED_CATEGORY == 1) $output .= "\t" . (isset($row->products_category) ? $row->products_category : (strlen(OPTIONS_PRODUCTS_CATGORY) ? OPTIONS_PRODUCTS_CATEGORY : "Not Supported")); i am not a php wizard or anything but do think this will work?? or ama i missing something? thanks, craig
  7. install the latest google feed by jackmcs. go to Googlefeeder.php and edit and those warnings should go away. all except the "product category", that should be updated about 9-22-2011 craig
  8. zpupster

    Sitemap SEO

    jack, i tried to pm but it i received an error: that you can not receive any new messages. craig
  9. zpupster

    Sitemap SEO

    thanks for responding! i turned off enable seo urls and it works fine. i am using Ultimate SEO URLs v2.2d. after further look the code on product_info.php is taking the category link from sitemap_seo.js : <?php if (SITEMAP_SEO_SHOW_INDIVIDUAL_CATEGORY_SITEMAP == 'true') { ?> <tr> <td class="smallText"><a href="javascript:displaySitemapCategory();" class="smallText"><span style="vertical-align:text-bottom; "><img src="images/sitemap_arrow.jpg" alt="" border="0"></span><span style="padding-left: 3px;"><?php echo TEXT_SITEMAP_RELATED_CATEGORIES; ?></span></a></td> </tr> and the category links on sitemap.php are taken from this code on the sitemap.php ( if i am right??): /****************** DISPLAY CATEGORIES *********************/ $showCategories = ''; if (tep_not_null($settings['heading_categories'])) { $showCategories .= '<tr><th class="sitemapHeading" align="' . SITEMAP_SEO_HEADING_ALIGNMENT . '">' . $settings['heading_categories'] . '</th></tr>'; } $showCategories .= '<tr><td class="sitemap">'; $class = (SITEMAP_SEO_DISPLAY_PRODUCTS_CATEGORIES == 'true') ? 'category_tree.php' : 'category_tree_no_products.php'; require DIR_WS_CLASSES . $class; $osC_CategoryTree = new osC_CategoryTree(); $showCategories .= $osC_CategoryTree->buildTree(); $showCategories .= '</td></tr>'; i changed the closing tag for <th...> from </td> to </th>, but that is just minor. is there any way i can get this to work, or if not maybe i will remove the related categories on the product_info.php page. thanks again, craig
  10. zpupster

    Sitemap SEO

    hello jack, first of all this is a great contribution. i have run into a problem though--my realted category(ies) links on the bottom of my product page ( they work on the sitemap.php page) does not take me to the related category but takes me back to the homepage. i searched "related categories" in this topic but did not find anything quite like my problem. the link to my category in source looks like this: <a class="sitemap" title="title" href="http://mysite.com/series-c-_23.html">my category</a> but my URL for that category looks like this: http://mysite.com/series-c-22_23.html why it takes me back to my homepage rather than erroring is also strange. all "related categories" links are similiar. "related products" links are all fine. could you comment what i did wrong or why this is happening. thanks, craig
  11. hello jack, first of all this is a great contribution. i have run into a problem though--my realted category(ies) links on the bottom of my product page ( they work on the sitemap.php page) does not take me to the related category but takes me back to the homepage. i searched "related categories" in this topic but did not find anything quite like my problem. the link to my category in source looks like this: <a class="sitemap" title="title" href="http://mysite.com/series-c-_23.html">my category</a> but my URL for that category looks like this: http://mysite.com/series-c-22_23.html why it takes me back to my homepage rather than erroring is also strange. all "related categories" links are similiar. "related products" links are all fine. could you comment what i did wrong or why this is happening. thanks, craig
  12. hello jack, first of all this is a great contribution. i have run into a problem though--my realted category(ies) links does not take me to the related category but takes me back to the homepage. i searched "related categories" in this topic but did not find anything quite like my problem. the link to my category in source looks like this: <a class="sitemap" title="title" href="http://mysite.com/series-c-_23.html">my category</a> but my URL for that category looks like this: http://mysite.com/series-c-22_23.html why it takes me back to my homepage rather than erroring is also strange. all "related categories" links are similiar. "related products" links are all fine. could you comment what i did wrong or why this is happening. thanks, craig
  13. zpupster

    Google Checkout - free shipping not working

    damian, no this did not work. it flashes shipping 0.00 for a second and then is over ridden by what i have there. i tried installing freeamount w/ minimum and the google checkout add on to that, something looks strange about that code. //**************googlecheckout/shipping_methods.php****************** Find: $mc_shipping_methods = array( Add directly below: 'freeamount' => array( 'domestic_types' => array( 'freeamount' => 'Free shipping' ), ), Find: $mc_shipping_methods_names = array( Add directly below: 'freeamount' => 'Free shipping' , it does not look right like it has commas instead of semicolons and it is missing a parenthesis, i tried to fix but still received errors. craig
  14. zpupster

    return to google checkout

    hello support, i am in sandbox mode, i am finally got the order to go thru. everything looks fine. except this one link return to my site. it gives this error: 1054 - Unknown column 'Array' in 'where clause' select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id from products p, products_description pd where p.products_status = '1' and p.products_id in (Array) and pd.products_id = p.products_id and pd.language_id = '1' [TEP STOP] any suggestions?? thanks, craig
  15. zpupster

    return to google checkout

    The 'p.products_id in (Array)' is not in your database, that's why your getting that error. i am confused, from this line in gc_return.php . TABLE_PRODUCTS . " p, " when i go to the products table there is a column labeled and filled products_id if there is more information, you need to help me please let me know. thanks, craig
  16. zpupster

    return to google checkout

    do you think if i just add it then everything will be all right. actually i do not know how to add it but, i will find out. thanks, craig
  17. hello, i just installed the 2 minute test again after updating my php from 4.4 to 5.21-- and it works fine now. but it raises a question-- i will install a contr. that gives each category a description. ( that is, when i find one --can someone refer me to a good one, i have loked at some but those are not quite what i need????????) my question is will the keywords from the description be picked up by kissmt, if i use an include i.e. "category_name.php" thanks, craig
  18. hello, i have installed cDynamic meta v 1.52. i was under the impression that the module would scan my page and pick out keywords and store them in a database. well that was wishful thinking huh? anyway, i enterd keywords in the database and a description for index.php, product_info.php. index.php good product_info--categories and subcategories are good. but the products, there is no keywords, and i do not know how to get some to show up. i have ultimate seo urls 22d installed , i looked over the configuration to see if somthing could configured to help, but i did not notice anything. thanks, craig
  19. Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /home/site/public_html/includes/modules/kiss_meta_tags/kiss_meta_tags.php on line 23 this is the error i get when i install kiss MT any ideas? craig
  20. i was installing the sql file for the cDynamic Meta tag module and received this error: INSERT INTO `configuration` VALUES ( 190, 'Store Description', 'STORE_DESCRIPT', 'The Next Level Of osCommerce', 'Place your sites meta description here, for use with dynamic meta-tags<br>Leave empty for no description<br>', 1, 40, NULL , '2003-12-05 05:01:41', NULL , 'tep_cfg_textarea(' ) ; MySQL said: #1062 - Duplicate entry '190' for key 'PRIMARY' i do not know waht to do here, i did back up my database, do i need to import the old back in or is there a way i can fix this error so i can complete this install?? thanks, craig
  21. hello, i can not edit any products, all buttons in the section admin>catalog> categories and products have stopped working thinking about the last thing i did was mod to seo urls, i changed the categories.php from this: $action = (isset($HTTP_GET_VARS['action']) ? $HTTP_GET_VARS['action'] : ''); to this: // Ultimate SEO URLs v2.2d // If the action will affect the cache entries if ( preg_match("/(insert|update|setflag)/i", $action) ) include_once('includes/reset_seo_cache.php'); does anyone see anything wrong with this?? craig
  22. thanks jack, the line was not to be replaced but to be added after, everything fine now. thanks again, craig
  23. i tried setting the products,categories, and manufactures cache to false updating it from true. no help. i tried setting enable seo cache to save queries to false. no help. and lastly i tried setting seo urls to false. and that did not help. am i missing your point about updating? i mean do i have to install an update for 2.2.10 because i didnot see one. craig
  24. hello, thinking about the last thing i did was mod to seo urls, i changed the categories.php from this: $action = (isset($HTTP_GET_VARS['action']) ? $HTTP_GET_VARS['action'] : ''); to this: // Ultimate SEO URLs v2.2d// If the action will affect the cache entries if ( preg_match("/(insert|update|setflag)/i", $action) ) include_once('includes/reset_seo_cache.php'); therre are no errors just refreshes the page. does anyone see anything wrong with this?? craig
  25. zpupster

    out of stock

    hello, looking for a out of stock addon. found this http://www.oscommerce.com/community/contributions,4884. this addon will show out of stock and remove add to cart button for those items out of stock. but let's say -- i have 10 items, the product is in stock, but the customer orders 20. how should i handle that. sure i could install it and see if this addon will work, if it does not try to modify it, and if it did not work uninstall it, but i am trying to save sometime and ask for some help so-- if anyone has experience with this module or knows of one that will do what i need or can offer some advice for me so that i can accomplish my goal, i would appreciate it. thanks, craig
×