Jump to content

varis

Members
  • Content count

    10
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    ano
  1. varis

    All Products SEO

    Ok, but anyways, Jack - You gave me a hint where to look for and I tried to do that by myself. Thank You very much. If anyone else has the same problem, here's the solution: Source all-products.php file has those lines: ----------------------------------------------------- if (in_array($firstletter, $letters) || in_array($firstletter, $numbers)) { $where="where pd.products_name like '$firstletter%' AND p.products_status='1' "; $breadcrumb->add(NAVBAR_TITLE . '-'. $firstletter, tep_href_link(FILENAME_ALLPRODS_SEO, 'fl='.$firstletter, 'NONSSL')); } else if (! tep_not_null($firstletter)) $breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_ALLPRODS_SEO, '', 'NONSSL')); ----------------------------------------------------- You don't have to be a pro codder to see what happens here. When we've got any letter chosen to display products by, there's one extra line which is setting $where variable. So we have to add it also to the second if. The code then should look like that: ----------------------------------------------------- if (in_array($firstletter, $letters) || in_array($firstletter, $numbers)) { $where="where pd.products_name like '$firstletter%' AND p.products_status='1' AND p.products_quantity > '0'"; $breadcrumb->add(NAVBAR_TITLE . '-'. $firstletter, tep_href_link(FILENAME_ALLPRODS_SEO, 'fl='.$firstletter, 'NONSSL')); } else if (! tep_not_null($firstletter)) $where="where pd.products_name like '$firstletter%' AND p.products_status='1' AND p.products_quantity > '0'"; $breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_ALLPRODS_SEO, '', 'NONSSL')); ----------------------------------------------------- I've added also " AND p.products_quantity > '0' " to both of them as Jack told me to do, but I guess it should be working even without that as far as products_status is automatically setting to 0 when products_quantity equals 0.
  2. varis

    All Products SEO

    Sorry, I didn't check the link I've put. Of course it's the same link FWR Media wrote on the first page of this thread (third post). Not "All products with images", but "All products SEO". > The right link < Can You really find two instances of p.products_status in there? :)
  3. varis

    All Products SEO

    Yes, I think so - I'm using version 1.2 from there: http://www.oscommerce.com/community/contributions,6216/category,3/search,all+products+seo Even when I looked into that package once again, there's still only one instance of p.products_status, or am I blind? :) Even though, I changed that one as You told me, from: $where="where pd.products_name like '$firstletter%' AND p.products_status='1' "; to: $where="where pd.products_name like '$firstletter%' AND p.products_status='1' and p.products_quantity > 0"; But in vain. Nothing has changed.
  4. varis

    All Products SEO

    Thanks for reply Jack. You mean all-products.php file, the one in catalog? There's only one instance of that string "p.products_status" and it's there: $where="where pd.products_name like '$firstletter%' AND p.products_status='1' "; And I guess it's not about that one.
  5. varis

    All Products SEO

    Ok, I've managed to make it work - my split_page_results.php file was corrupted. But still, is there any possibility NOT to show sold out products?
  6. varis

    All Products SEO

    Hello, I've installed All Products SEO and got a problem. Some of my products are set to be sold out, so I don't really want to show them on the list of my products. When I choose a letter on all-products.php, it's ok. Products that are sold out, aren't seen, but when I choose "Show All", all the products are listed, even those sold out. And there's one more problem then - I've got 40 products (including those sold out) and there appear 2 pages. On first one it's written "Showing 1-20 (from 40) products", on the second one "Showing 21-40 (from 40) products", and it's logic. But the thing is, that on both of them, there are listed all 40 products, so the second page is like a duplicate of the first one. Is there any way to fix this?
  7. varis

    Header Tags SEO

    Where exactly in Page Control can I see the other languages? I can't find it. By the way - polish language, which I use, has it's id set to 1 as it was written somewhere in readme file. Edit: Ok, in phpMyAdmin I changed english language to id = 1 and everything seems to work well, but why the hell isn't it working for polish language? I've put everything that was in english folders in installation catalog to polish folders.
  8. varis

    Header Tags SEO

    I tried installing it 3 times, so I guess it's not installation fault. How can I check if admin is using different database than shop? In configure.php file in both of them? They are ok, connecting to the same database. There's also "page index.php?language=pl" text in my upper left corner of the screen. I don't know what's going on. I made a screenshot of my Page Control panel, take a look at it: http://img39.imageshack.us/f/screenwsh.jpg/
  9. varis

    Header Tags SEO

    Thanks for reply. But I've already said I updated it in Page Control / index.php, but it didn't work. I mean, as I said before - it is saved there, because every time I get there, my title is written there, but it doesn't actually work for real site. When I'm in www.mysite.com/index.php, the title is still "Replace me (...)" and so it is for others categories (but there are a few ones in which title is like I set in Page Control / index.php). That's strange.
  10. varis

    Header Tags SEO

    Hello, I've got a problem here. I installed Header Tags SEO and everything seems to be ok, I don't get any errors when I make test. The problem is that my main page (index.php) doesn't have a title even though I set it in "Page Control". It still shows "Replace me in Page Control under index.php". No difference if I set a default title, or not. I went into phpMyAdmin to see if everything is ok in database, but everything seems to be ok. In "headertags" field "index.php" has it's own page_title, page_description, etc. Second thing is, that the same thing happens to some categories. Some of them are titled with default title that I set in Page Control, others still have "Replace me (...)" title. I don't know what's going on. Could You, please, help me with that? // Edit: When I select "index.php" in "select an option" field in Page Control and change Title, Description, etc. and click "update" it saves, but when I click "View Result", it shows "Replace me (...)".
×