Jump to content

quicker

Members
  • Content count

    21
  • Joined

  • Last visited

Everything posted by quicker

  1. return $seo_urls->href_link($page, $parameters, $connection, $add_session_id);
  2. I just upgraded to the new version and this is what my homepage says: Fatal error: Call to a member function href_link() on a non-object in /home/user/public_html/website/includes/functions/html_output.php on line 17 I followed instructions exactly as to how to upgrade.
  3. Does the new version fix my problem?
  4. What could make www.mydomain.com/category-cat-c27?osCsid.html not work? P.S: WAIT!!! I think I know why the link along with the two others of its type might not work, but I'll need your assistance. The original link does not link directly to a category, but redirects/points to a category in my store: www.domain.com/index.php?cPath=27.
  5. "It's how osCommerce works" as you said last time regarding part one of the problem (long URL). The long URL problem I've decided to ignore, because you said it could be alleviated by "preventing spider session," which I enabled. BUT the second part of the problem I cannot ignore. Let me elaborate for you. Ultimate SEO tries to redirect a link on my template osCommerce. The first time that it does so for a first-time visitor (or one who has cleared browser cache), the link, which is among two others of its type that also have the same problem, does not render correctly. Instead of a html page, for example: www.mydomain.com/category-cat-c27.html, the URL that is rendered is as follows: www.mydomain.com/category-cat-c27.html?osCsid.html The part in bold is the problem -- it makes the rendered page broken/nonexistent. The second time and so on, presumably after caching, the URL is the first one I mentioned (www.mydomain.com/category-cat-c27.html), and there are no broken links. There is nothing wrong with my shop's configuration, because in my backup of my store without Ultimate SEO installed, the link, along with the two others of its type, work correctly without broken pages.
  6. Help! I got a serious problem. Every time I shut down my computer OR I clear my browser's cache, the FIRST time I click a link on my site, the URL is long, for example: www.domain.com/category1/?osCsid=l7p9sjkl8mk681hkvehksa3ef4. I KNOW I already mentioned this before. BUT, here is a related problem: By doing the same procedure (turn off computer or clear browser cache), and clicking another link type/area (picture/button links - 3 of them), not only do I get a URL along the lines of www.domain.com/category--c-27?osCsid.html, but also the page is broken. Oops! This link appears to be broken (Firefox). The second time and so forth that I click anything, everything is fine.
  7. quicker

    Header Tags SEO

    I got a problem. When I click on any product on my site, I get: Fatal error: Cannot redeclare do_magic_quotes_gpc() (previously declared in /home/site/public_html/site/includes/functions/compatibility.php:18) in /home/site/public_html/site/includes/functions/compatibility.php on line 30
  8. quicker

    Header Tags SEO

    I've finished installing this addon though I skipped parts that weren't in my template-version files. When I click "test" in admin, I get this diagnosis: The Header Tags head code for the product_reviews.php file cannot be found. The Header Tags head code for the product_reviews_info.php file cannot be found. The Header Tags head code for the product_reviews_write.php file cannot be found. The Header Tags head code for the specials.php file cannot be found. I don't recall the catalog_install instructing me to add the code to the above files.
  9. quicker

    Header Tags SEO

    Hi, I'm using a osCommerce template, so my index.php file is altered and I can't find some parts from the catalog_readme that need to be replaced. You have suggested to skip it. If I skip some of those parts that needed to be replaced or added to, how seriously will this addon be affected in performance/effectiveness? Thanks
  10. quicker

    Google XML Sitemap SEO

    Oh yes, I forgot to mention. When I go through the process in localhost, everything is just fine. But on my webhost (Bluehost), I get the above problem. If that helps.
  11. quicker

    Header Tags SEO

    Can I install this addon to osCommerce version 2.2 RC1?
  12. quicker

    Google XML Sitemap SEO

    I did go through all the instructions. I meant that when I tried generating the sitemap via domain.com/googlesitemap/index.php, the "[an error occurred while processing this directive]" comes up in the browser. I've set all the permissions to 777.
  13. quicker

    Google XML Sitemap SEO

    I went through all the instructions in the readme, and then when I get to the last step (go to domain.com/googlesitemap/index.php), an error occurs - "[an error occurred while processing this directive]" comes up in the browser. I've set all the permissions to 777, so I don't know why I'm getting this problem.
  14. quicker

    Header Tags SEO

    Hi, Jack, My site is RC1, could I directly install this addon or should I upgrade it to RC2 before I install this? Thanks!
  15. quicker

    Google XML Sitemap SEO

    [an error occurred while processing this directive] when I go to domain.com/googlesitemap/index.php. Permissions all 777.
  16. Hi, thanks for the reply. Could you tell me what the "prevent spider" option does to fix the problem? Also, where is the addons section located so that I can update the spider file? So, osCommerce is supposed to generate long URLs like the example I gave, and what Ultimate SEO does is shorten the URL after the first time a link is clicked? Thanks
  17. Hi, I've installed Ultimate SEO. I noticed that the first time I click a link on my site after installation, the URL is not a shortened URL; a URL like this comes up: http://www.somedomain.com/category.html?osCsid=0nq20ba91o9jjkide9t6ed5td7. The second time and so forth that I click any link on my site, the URL is as intended - for example http://somedomain.com/category.html. The same problem of the aforementioned long URL happens every time I clear my browser's cache, I've noticed. Is this something that is intended by Ultimate SEO? Or have I not installed Ultimate SEO properly? If it is intended by Ultimate SEO, will it negatively affect search engine crawlers' indexing?
×