Jump to content

JoeB

Members
  • Content count

    57
  • Joined

  • Last visited

Everything posted by JoeB

  1. JoeB

    PC Pro Creator

    I have not read this complete post on this but does anyone use this add-on for other products besides computers? I have tried the custom product builder and like some of it but want to control the quantities of the items I am building. I am building custom drum sets. So pick a base drum and then you have a choice of picking the lugs, heads, hoops and claws. If my base drum requires 20 lugs and the inventory is below 20 then it will only show the lugs that are above 20. Is this possible? If anyone is using this add-on without any custom modifications for any other products could you post a link please.
  2. I have not read this complete post on this but does anyone use this add-on for other products besides computers? I have tried the custom product builder and like some of it but want to control the quantities of the items I am building. I am building custom drum sets. So pick a base drum and then you have a choice of picking the lugs, heads, hoops and claws. If my base drum requires 20 lugs and the inventory is below 20 then it will only show the lugs that are above 20. Is this possible? If anyone is using this add-on without any custom modifications for any other products could you post a link please.
  3. JoeB

    AJAX Attribute Manager support

    I wish I could get this to work for me.
  4. JoeB

    AJAX Attribute Manager support

    Look at your tables for products_attributes. You probably have another field most likely called sort. You need to add that to your insert call. It can be as simple as just putting in another set of "" to make it work.
  5. JoeB

    AJAX Attribute Manager support

    I am still having troub le not getting anything to show up at all. Anybody have any ideas?
  6. JoeB

    Links Manager II

    Hi Jack, What I tried was this. The URL they gave me was http://www.somthing.com/links where I got the error. I changed it to http://www.somthing.com/links/index.php and the error went away. Is that what curl is supposed to do? FInd a index.htm or html or php file?
  7. JoeB

    AJAX Attribute Manager support

    I changed my htacces file to use php5 but still nothing happens. How can I get this to give me errors?
  8. JoeB

    AJAX Attribute Manager support

    I turned on QTPro and no change. Still nothing there. I do not know how to make it give me more errors. I do know all the plugins I added but was not sure if Order editor had a sort routine added or the extra fields I added has it or not. I can try turning all the trues to false in the config file to see if that helps. I will later on change the httaccess file and see if I can get it to work that way and will let you know.
  9. JoeB

    AJAX Attribute Manager support

    I am now using 2.8.7 and still have the same things happening. When I enter in a new item I get the info in the correct place between the cost and the description. When I go to edit an item I get nothing. I am using PHP4.4.9 and have php5 enabled. I did not change anything in the config file in attributeManagerConfig.class.php. I am not using QTPro. I am not sure about anything else. I am not sure about the sort function if I should change something or not. I do not know if I set up a sort function or if one came with another addon or if this would stop this from working. Also is there a way to require that when categories.php gets used it uses php5? That was what I was trying to do but do not want the whole store to go back to php5 that has problems when using php5. If you do not know exactly what needs to be done to use php5 after I get your next post I will change my htacces file in the admin area to use php5 and see if Ajax attribution manager works for me. Then I will test the rest of the admin area and see if I get any errors. If I do get errors I may have to make catagories.php change my httaccess file on the fly to use php5 and when I am done have a script that puts it back to use php4. Just an idea on how to get this to work and hopefully anyone else that has this problem can use.
  10. JoeB

    AJAX Attribute Manager support

    The only thing I see is when you add a new product I do get the Info that says "Save Product before adding options". But after I add or go to something I have already I get nothing at all. So it is working at one point but not where I need it the most. I never used this before. I have both a versions of php4 and php5 running on our server. I have used my htacces file on the store and put in to use only php4 because a lot of things do not work on the store with php5 but I can only use php5 on PHPlist so in that htacces I have php5 listed on it and it runs fine. It will not run on PHP4. That is why I was asking about the htacces file. Any other ideas?
  11. JoeB

    AJAX Attribute Manager support

    Is there a way to use php5 on just the ajax attribute manager? WOuld I put something in a httaces file? Any ideas?
  12. JoeB

    AJAX Attribute Manager support

    Hi all, I am not getting anything when I try to edit a product. Do we have to have php5 for this to work?
  13. JoeB

    Links Manager II

    Hi Jack You answered shpy on his question .. 3. The error "Link Check Result: Error Reading URL" I has read all thread but cant understand how to fix it. The alow_open_url (...) is on. And when submit on my site, it found my link on my testing Reciprocal Page and let submit. but in Admin, when check URL it say that error ! The Link check Phrase just only my domain. So, i cant check my link is realy still be there on the user's Reciprocal Page if they remove it after submit success. Ask Host if curl is used. I get that error on some of the websites and I do see the URL there. What does curl do? If my host does not use it what can we do to get rid of the error? Thanks, JoeB
  14. JoeB

    Who's Online Enhancement 1.4

    If you are still getting this error there is a fix that was posted but was not correct in how to comment it out. The correct way is to do this.. //$answer = new SimpleXMLElement($backup); //if (!$backup) return false; // Failed to open connection }//else{ //$answer = new SimpleXMLElement($d); //} Notice the line }//else{ If you put the // in front of the } you will get another error.
  15. JoeB

    One Page Checkout Support

    Hi, I am having the same problems. Here is what I did so far. The statement you and I both have that gives the error is this. str_repeat('X', (strlen($this->cc_card_number)- 8)) I took out and changed it to this and then the error goes away. str_repeat('X', 16). You then will get 16 x's on the page where the credit card number is. You can use any number where I have the 16 and the error goes away. But that is not the problem. What this is supposed to do is give you back the X's after the credit card number has been entered in by the user. Credit card number 4564xxxxxxxx1234. Only in an error situation will the x string get used. I have the same credit card processing module used now without the one page checkout working fine but can't get it to work so I have given up. I really like this contribution but can't figure it out so I will move to something else unless I see an answer that works. The reason I know what the xxx's do is in error situation on my store now. I was not able to get the java-script to create the fields and so it was useless to keep on trying unless I want to pay 400 to 500 and that is not worth it at all. I will keep watching and trying a few more things and if jellybean55 or someone else gets it to work please share it to the rest of us.
  16. JoeB

    One Page Checkout Support

    I talked to one at $65 per hour and it was between 1 and 5 hours to fix it. That might be okay but it is weird that if I do not use one page checkout the echo module works fine but not in this module. Some must have an answer without having to get a coder involved. I have to think that a lot of other modules have the same problem. I was able to get rid of the error but not the missing fields. Any one have any ideas?
  17. JoeB

    One Page Checkout Support

    Hi Steve, Have you ever made this module work with ECHO1.7.4 payment processing. I have One Page Checkout working good but on the payment method section right above my credit card radio button called echo - pay by credit card it says.. Warning: str_repeat() [function.str-repeat]: Second argument has to be greater than or equal to 0. in /includes/modules/payment/echo_cc.php on line 126 In the file echo_cc.php at line 126 it says.. 'field' => substr($this->cc_card_number, 0, 4) . str_repeat('X', (strlen($this->cc_card_number) - 8)) . substr($this->cc_card_number, -4)), I have not had any problems using the echo module before I updated to One Page Checkout. It is probably something simple. Also when I click on the radio button it opens up but I do not get any text fields for the customer to enter anything. I have another radio button for echo for checks that used to work as well. It opens with no fields to enter anything in. It must be because of the error above. Any ideas on what I can do or change? Thanks in advance.
  18. I am working on a contribution that sends out a href link in an email. The code is this.. $verification_mail = tep_href_link(FILENAME_ACCOUNT_ACTIVATE, 'activation_id=' . $activation_id .'&submit=true&activation_code=' . $activation_code, 'SSL'); $verification_link = '<a href="' . $verification_mail . '">' . $verification_mail . '</a>' ."\n\n"; $email_text .= EMAIL_WELCOME . EMAIL_TEXT . TEXT_ACTIVATION_CODE . $activation_code . "\n\n" . EMAIL_TEXT_ACTIVATION . $verification_link . EMAIL_CONTACT . EMAIL_WARNING; tep_mail($name, $email_address, EMAIL_SUBJECT, $email_text, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS); tep_redirect($verification_href); Every time the link comes in my email the 2 "&" in the section of code "&submit=true&activation_code=" comes out looking like "&submit=true&activation_code=". If I take the amp; out by hand and then click on my link everything works. If it is left in it does not work. How would you change the above code to get rid of the amp;? Or is there a way to do a replace just like a perl routine that finds amp; and replaces it with "" nothing. HELP!!!
  19. Hi Jack, Another great contribution. I have everything working great but had a question that I might have something wrong or there is a small bug not sure. I am using the latest version of the add on and I am in the Links Manager II admin area. I click on the Links link and I have my list of links there. I click on the edit button for one of them and at the bottom of that page there is the pull down box with pending, approved and they are approved. Then I go to the link on the left that says Links Status and all of the links that are approved all have a question mark there. They do say in the table that they are approved but the question mark is still there. Did I do something wrong or is there a bug in this part of it? Joe
  20. In looking at this closer I realize that it could be done in the check_form validation JavaScript. I have been trying different things with no luck. Basically the JavaScript check_form code goes through each payment type and checks to see that a payment type has been selected or checked using the radio buttons. If it is null then the JavaScript alert function is called and the popup window is displayed and the user sees that they did not click on a radio button. I would like to have it check if the radio button for either the deposit or deposit50, 2 payment methods besides credit card and paypal, is checked and there is a valid discount coupon that they get an alert to not be able to use the discount coupon with these 2 payment methods and have to empty the text field for the discount coupon. I can display the code that check_form uses if this will help anyone help me re-code this. Let me know please.
  21. I would love to be able to add to the JavaScript error that comes up when you do not enter anything in the checkout_payment.php page. It now says, if you do not click on a radio button that you did not select a payment method. I need help figuring out how to make one that almost does the same thing. I have discount coupon codes installed and deposit payment module that allows a customer to put down 25% or 50% or 75% towards the purchase. I need a way to have an error come up if a user uses the deposit payment plan and puts in a discount coupon code so they can not use both.A error would pop up telling them that you can only use the coupons with a full payment. I am trying to find out where the JavaScript error comes from. What php file has the code in it? If anyone has any ideas on how to code this or where I can see or learn how to do this. Thanks for everyone's help in advance.
  22. JoeB

    [CONTRIBUTION] CCGV (trad)

    I have been reading through most of this contribution and wanted to find out if this can be done. I want to be able to give a customer a coupon code and have it not work with a payment module I have installed called deposit payments. Basically when someone uses the deposit payments they get an error if they put in a coupon code that says this coupon canot be used with this payment method please pay in full to use this coupon. Can this be done and has it been done before? If anyone has some code that would work please let me know. Thanks
  23. I wanted to find out if I can use this contribution to work with a payment module called deposit payments. I want to use the percentage discount for one item based on the fact that they are paying right away. If they use the 25% or 50% deposit payment then the discount will not apply. Is this possible to do? What would I have to do to make it work?
  24. Hi, I love this contribution everything works great. I wanted to know if someone could help me make a slight change. I have added a contribution called deposit payments for my test store. I have higher dollar value items that I sell and needed to have the ability to let the customer send in a deposit. Then make another or finish paying and the product is sent. I make custom drum sets. I need to make a slight change to some code in either checkout_payment or checkout confirmation or payment.php to be able to not allow the discount coupon code be used with either my 25% deposit payment plan or the 50% deposit payment plan. Does anyone know of a thread that may have something like this done before that would be customized for something else that I can look at and do the coding or if someone would be so kind to help with this coding to do it. I am hoping that it would not be too much coding. I would love to have it give the user an error when they use either deposit payments with the discount codes. Thanks for everyone help in advance.
×