Jump to content

Tsimi

♥Ambassador
  • Content count

    2,353
  • Joined

  • Last visited

  • Days Won

    85

Everything posted by Tsimi

  1. Tsimi

    veraltete Shopversion osC 2.2

    Träume ich oder haben eben 2 Teammitglieder was geposted? *Armkneif* Es geht ja nicht nur darum Gesetzeskonform zu sein oder um "schauen wir mal wie lange ich 2.2 verwenden kann" es geht auch darum osC endlich mal vorwärts zu bringen. Jeglicher Support um einen 2.2 auf derzeitgen Servern zum laufen zu bringen müsste verweigert werden egal ob der Shopbesitzer deswegen ne Kriese kriegt. Team Members wie Ihr das seit sollten mit gutem Beispiel vorangehen und alles mögliche tun die noch 2.2er Shop zu überzeugen umzusteigen. Wenn nicht auf Burts Edge version dann halt zumindest auf Haralds 2.3.4.1 Version. Auch wenn diese nicht mehr up to date ist, aber sicher besser als 2.2, 2.3.1 Und nochwas anderes,.. was in diesem Forum in den letzten Tagen (Wochen? ) abgegangen ist, ist absolut unakzeptabel. Der Umgang unter 3 Mitgliedern hier ist weit unter die Gürtellinie gegangen und einen klappser auf die Hand reicht da nicht. Eine "sehr" starke Warnung wäre da schon zu erwarten. Oder sogar einen Rausschmiss aus dem Forum falls nötig.
  2. Tsimi

    [Addon} Modular Front Page

    @ce7 Last time I checked the Edge version has already the index call inside the index.php file. <div class="row"> <?php echo $oscTemplate->getContent('index'); ?> </div> So installing the Nivo Slider inside the index area should be straight forward. Just drop the files into the ..includes/modules/content/index/ folder and activate. It depends where you want to show that slider header, footer, front page or index (isn't the front page and the index page the same? ) anyways, yeah just upload the right files into the right folders and activate or setup through the admin area.
  3. @kymation Is this add-on (version 2.1a) PHP 7 compatible?
  4. @raiwa New version uploaded. I changed all FA icons to the latest v5 standards. Even though there were no issues with the regular coded FA icons yet just changed them too just in case. For example; going from fa fa-list to fas fa-list Only Edge shops after 11th February need that new update. Older Edge shops should can keep using the v1.3.2
  5. Yeah I needed to install this for someone yesterday and saw the problem. I had it fixed already but didn't uploaded yet. Will do asap. Thanks.
  6. Are you uploading the sql file via the import function or are you copy&pasting the sql code and then running it? Check your configuration_group table if there is an entry with the configuration_group_id 12954 already in there. If yes delete that entry and try to rund the sql file or code again.
  7. @Michalis2421 When you import the sql file in phpMyAdmin uncheck Do not use AUTO_INCREMENT for zero values and try it again.
  8. Tsimi

    v2.3.4 und php 5.5

    @jeannie Um deine Frage zu beanworten. Schalte auf PHP 5.6 um da sollte alles normal laufen. Falls aber das Problem bestehen sollte dann liegt der Fehler nicht bei der PHP Version.
  9. Tsimi

    v2.3.4 und php 5.5

    Ich nehme an das Harald diesen Pflaster-Code eingebaut hat um etwas Zeit zu gewinnen. Wobei ihm die Zeit langsam aber sicher davon läuft. Er hat auch nie offiziell gesagt oder erwähnt dass osC 2.3.4.1 PHP 7 kompatibel ist. Auf der oscommerce Seite steht immer noch PHP v4+ (v5+ recommended)
  10. Tsimi

    Merchant v2.2 und php 7.0.27

    @mcmannehan Ist eine Weile her seit ich hier im deutschen Forum vorbei geschaut habe und man könnte schon sagen dass hier fast tote Hose ist. Darum sind auch die meisten, auch Deutschsprechenden User, im englischen Forum anzutreffen. Das Harald ein- zwei mal im Jahr vorbeischaut ist nichts Neues. Was die anderen Admins oder Mods hier machen kann ich nicht Heute beurteilen aber wenn es die gleiche Situation ist wie im englischen Forum dann ist das schon traurig. Ich habe mich nicht hier eingeschaltet um eine Seite zu wählen, ich wollte lediglich meine Meinung zu osC 2.2 und PHP 7 teilen. Was die anderen beiden Herren/Damen da von sich geben oder zumindest in was für einem Ton ist nicht korrekt und sollte unterbunden werden. Wir sind alle hier um einander zu helfen wo es nur geht und wann es geht und nicht um eine Schlammschlacht zu führen. Früher hätten solche Kommentare eine Warnung und im schlimmsten Fall den Ausschluss aus dem Forum zur Folge. Beim Coding/Progmmieren hat jeder so sein Meinung und Style denn er durchsetzen möchte. Man sollte aber nicht daruf beharren dass andere dem folgen müssen. Wenn jemand deinen Rat zu schätzen weiss und dem folgt dann ist es toll ansonsten sollte man akzeptieren dass diese Person das nicht will falls er/sie nicht dem Ratschlag folgen sollte. Man kann es nicht jedem recht machen. Am Ende muss jeder selber wissen was er mit seinem Shop machen will. Aber dann auch selber die Konsequenzen tragen und nicht hier heulen kommen und verlangen dass man die Lösungen zu den Problemen auf einem Silbertablet serviert.
  11. Tsimi

    v2.3.4 und php 5.5

    Laufen ja. Problemlos ja-ein 2.3.4.1 läuft schon auf PHP 7.1 wobei nicht Fehlerfrei. Die Fehlermeldungen werden zur Zeit unterdrückt. Siehe diesen Post hier im englischen Forum. In der application_top.php Datei kannst du mal den folgenden Code deaktivieren und schau dir den Shop dann nochmals an. includes/application_top.php Suche nach diesem Code if (defined('E_DEPRECATED')) { error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED); } Ersetze diesen durch /* if (defined('E_DEPRECATED')) { error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED); } */ Nun gehe zum Shop und aktualisiere die Seite. Ob man das nun PHP 7 kompatibel nennen kann oder nicht ist jedem selber überlassen.
  12. Tsimi

    Merchant v2.2 und php 7.0.27

    Na ich weiss nicht was genau das Ganze entfacht hat zwischen euch aber man sagt was sich neckt das liebt sich. Einen alten 2.2 shop auf PHP 7 zum laufen zu bringen ist nicht etwas was man empfehlen sollte. 2.2 ist über 10 Jahre alt! Oder will mir jemand sagen dass er noch Windows 98 benutzt? Man muss einfach akzeptieren dass man früher oder später auf eine neue Version umsteigen muss. Darum empfiehlt es sich auch immer nicht all zu grosse Änderungen am Core-Code vorzunehmen damit das umsteigen einfacher wird. Mittlerweile ist osC etwas modular (nennt man das so? ) geworden und die neusten, richtig codierten, Add-ons können ohne grosse Codeänderungen installiert werden. Am besten in den sauren Apfel beissen und neuen Shop aufsetzen. Muss ja nicht gleich den alten Shop zu machen, solange der noch läuft PHP Version runterschrauben, falls das möglish ist, und in einem Unterordner am neuen Shop basteln. Und wenn fertig einfach umspringen. Im englischen Forum wird auch meistens empfohlen umzusteigen wenn man einen 2.2 Shop hat der Probleme macht. So eine alte Software noch weiter zu unterstützen ist wirklich sinnlos. Wenn jemand sagt man solle umsteigen dann sollte man das nicht als persönlichen Angriff sehen. Die meisten User dort helfen schon gar nicht mehr bei einem 2.2 Shop sondern verweisen auf die neuste Version oder empfehlen die Commercial Section wo man professionelle Hilfe (Kostenpflichtig) suchen kann die einem beim umsteigen hilft. Zur Zeit wird die sogenannte osC Edge, auch als Cummunity Edition bekannt, als aktuellste Version empfohlen. Kann man hier runterladen.
  13. What about the math solution that we talked about in the past? (What is the sum of X and X?) It looks simple and everyone, I hope, can count numbers right?
  14. Tsimi

    HoneyPot Captcha

    @ArtcoInc And what an important 1000 post it was. I would have expected something like "HURRAY! Post #1000!"
  15. Tsimi

    NEW! Complete Order Editing Tool!

    If we could get a clean Order Editor together that actually works with all the basic osC functions then that would be a huge step forward.
  16. Tsimi

    Create New Infobox OSC 2.3.4BS

    I had a generic box template ready just saw this a bit too late. Well, just in case someone else is looking for a generic box. generic_box_BS.zip
  17. Tsimi

    NEW! Complete Order Editing Tool!

    I don't think to add code for compatibility with other add-ons is the right way to go. Order Editor should should be simple and clean as possible and work with stock osC features. Any required support or modification should be written down inside a install manual as OPTIONAL. Not everyone is using QTPro or SPPC or SSPP or whatever all those add-ons are called. Right now there is code to support; shipping label pdf, google maps + direction, pdf invoice admin 1.6.2, Send Html Email and I think QTPro. That all should be stripped out and make Order Editor as simple as possible. People can modify their own Order Editor version later to support the add-ons they need. Just my 2 cents.
  18. Tsimi

    NEW! Complete Order Editing Tool!

    @dr_lucas I will un-tailor it if you share the file. That is if your file contains the fix for the tax issue.
  19. Tsimi

    NEW! Complete Order Editing Tool!

    Then I guess we'll have to wait for a better Order Editor then. I also tested it further and it is buggy. Sometimes it adds tax sometimes not all. When I place a new order and edit that order the first time it works. If I edit it again it doesn't update the tax anymore. The Order Editor was never 100% working as it should. It is bloated with tons of unnecessary code to support various add-ons. I guess use it to change address, add/remove products and that's it. Regarding the tax just edit that inside the DB manually if it has to be. It sucks I know but the Order Editor situation has been like this since.... ever.
  20. Tsimi

    NEW! Complete Order Editing Tool!

    @PeperAre you using my Ajax file?
  21. Tsimi

    NEW! Complete Order Editing Tool!

    Wait a sec. You were not using Ajax before?
  22. Tsimi

    NEW! Complete Order Editing Tool!

    @Peper Works fine for me. I also applied the fix you linked to. All good here. You can once try my ajax file if you like. edit_orders_ajax.php
  23. Tsimi

    NEW! Complete Order Editing Tool!

    @BrockleyJohn Never mind. Used winmerge and saw it.
  24. Tsimi

    NEW! Complete Order Editing Tool!

    @BrockleyJohn Which part exactly is the fix for the Ajax file? I can see a few new added (int) in the queries. Is that it?
×