scastro

Members
  • Content count

    42
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About scastro

Profile Information

  • Real Name
    Steve Castro
  1. Apparently i wasn't searching for the correct terms in google because I couldn't find squat. Thank you.
  2. Has anyone got the latest Easy Populate version (Easy Populate 2.77a) working with an oscommerce installation of 3.2.1?
  3. Hello, I have v1.3.6 installed, and it's working just as it should. However, I have a question. Is there a way to disable the minimum order quantity selected function? I noticed in the FAQ section of the install documentation, it walks through how to remove the Quantity Block feature but keep minimum order quantity feature in tact. I need the opposite. I understand that the last response was from a year ago but I was hoping someone that has this installed could help me out, this extension works perfectly for me except that one small issue.
  4. Use a file compare program and see which lines of code changed. The problem is that it's using the same template structure as the older version. It takes a bit of hack and slashing but it works for 2.3.1.
  5. Duplicate post - sorry.
  6. Hey guys, I've been searching all around google and these forums for a support forum for the contribution Add Weight To Product Attributes v0.1 (http://www.oscommerce.com/community/contributions,1622), and I can't find anything. Hence, the new thread. I'm not having any errors with the contribution, it works perfectly, I just have a functionality question and I was hoping someone here cold help. Currently, the contribution only accepts fixed weight increases. I was wondering if it would be possible to enter a percentage for the weight increase. Is this functionality available already, or is there any tweaks to the code I can make?
  7. Hey guys, I've been searching all around google and these forums for a support forum for the contribution Add Weight To Product Attributes v0.1 (http://www.oscommerce.com/community/contributions,1622), and I can't find anything. Hence, the new thread. I'm not having any errors with the contribution, it works perfectly, I just have a functionality question and I was hoping someone here cold help. Currently, the contribution only accepts fixed weight increases. I was wondering if it would be possible to enter a percentage for the weight increase. Is this functionality available already, or is there any tweaks to the code I can make?
  8. Nevermind, it was a configuration error on my end. The v0.2 package of Add Weight To Product Attributes v0.1 (http://www.oscommerce.com/community/contributions,1622) works perfectly with v3.2.1. I am not sure if it integrates into any shipping quote calculator like UPS, etc. But I am using table rates and it works fine for me.
  9. Does anyone know if this is being developed for v2.3.1? I tried installing this on my cart (v2.3.1) and I couldn't get it working. I followed the instructions very thoroughly and could not get it working.
  10. Hello, Does anyone know if the component Add Weight To Product Attributes v0.1 is being developed for v3.2.1 or know of a similar add on that is support on the most recent version?
  11. Hello, I have recently installed a new cart in v2.3.1 I have a pretty substantial amount of categories for my cart. So i need a dynamic menu that pulls the category names and puts them in the navigation. Preferably I would like something that looks nice and animated. I have tried installing Dynamenu and Coolmenu, but support for the extensions has stopped and nothing has been develop for the new version of osCommerce. Anyone have a recommendation on well support extension for what I'm looking for?
  12. Works perfectly. Thanks.
  13. Thank you for your support on this, I realize that you are contributing out of kindness and it is greatly appreciated!
  14. Hello, I'm getting a snag on Step #3 which reads: -------- STEP 3 *** If you have already installed USPS Methods or UPS Choice, you can skip this step -------- In catalog/admin/modules.php ***************************************** Find This code somewhere around line 48: ***************************************** if (tep_not_null($action)) { switch ($action) { case 'save': while (list($key, $value) = each($HTTP_POST_VARS['configuration'])) { *********************************************** INSERT THE FOLLOWING CODE AFTER THE ABOVE LINE: *********************************************** if (is_array($value) ) { $value = implode( ", ", $value); $value = ereg_replace (", --none--", "", $value); } **************************** SO IT SHOULD LOOK LIKE THIS: **************************** if (tep_not_null($action)) { switch ($action) { case 'save': while (list($key, $value) = each($HTTP_POST_VARS['configuration'])) { if (is_array($value) ) { $value = implode( ", ", $value); $value = ereg_replace (", --none--", "", $value); } tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . $value . "' where configuration_key = '" . $key . "'"); } tep_redirect(tep_href_link(FILENAME_MODULES, 'set=' . $set . '&module=' . $HTTP_GET_VARS['module'])); break; case 'install': NOTE1: if you fail to do this step you will get the following error message when editing UPS XML in the admin: Warning: constant() [function.constant]: Couldn't find constant UPSXML_Array in /path/to/your/shop_root/includes/modules/shipping/upsxml.php on line 1010 NOTE2: if your settings do not save change the line while (list($key, $value) = each($HTTP_POST_VARS['configuration'])) { to: foreach($_POST['configuration'] as $key => $value) { I found the general location of where Step 3 is referencing, but it is not quite the same. My code reads: $action = (isset($HTTP_GET_VARS['action']) ? $HTTP_GET_VARS['action'] : ''); if (tep_not_null($action)) { switch ($action) { // {{ buySAFE Module case 'buysafe_save': if ( ( $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'] == '' || $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'] == '-- none --' ) && ( $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'] == '' || $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'] == '-- none --' ) ) { $seal_data = tep_db_fetch_array(tep_db_query("select configuration_value from " . TABLE_CONFIGURATION . " where configuration_key = 'MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'")); $store_data = tep_db_fetch_array(tep_db_query("select configuration_value from " . TABLE_CONFIGURATION . " where configuration_key = 'MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'")); $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA'] = $seal_data['configuration_value']; $HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA'] = $store_data['configuration_value']; } if (strlen($HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_SEAL_AUTHENTICATION_DATA']) != 88) { $messageStack->add('Data entry error: Invalid seal authentication data. Please fix the input data and try again.', 'error'); $action = 'buysafe_edit'; } if (strlen($HTTP_POST_VARS['configuration']['MODULE_BUYSAFE_BUYSAFE_STORE_AUTHENTICATION_DATA']) != 36) { $messageStack->add('Data entry error: Invalid store authentication data. Please fix the input data and try again.', 'error'); $action = 'buysafe_edit'; } if ($HTTP_POST_VARS['test_authentication'] == '1') { $action = 'buysafe_edit'; } if ($action == 'buysafe_edit') break; // }} Any help would be appreciated.