Jump to content

egutierrez

Members
  • Content count

    63
  • Joined

  • Last visited

Posts posted by egutierrez


  1. @@egutierrez

    I understand now. 

     

    I updated from v3.039 to v5.018 using the app, it worked well.

     

    I did notice that the addon page info/9184 did not have the v5.018 update, so I just used the app auto update feature.

     

    Can you go back to a previous backup, having v4.039 and update using the app, just a thought...@@Harald Ponce de Leon @@burt where is the v5.018 manual update?

     

    Mike

     

    Thanks @@Mikepo

     

    I tried it but when tried to update from v4.039 I find the same problem. No possible to use the auto update feature as the App give me the option to update manually only.


  2. I updated from v4.039 to v5.018 with no problems.  What error message do you get?

     

    I updated from v4.039 to v5.010 manually using http://addons.oscommerce.com/info/9184 . Now when i go to the admin side of the paypal app and click the "view update" button, it doesn't update automatically from v5.010 to 5.018 but show a message asking me visit http://addons.oscommerce.com/info/9184 and update manually but I only find till v5.010 there


  3. Hi, I have osc 2.3.4 bs. I updated to PayPal App v5.010 and installed the patch for 2.3.4bs. 

     

    Now app shows v5.018 is available as an update! but it's not able to retrieve it online. How could I update in this case as I can't find the update on osCommerce Apps site?

     

    Visit App at osCommerce

    v5.018 is available as an update! This can be downloaded and applied manually from the osCommerce Apps site.


  4. Thanks for that Rainer,

     

    For me it worked like this:

    RewriteRule ^mobile/$ /$1 [R=301,NC,L]
      RewriteRule ^(.*?)mobile/([a-z0-9/-]+)-mc-([0-9_]+).html$ index.php?cPath=$3 [NC]
      RewriteRule ^(.*?)mobile/([a-z0-9/-]+)-mm-([0-9_]+).html$ index.php?manufacturers_id=$3 [NC]
      RewriteRule ^(.*?)mobile/([a-z0-9/-]+)-mp-([0-9]+).html$ product_info.php?products_id=$3 [NC]
      RewriteRule ^(.*?)mobile/([a-z0-9/-]+)-mpr-([0-9]+).html$ product_reviews.php?products_id=$3 [NC]
      RewriteRule ^(.*?)mobile/([a-z0-9/-]+)-mpri-([0-9]+).html$ product_reviews_info.php?products_id=$3 [NC]
      RewriteRule ^(.*?)mobile/catalog_mb.php$ index.php [R=301,NC,L]
      RewriteRule ^(.*?)mobile/about.php$ index.php [R=301,NC,L]
      RewriteRule ^(.*?)mobile/search.php$ index.php [R=301,NC,L]
    

    Anyway, after upgraded to 2.3.4 Bootstrap more than 1 year ago I realised now that this addon was really valuable. It had details very good for conversions. And for some reasons maybe sometimes could be better to have differents versions for mobile and desktop as this addon do. But, anyway, yes, Google prefer responsive sites and so in the long term the best option always will be to migrate.


  5. Great contribution! 

     

    On googlefeeder.php I didn't find any option to add additional gtin codes for products with variants. For example when the product comes in multiple colours or sizes, and you have different unique product identifiers for each of these variants. How can I do that?


  6. Hi,

    I use Seo Urls 5 Sitemap.

     

    I have multilangue shop but problem is that sitemap files are generated always with url's in default language (spanish), for example it generates 

     

    www.mysite.com/en/cubierta-michelin-power-competition-700x23-negro-p-6178.html

     

    But it should be

     

    www.mysite.com/en/michelin-power-competition-700x23-tyre-black-p-6178.html

     

    Any idea?

     

    Thanks

     

    Sorry about the above post. I've found the solution on http://forums.oscommerce.com/topic/336702-ultimate-seo-urls-5-by-fwr-media/page-180#entry1623850


  7. Hi,
    I use Seo Urls 5 Sitemap.

     

    I have multilangue shop but problem is that sitemap files are generated always with url's in default language (spanish), for example it generates 

     

    www.mysite.com/en/cubierta-michelin-power-competition-700x23-negro-p-6178.html

     

    But it should be

     

    www.mysite.com/en/michelin-power-competition-700x23-tyre-black-p-6178.html

    Any idea?

    Thanks


  8. We have problems about Stock not decreasing when users pay with PS and order finish through ext/modules/payment/paypal/standard_ipn.php.

     

    We have OSC 2.3.4 BS with QTPRO . I'm not sure if I have to use the original standard_ipn.php including with osc 2.3.4 BS https://github.com/gburton/Responsive-osCommerce/blob/master/ext/modules/payment/paypal/standard_ipn.php or the one coming with the App. The App ipn file is bigger and the other one looks as redirect most of the stuff to includes/modules/payment/paypal_standard.php. Actually we are using the one including with the App (with the QTPRO decreasing Stock code added)

     

    Which one should I use? 


  9. Hi there, On language selection I try to get uri's like that:

     

    www.mysite.com/uri-in-english

    www.mysite.com/es/uri-in-spanish

    www.mysite.com/it/uri-in-italian

     

    To try that I was using the code for language selection from here http://forums.oscommerce.com/topic/336702-ultimate-seo-urls-5-by-fwr-media/?p=1573463 and also tried the mod "Keep in same page when switching language with Ultimate Seo Urls 5 Multi Language Support" http://addons.oscommerce.com/info/8469

     

    But for both cases I get (if for example I am on english language):

     


    www.mysite.com/uri-in-english

    www.mysite.com/es/uri-in-english

    www.mysite.com/it/uri-in-english


     

    Then of course it redirects 301 and you reach for example the www.mysite.com/es/uri-in-spanish. But question is: Is it not any way to show the uri's with the corresponding language directly?

     

    I have OSC 2.3.4 BS


  10. After an initial project we have continued working with Rainer in various projects and have always been completely satisfied with his work.

     

    Unfortunately in the last project that we requested from Rainer we cannot say that we are happy. This project involved the implementation of an updated module for PayPal Express in our Oscommerce 2.2. Rainer sent us the work within the agreed time and according to the tests that we did everything worked correctly, and therefore we immediately paid the agreed amount. However, when going "live" with the update we began having the problem that VAT (IVA) was not being added to some of the clients orders.

     

    We informed Rainer of this problem, but he told us that he could not resolve this issue as he had already finished the project and the installation functioned correctly in the tests. After some discussion with Rainer regarding this, and explaining that in our initial conversations about the project we had mentioned that in some initial tests done by us we had had this problem, Rainer did not provide us with any suitable solution.

     

    Finally, we offered Rainer to send us a budget for an additional amount in order to be able to resolve this issue, but he refused to give us this support arguing that he had already finished this project and now had to move on to others etc. Even going so far as to delete another project he was doing for us (an adaptation of SPCC to OSC mobile) from the test server without any warning. We find this highly unethical and it was a very abrupt way to end a working relationship with us; at the end of the day we are a client that had paid the agreed amount for the first project and as a client that pays for a service we believe we have the right to some guarantees that an installation meets minimum quality requirements,  as ultimately, what has happened is that we have paid for a project that now doesn´t work as required and we cannot use.

     

    On the other hand, we had requested an adaptation of SPCC to OSC mobile as we were interested in this, and we were going to pay the agreed amount once we had confirmed correct functioning of this project. But Rainer also had to understand that we needed the first project functioning correctly first. In any case, this situation with the double project occurred over a period of hardly 6 calendar days, therefore we do not understand that Rainer was able to be so annoyed for excessive delays in testing the second project.

     

    After asking Rainer for an explanation of this, the only reply we have received is silence.


  11. Thank you. I tried it, but didn't work.

     

    someone from the techical department of PayPal told me about use the variable PAYMENTREQUEST_n_SHIPTOPHONENUM in SetExpress Checkout,

     

    Don't you think it could work. The problem is that I don't know how to add it exactly, I mean, what value I have to assign it?


  12. Hi there,

     

    I need to include the phone in the orders. I know that I have to use the variable PAYMENTREQUEST_n_SHIPTOPHONENUM in SetExpress Checkout, but, Can I get some help about how add it on the params of this function?

     

     

        $params = array('VERSION' => $this->api_version,

                          'METHOD' => 'SetExpressCheckout',
                          'PAYMENTREQUEST_0_PAYMENTACTION' => ((MODULE_PAYMENT_PAYPAL_EXPRESS_TRANSACTION_METHOD == 'Sale') || (!tep_not_null(MODULE_PAYMENT_PAYPAL_EXPRESS_API_USERNAME)) ? 'Sale' : 'Authorization'),
                          'RETURNURL' => tep_href_link('ext/modules/payment/paypal/express.php', 'osC_Action=retrieve', 'SSL', true, false),
                          'CANCELURL' => tep_href_link('ext/modules/payment/paypal/express.php', 'osC_Action=cancel', 'SSL', true, false),
                          'BRANDNAME' => STORE_NAME,
                          'SOLUTIONTYPE' => (MODULE_PAYMENT_PAYPAL_EXPRESS_ACCOUNT_OPTIONAL == 'True') ? 'Sole' : 'Mark');

  13. Rainer hizo una gran trabajo para integrarnos el módulo QTPRO en la versión mobile (Mobile_OsC_7.3.4). Cumplió con los plazos establecidos y nos presentó una memoria de los trabajos realizados que nos ayudó mucho.

     

    Rainer también ha hecho un módulo para analytics, http://addons.oscommerce.com/info/9059 (raiwa), que nos ha permitido usar comercio electrónico en analytics con el nuevo código universal de analytics.


  14. On this piece of code of includes/functions/header_tags.php

     

    (Line 85)

     

    $product = ($product && ($pageTags['append_category'] || $pageTags['append_manufacturer'] || $defaultTags['default_logo_append_category']) ? true : false);

     

    if (($type == 'cat' || $type == 'top') && ($pageTags['append_category'] || $defaultTags['default_logo_append_group'] || $defaultTags['default_logo_append_category'] || $product))

    {

    if ($category_depth == 'nested' || $category_depth == 'products' || $product)

     

    Don't understand why $products is ever true, so then the Category will be append always for all product without import if the append category checkbox is checked or nor. Anyway, i don't understand also why $pageTags['append_category'] is also true for the page product_info (espanol) if on the header tags table i can see that it's false for that page.

     

    Regards,

     

    Eduardo

     

    Well, i deleted the HeaderTags table, and created again and also changed the below code of includes/functions/header_tags.php

     

    if (($type == 'cat' || $type == 'top') && ($pageTags['append_category'] || $defaultTags['default_logo_append_group'] || $defaultTags['default_logo_append_category'] || $product))

     

    by this:

     

    if (($type == 'cat' || $type == 'top') && ($pageTags['append_category'] || $defaultTags['default_logo_append_group'] || $defaultTags['default_logo_append_category'] ))

     

     

    An also:

     

    if ($type == 'man' && ($pageTags['append_manufacturer'] || $defaultTags['default_logo_append_group'] || $defaultTags['default_logo_append_manufacturer']))

     

    by

     

    if (($type == 'man' || $type == 'top') && ($pageTags['append_manufacturer'] || $defaultTags['default_logo_append_group'] || $defaultTags['default_logo_append_manufacturer']))

     

    Now everything is working fine.

     

    Thanks for a great contribution!

     

    Eduardo


  15. I got some advances, but still i have some problems.

     

    In page control -> Product_info.php, i have the next configuration:

     

     

    post-273143-0-32910100-1348047916_thumb.jpg

     

    Why can't i see the includes in the view section?

     

     

    By other way, if try the Test page for some product (with ID), i get:

     

    post-273143-0-00018400-1348048159_thumb.jpg

     

     

    Why the manufacturer is missing and why the "From Site" results don't match?,

    Finally, If I try the same product online i get more or less the expected results like configured in page control:

     

    <!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

    <html dir="LTR" lang="es">

    <head>

    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" >

    <title>Aceites masaje - Bote Crema Born Muscle Relax 4 - Compra online</title>

    <meta name="Description" content="Aceites masaje - Bote Crema Born Muscle Relax 4 - Compra online" >

    <meta name="Keywords" content="Aceites masaje , Bote Crema Born Muscle Relax 4 , Compra en Linea" >

     

    The only problem is the i don't get the manufacturer (but the Category, Aceites masaje, (Standard Category configuration))

     

    What could it be wrong?

     

    Eduardo

     

    On this piece of code of includes/functions/header_tags.php

     

    (Line 85)

     

    $product = ($product && ($pageTags['append_category'] || $pageTags['append_manufacturer'] || $defaultTags['default_logo_append_category']) ? true : false);

     

    if (($type == 'cat' || $type == 'top') && ($pageTags['append_category'] || $defaultTags['default_logo_append_group'] || $defaultTags['default_logo_append_category'] || $product))

    {

    if ($category_depth == 'nested' || $category_depth == 'products' || $product)

     

    Don't understand why $products is ever true, so then the Category will be append always for all product without import if the append category checkbox is checked or nor. Anyway, i don't understand also why $pageTags['append_category'] is also true for the page product_info (espanol) if on the header tags table i can see that it's false for that page.

     

    Regards,

     

    Eduardo


  16. You can't see the results of all of the pages since some of them require additional url information. You should be able to view the home page though.

     

    I got some advances, but still i have some problems.

     

    In page control -> Product_info.php, i have the next configuration:

     

     

    post-273143-0-32910100-1348047916_thumb.jpg

     

    Why can't i see the includes in the view section?

     

     

    By other way, if try the Test page for some product (with ID), i get:

     

    post-273143-0-00018400-1348048159_thumb.jpg

     

     

    Why the manufacturer is missing and why the "From Site" results don't match?,

    Finally, If I try the same product online i get more or less the expected results like configured in page control:

     

    <!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

    <html dir="LTR" lang="es">

    <head>

    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" >

    <title>Aceites masaje - Bote Crema Born Muscle Relax 4 - Compra online</title>

    <meta name="Description" content="Aceites masaje - Bote Crema Born Muscle Relax 4 - Compra online" >

    <meta name="Keywords" content="Aceites masaje , Bote Crema Born Muscle Relax 4 , Compra en Linea" >

     

    The only problem is the i don't get the manufacturer (but the Category, Aceites masaje, (Standard Category configuration))

     

    What could it be wrong?

     

    Eduardo


  17. You can't see the results of all of the pages since some of them require additional url information. You should be able to view the home page though.

     

    I have just realised that the only page where I am able to view the results is one named "index1.php" that i used for testing a while ago only and this is the HTS header code that i have there:

     

    <?php

    /*** Begin Header Tags SEO ***/

    if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

    require(DIR_WS_INCLUDES . 'header_tags.php');

    } else {

    ?>

    <?php

    /*** Begin Header Tags SEO ***/

    if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

    require(DIR_WS_INCLUDES . 'header_tags.php');

    } else {

    ?>

    <meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

    <title><?php echo TITLE; ?></title>

    <?php

    }

    /*** End Header Tags SEO ***/

    ?>

    <?php

    }

    /*** End Header Tags SEO ***/

    ?>

     

    Why does the above code work and the other pages, index.php, product_info.php, with the right code (see below) dont work?

     

    <?php

    /*** Begin Header Tags SEO ***/

    if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

    require(DIR_WS_INCLUDES . 'header_tags.php');

    } else {

    ?>

    <meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

    <title><?php echo TITLE; ?></title>

    <?php

    }

    /*** End Header Tags SEO ***/

    ?>

     

     

    Regards,

     

    Eduardo


  18. You should use the latest version, which is 3.2.8.If you have the BTS or STS installed, or not fully removed, the code may think they are installed. You will have to remove the parts of them left over.

    In the product_info.php file in the espanol directory. Instructions code are not included so you will have to see the instructions for the English file.

     

    I installed the 3.2.8 but still i have the same problem about can't see the results in page controls. But when i check online i can see that i get the expected results (just the product name on the products page titles). Where should i look in order trying to resolve this? I have installed other modules like SPPC or Quantity Price Breaks Per Product for Separate Pricing Per Customer v2.0

     

    Regards,

     

    Eduardo


  19. Hi there,

     

    I have just upgraded to Header Tags SEO V3.2.6 and i'm founding 3 problems that i can't fix:

     

    - In page control (left side) I try to set up the product_info page. I check "Product" and i put "1" on the right but when i try to view results all the time i get the red color below saying that nothing was found.

     

    - When i try the test i get the "CRE or oscMax Error" for all the pages. I had STS installed before but i uninstall it. On the header_tags_text.php i found the below code (line 398). I don't why the property IsTemplate is true, where is looking for this property to set up itself on true?, so i suppose that that property should be false and then I won't get the "CRE or oscMAx Error)

     

    else if (IsTemplate())

    {

    if (! $dbError)

    {

    $results[] = ERROR_HEADING_TEMPLATE . $explain;;

    $dbError = true;

    }

    $results[] = sprintf(ERROR_TEMPLATE_EXTRA_CODE, $files[$i]);

    }

     

    - And finally, where i personalice for the spanish lenguage the viewing text on the bottom of the product pages?

     

    Thanks,

     

    Eduardo


  20. The multi language system is coded the way it is for a reason: -

     

    www.mysite.com/ - the server will load index.php

     

    www.mysite.com/index.php/it - the server will load index.php ( if server settings are as required )

     

    www.mysite.com/it - will load nothing, the server hasn't a clue what you want loaded. You would need to write RewriteRules in .htaccess to enable the server to deal with the request.

     

    I already got that the server to deal successfully with the request www.mysite.com/it by using Rewrite

     

    My problem now is how to get that for example the language box produces uri's like www.mysite.com/it and not www.mysite.com/index.php/it

     

    Regards,

×