Jump to content

AlaneinHilo

Members
  • Content count

    40
  • Joined

  • Last visited

  1. Ok I jumped the gun, just needed to apply logic in my case. I am using image category trees but the thumbnail folder must be manually created for each category. Just gave the new image category folder a thumbnail folder and viola. Alane
  2. Hi Robert, Have you had any luck with this issue? I am encountering the same behavior with some of my thumbnails. Alane
  3. AlaneinHilo

    [contribution] STS PLUS v4

    Hi Rigadin, Thanks so much for replying so quickly. OK I found where I had gone wrong - I was making changes to includes/sts_user_code.php when I should be making changes includes/modules/sts_inc/sts_user_code.php ! :blush: Residue from previous STS. Really like what you have created here, thanks so much for all your work! Alane
  4. AlaneinHilo

    [contribution] STS PLUS v4

    Nifty contrib, I really like it. I do need some help though: I am trying to create some new placeholders, I tried adding to sts_user_code.php: $sts->template['imagepath'] = 'images/default_template'; $sts->template['aboutus'] = '<a href=' . tep_href_link(FILENAME_ABOUT) . ' class="headerNavigation">' . HEADER_TITLE_ABOUT . '</a>'); $sts->template['locate'] = '<a href=' . tep_href_link(FILENAME_LOCATE) . ' class="headerNavigation">' . HEADER_TITLE_LOCATE . '</a>'); $sts->template['contact'] = '<a href=' . tep_href_link(FILENAME_CONTACT) . ' class="headerNavigation">' . HEADER_TITLE_CONTACT . '</a>'); $sts->template['home'] = '<a href="index.php" class="headerNavigation">' . HEADER_TITLE_HOME . '</a>'); ALSO TRIED: $template['imagepath'] = 'images/default_template'; $template['aboutus'] = '<a href=' . tep_href_link(FILENAME_ABOUT) . ' class="headerNavigation">' . HEADER_TITLE_ABOUT . '</a>'); $template['locate'] = '<a href=' . tep_href_link(FILENAME_LOCATE) . ' class="headerNavigation">' . HEADER_TITLE_LOCATE . '</a>'); $template['contact'] = '<a href=' . tep_href_link(FILENAME_CONTACT) . ' class="headerNavigation">' . HEADER_TITLE_CONTACT . '</a>'); $template['home'] = '<a href="index.php" class="headerNavigation">' . HEADER_TITLE_HOME . '</a>'); And then in my template I have placed the markers for them, ie.: $imagepath#, $locate#, $home# etc. The end character has been configured as #. But the placeholders are not being recognized, they are printing on the page. What have I missed? Thanks! Alane
  5. Hi Giles, Did you solve your problem? I encountered the same issue. What I did to fix it was upload the options_attributes.php file to catalog/admin rather than catalog/admin/includes then 2 changes: Changed options_update.js: http.open('get',"includes/options_attributes.php?po_id="+id) to: http.open('get',"options_attributes.php?po_id="+id) Changed options_attributes.php: require('application_top.php'); To: require('includes/application_top.php'); Alane
  6. Hi there! I've got this contrib installed and working fine! Thank you for your work! Is there a way to add the customer fax and order comments to printorder? I have modified this to act as a fax order form but need to insert the customer's fax number to the details. If there is a way to add the comments that would be awesome! I tried: <?php echo '?<b>Fax#</b>' . '<br>?' . $order->customer['fax']; ?> But that didn't work. Thanks! Alane
  7. AlaneinHilo

    Quantity Price Breaks Per Product

    That worked! Thanks so much for your quick help Jan! Alane
  8. AlaneinHilo

    Attribute Sets Plus

    Thanks so much for this wonderful contrib! I have it installed and working fine. I do have a question/suggestion though: There doesn't seem to be a way to add more attributes to a set once you have created the set. I see you can remove but not add if you go to edit an existing set. Are there any plans to add this ability to the contrib? Thanks for your work, this has saved me so much time! Alane
  9. AlaneinHilo

    Quantity Price Breaks Per Product

    I've got QPBPP mostly successfully installed but I am having an issue with the product copy feature in admin. When I attempt to copy (duplicate) a product I get this: The corresponding code in categories.php is: elseif ($HTTP_POST_VARS['copy_as'] == 'duplicate') { $product_query = tep_db_query("select products_quantity, products_model, products_image, products_price, products_price1, products_price2, products_price3, products_price4, products_price5, products_price6, products_price7, products_price8, products_price1_qty, products_price2_qty, products_price3_qty, products_price4_qty, products_price5_qty, products_price6_qty, products_price7_qty, products_price8_qty, products_qty_blocks, products_date_available, products_weight, products_tax_class_id, manufacturers_id from " . TABLE_PRODUCTS . " where products_id = '" . (int)$products_id . "'"); $product = tep_db_fetch_array($product_query); tep_db_query("insert into " . TABLE_PRODUCTS . " (products_quantity, products_model, products_image, products_price, products_price1, products_price2, products_price3, products_price4, products_price5, products_price6, products_price7, products_price8, products_price1_qty, products_price2_qty, products_price3_qty, products_price4_qty, products_price5_qty, products_price6_qty, products_price7_qty, products_price8_qty, products_qty_blocks, products_date_added, products_date_available, products_weight, products_status, products_tax_class_id, manufacturers_id) values ('" . tep_db_input($product['products_quantity']) . "', '" . tep_db_input($product['products_model']) . "', '" . tep_db_input($product['products_image']) . "', '" . tep_db_input($product['products_price']) . "', now(), " . (empty($product['products_date_available']) ? "null" : "'" . tep_db_input($product['products_date_available']) . "'") . ", '" . tep_db_input($product['products_weight']) . "', '0', '" . (int)$product['products_tax_class_id'] . "', '" . (int)$product['manufacturers_id'] . "')"); $dup_products_id = tep_db_insert_id(); $description_query = tep_db_query("select language_id, products_name, products_description, products_url from " . TABLE_PRODUCTS_DESCRIPTION . " where products_id = '" . (int)$products_id . "'"); while ($description = tep_db_fetch_array($description_query)) { tep_db_query("insert into " . TABLE_PRODUCTS_DESCRIPTION . " (products_id, language_id, products_name, products_description, products_url, products_viewed) values ('" . (int)$dup_products_id . "', '" . (int)$description['language_id'] . "', '" . tep_db_input($description['products_name']) . "', '" . tep_db_input($description['products_description']) . "', '" . tep_db_input($description['products_url']) . "', '0')"); } Where have I gone wrong here? Thanks, Alane
  10. AlaneinHilo

    [contribution] Simple Template System (sts)

    I am having some issues with the way STS is setting the headcontent base href. I am using STS 3.0 beta and I see the code to set it is this bit: $template['headcontent'] .= '<base href="' . (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG . '">' . "\n"; BUT, it's always using the HTTPS_SERVER to set the base. See http://www.hulasupplycenter.com/catalog/ and take a look at the source code. It isn't a huge thing, but it is noticable when you go to click a relative link and it switches to the secure server (ie when you switch between english and japanese). ---------------------------------------------------- The javascript syntax error issue that some of us have had: on the sts_osc_javascript.js I removed the: <script language="javascript"><!-- at the top and the: //--></script> from the bottom of the file. Alane
  11. AlaneinHilo

    [Contribution] Extra Fields

    Does anyone know how to add the extra fields to the checkout_confirmation.php page under the order listing? My attempts so far have failed spectacularly. Thanks in advance! Alane
  12. AlaneinHilo

    [Contribution] Extra Fields

    So you just want to hide the field name in your display? I think you could just remove or comment out: echo '<b>'.$extra_fields['name'].': </b>'; from the following bit in product_info.php: while ($extra_fields = tep_db_fetch_array($extra_fields_query)) { echo '<b>'.$extra_fields['name'].': </b>'; echo $extra_fields['value'].'<BR>'; Alane
  13. AlaneinHilo

    [CONTRIB] Options as Images for MS2

    Anyone using this contribution with 'On the Fly' Auto Thumnailer or a similar contrib? I just tried to install On the Fly but it is 'breaking' my option images by messing up the src. With the option installed the src code for the options display comes out looking like this: When it should look like this: It is the edits to includes/functions/html_output.php that are causing it but I am not sure what I need to do to make these 2 get along. -------------------------------------------------------------------- Regards to gtr_rider: Did you get it working? I am using STS as well, here is what I did to make it work for the site www.hulasupplycenter.com/catalog/. includes/sts_product_info.php file: approx line 64 find: directly above this line, ADD: next, find: after this line, ADD: Next, in includes/sts_templates/[your template folder]/product_info.php.html Where you want the options to display, ADD: So that is what I did - if anyone has a better way I'm interested in knowing because this seems a little hinky. Thanks! Alane
  14. AlaneinHilo

    [contribution] Simple Template System (sts)

    OK I have experienced a healing with the strange code snippets showing up on the tops of my pages. I just overwrote all my includes files with my local copy and viola, problem solved.
  15. AlaneinHilo

    [contribution] Simple Template System (sts)

    OK things have changed a little with my strange bit of code appearring at the tops of my pages, I just updated my english.php file and now this shows up at the top of my pages: I tried searching for that string in my shop and my search didn't eve turn it up. This is confusing. ALSO... yeah yeah, I know, there's more {=) I am getting the same syntax error as meules, except on all pages for me. Line: 2, Char: 1, Syntax error. Thanks!
×