Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

modem2.0

Members
  • Content count

    70
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by modem2.0

  1. Fixed. Kiss_MT was returning the title using htmlspecialchars(), so writing &lt and &gt in the source code. So I changed to : echo strip_tags(htmlspecialchars_decode(KissMT::init()->page_title)) . PHP_EOL;
  2. I know, but it doesn't work. On current online version has the following code: <?php // KissMT start echo strip_tags(KissMT::init()->page_title) . PHP_EOL; // KissMT end ?> in 3 places but the tags are still there.
  3. In my case the html tag is to highlight the category, but I need to remove it from the page, but using htmlspecialchars() does not do that as it transforms the < and > into &lt and &gt. How can I fix this? You are already fixing this when writing the category name in the head section...
  4. Hi Robert, I noticed something strange. I have 2 categories with HTML tags in their name, to put some emphasis on the categories list, but when I go the the category page, I see the tags written there as text. I give you a concrete example, one of them is <b>Christmas Specials</b>, and it works ok in the categories list as the name in Bold, but when I load the category page I see <b>Christmas Specials</b> as the title. The title meta tag is ok. I see the same behavior in the breadcrumb, but maybe here is not due to your contribution. I tried to change in index.php from echo KissMT::init()->page_title . PHP_EOL; to echo strip_tags(KissMT::init()->page_title) . PHP_EOL; but the tags are still there. I tried also to change the strip_tags to htmlspecialchars and it works as expected so I'm on the right place... You can have a look at the page here: http://www.atelierdascores.com/bespecial-natalb-c-78.html
  5. modem2.0

    SEO Assistant

    Hi Jack, is the search being saved somewhere in the server, or is there a way to do it? Just by going to google, search something and look at the source code seems not enough, as when I do that I can't find the term I searched for in the source as most of it is javascript code...
  6. modem2.0

    SEO Assistant

    Thanks Jack, I'll have a look.
  7. modem2.0

    SEO Assistant

    Hi, is there anyone using this contribution currently? I've just installed this and I believe it is not working for Google and MSN. I manage to change the google URL from: case "Google": $filename = "http://www.google.com/ie?q=$query&hl=en&num=$hits_per_page&start=$i"; to case "Google": $filename = "http://www.google.com/?#hl=en&output=search&q=$query&num=$hits_per_page&start=$i"; in admin/includes/modules/seo_position.php but I guess I need to change somewhere else as it is still not working. Any ideas?
  8. Hi hookswitch, is there a way to fix this? Thanks!
  9. modem2.0

    dot decimal quantities

    Thanks multimixer.
  10. modem2.0

    dot decimal quantities

    Hi multimixer, did you build an addon for this? Or can you share what you did?
  11. Never. But now I also have the PDO issue in the create account...
  12. modem2.0

    SiteMonitor

    Hi Jack, I can't setup the server cron job. I followed your instructions, if I use the method php /home/username/public_html/catalog/admin/sitemonitor.php X the instance provided in x is ignored and instance 0 is always run. If I use the 2nd method, php /home/username/public_html/catalog/admin/sitemonitor.php?instance=X I get an error saying Status: 404 Not Found X-Powered-By: PHP/5.3.13 Content-type: text/html No input file specified. Is there another way to run it? Or am I doing something wrong?
  13. modem2.0

    SiteMonitor

    Mine is not protected by .htpassdw, otherwise I can not configure cron tab (I use a web cron tab as my provider does not allow me to have crontab jobs). I believe this will happen to lot's of people.
  14. modem2.0

    SiteMonitor

    Hi Jack, I noticed that on the browser you can open the site monitor text files (sitemonitor_configure_0.txt, sitemonitor_db_reference.txt, etc), and you can also show the text logs from the directory sitemonitor_logs. Shouldn't these files be protected by .htaccess? Regards
  15. modem2.0

    Product listing

    Thanks Robert, I can't give feedback on current version as I need watermark. I have too many products images to add watermark to all of them manually. I'm currently using ocsThumb, but it is an old, buggy and unsupported addon, so if I find a better one I'll change it. That's why I asked.
  16. modem2.0

    Product listing

    Any plans to support wattermarks?
  17. modem2.0

    SiteMonitor

    Hi again Jack, I managed to use PHPmailer class to send the emails. For other people using the same contrib (http://addons.oscommerce.com/info/7226), here is what I changed on admin/includes/functions/sitemonitor_functions.php: Find: if ($ttlErrors || $always_email) { mail($to, 'Site Monitor Results', $msg, $from); if ($verbose) echo 'Email sent to shop owner.' .'<br>'; } Replace by: if ($ttlErrors || $always_email) { // include server parameters require('includes/configure.php'); $server=DB_SERVER; # host name of server running MySQL $user=DB_SERVER_USERNAME; # existing login username for mysql $password=DB_SERVER_PASSWORD; # login password for mysql username $dbname=DB_DATABASE; # name of existing database to use // Connect to database and get all config values. $config_values=""; $dbconn=@mysql_connect($server,$user,$password) or http_headers('','Error,Database Connection'); @mysql_select_db($dbname,$dbconn) or http_headers('','Error,Database Connection'); $sql="select configuration_key as cfgKey, configuration_value as cfgValue from configuration where configuration_group_id='12' or configuration_group_id='1'"; $result=@mysql_query($sql,$dbconn) or http_headers('','Error,Database Connection'); while ($row = @mysql_fetch_array($result)) { if ($row['cfgKey'] != "LAST_HASH") $config_values.=$row['cfgKey'].'='.$row['cfgValue']; // To be fed to hashing function. define($row['cfgKey'], $row['cfgValue']); } if(EMAIL_USE_PHPMAILER == 'true') { require(DIR_WS_FUNCTIONS . 'general.php'); require_once(DIR_WS_CLASSES . 'phpmailer/class.phpmailer.php'); tep_mail($to, $to, 'Site Monitor Results' . ' - ' . STORE_NAME, $msg, $from, $from); } else { mail($to, 'Site Monitor Results', $msg, $from); } if ($verbose) echo 'Email sent to shop owner.' .'<br>'; } I had also the change the $from string in the sitemonitor_configure_0.txt (as for other instances if they exist) from: $from = 'From: some_address@your_domain.com'; //where email is sent from to: $from = 'some_address@your_domain.com'; //where email is sent from as I got an error saying: Invalid address: From: some_address@your_domain.com Of course I changed some_address@your_domain.com to my real email address... This last change can also be performed on sitemonitor_functions.php for any new configuration files to be created using the right string. Enjoy!
  18. modem2.0

    SiteMonitor

    Thanks Jack, I'll have a look... I'm just a bit confused about the change to do in tep_mail line, because I can't find any tep_mail being used in your contribution. There is although a mail line around line 1169 in the file sitemonitor_functions.php: if ($ttlErrors || $always_email) { mail($to, 'Site Monitor Results', $msg, $from); if ($verbose) echo 'Email sent to shop owner.' .'<br>'; } Unless you are talking about other tep_mail line...
  19. modem2.0

    SiteMonitor

    Hi Jack, I'm using your great contrib, but unfortunatelly my provider has disabled mail function for security reasons. Is there a way to use other mail contribs? I'm using PHPMailer Class in the store... Thanks
  20. modem2.0

    [Contribution] oscThumb

    Hi Sam, do you have any news regarding your re-write version? I'm testing the latest in osc 2.3.1 and I can't seem to put it to work, I've seen no image so far. It's working on my osc 2.2 shop though... Not sure what's different... if you need a beta tester let me know.
  21. modem2.0

    ULTIMATE Seo Urls 5 - by FWR Media

    Hi Robert, I've just installed USU 5 PRO r205 on my new OSC 2.3.1 shop. I noticed no issues anyway my shop it is still under development, so I just have the OSC products and categories. I was reading the thread (it's quite long and I still haven't read it all), but I noticed that since the last module update you made, there have been some fixes here in the forum, so I'm wondering what is important to fix over the r205 version... Do you plan to release an official update? Thanks for the hard work developing the contribution and all the support you give here in the forum.
  22. Hi, I'm having this contribution installed, and I'm also using the contribution customer Must Accept Terms and Conditions (MATC) http://addons.oscommerce.com/info/5750 But now I have lots on entries in the table PHPIDS Log related to REQUEST.conditions and POST.conditions in the create_account.php file and with all the conditions written. Is there a way to fix this?
  23. modem2.0

    Contribution: Auto Backup Database

    Updated and working :). I didn't test the mail though...
  24. Hi again Sam, I reverted back to v1, and I believe I found another bug. I have the following exclude line in the php file: $exclude = 'DIR_FS_BACKUP, DIR_FS_CACHE, SESSION_WRITE_DIRECTORY, images/products/, thumbs/cache/, includes/modules/kiss_meta_tags/cache/' ; and I have the following line in the page: Excluded Folders: admin/backups/ + admin/tmp/ + tmp/ + images/products/ + thumbs/cache/ + includes/modules/kiss_meta_tags/cache/ When I download the ZIP file, I have the folder (catalog)/tmp with all the files inside, which are more than 4000 cache files. From the order in the exclude string I believe the tmp/ folder is coming from the entry SESSION_WRITE_DIRECTORY, and I even replaced it by "tmp/" and "tmp", moved it to the beggining of the string, and I even deleted the entry DIR_FS_CACHE but I always download the tmp/ folder. This is quite weird, as the other entries are excluded, only this one is kept.
×