Jump to content

Farnastic

Members
  • Content count

    93
  • Joined

  • Last visited

Posts posted by Farnastic


  1. Well, I proved that /index.php?cPath=0 is a valid url’s. If you want call that an “invalid url'” that is another thing, but the picture is there and the address bar is showing what I said, in addition the list of parent categories are displayed on the webpage. I don’t think there is something wrong with my code, may be some extra work between this addon and my working path, but nothing we can say “wrong code”. I really expected a simple comment/solution from someone’s own experience.


  2. Exactly, after I installed Ultimate SEO that link redirect me to the main domain (www.mydomain.com), however, before Ultimate SEO was installed, that link show me the main page with the picture and the category name.
    Even now if I disable Ultimate SEO in admin, the link works ok. The attached pic shows the link working.

    http://www.mydomain.com/index.php?cPath=0&quickjump=1

    Thank you for helping me out on this.

    post-27188-0-28542200-1446079522_thumb.jpg


  3. It seems like a lot of work to me. If you use the included cron script, it will check if the recipricol link exists and, if not, will change the link to disabled. You will need to use it anyway, if you want to keep your links current, since sites drop such links all of the time, for a variety of reasons. So even if someone visits your site and aprroves the link today, it may not present tomorrow.

     

    Jack

     

    Hi Jack,

    I understand what you means, but, I didn't go that far. I don't recommend the script attached with this contr. for a daily basic of reciprocal checker. One of my sites had over 1,000 links and I check all of then in just 20 minutes using the Reciprocal Link Checker. This program even looks in another pages inside the domain and it is the best I have found.

     

    I was thinking for some kind of verification at the entry process. In my case, I enter many links every day and then invite partners for an exchange. I got the idea of placing the link in pending status, and in the invitation message to partners ask then to come to my site and approve the link so we don't have to display the link until the partner accept. This way if the link is not approved by the partner, we never show up, so it is more easy to delete in the future.

     

    I agree with you, links must be checked regularly and it is a tedious work that never ends. Believe me, I have been on this for a long time and every second we can save will make hours in the run.

     

    Thanks for the post.


  4. Hello,

    I have working with this contribution a lot.

     

    Due to the fact that we add links from admin section to some people and they never link back, I was thinking in create an approval page. It will be placed on the catalog section and will work this way.

     

    We enter the link from admin with pending status. We email the prospect and make the offer. We ask him to come to the approval page to approve his link. When he come to the approval page, we ask him to enter his website address, the script looks and pull from database all details we entered previously from admin and we ask him to enter the exact location of our link on his site. If it exists, the script changes the status of his link to approved and we show the category it's located, otherwise, we display a warning that our link is not found.

     

    I think this way we are sure to have approved links from sites are linking to us and save us time in looking for reciprocal. Of course, there is room to elaborate on this, we can even set a period of time to delete his info, etc, etc.

     

    I know what to do, BUT, I don't know how. We even can use part of the existing script (like the one to check for reciprocal on the admin side).

     

    If anyone want to work with me on this, please let me know.

    Thanks

    Bob


  5. I have installed this contr. and everything looks fine. I can even disable it from the admin section, in such case categories and products path return to the original (you know cpath? and .....).

    The only problem I have is once installed, I can't login to the website using MS Frontpage. I'm not sure if this is something related to the rewrite rules or something related to any of the new files from the contr.

     

    I want to know if anyone with this mod. installed is facing the same problem, or instead, can login using Frontpage.

    I appreciate your comments.

    Thanks

    Greg


  6. Thank you for replying.

     

    Okay, I have set the permissions.

     

    ALso, by the time you looked at my page I turned off "enable SEO url's" in Admin->Configuration->SEO URLs.

     

    When Doing that and trying to click a page it just takes forever and nothing happens.

     

    Anyway I turned it back on now. Still the same error.

     

    Any help would be greatly appreciated.

     

    joe - your need to turn on SEO in admin. If you want to turn on/off, you need to install a fix to the last version. Basically you will modify 2 files (I guess includes/application_top and seo_class.

     

    You site as I see now is with SEO off.

    greg


  7. Good remark. For the moment, we are looking in the "session" table to get the shopping cart content. But the sessions expire, so we do not see the cart anymore. I think we also should look in the customer basket. I think the cart is also stored in this table but only for registered customers.

     

    So we should combine the sessions and customer_basket table. Another solution would be NOT to empty the session table. I do not know what would be the side effect of that.

     

    Didier.

    Hello Spaceboy,

    do you found something new about this? I think the best way should be NOT to empty shopping cart session table, but, how can be done?

    thanks

    far


  8. I got everything going now. But I get this error, how do I fix it?

     

    1146 - Table 'oscommerce_#.links_status' doesn't exist

     

    select links_status_id, links_status_name from links_status where language_id = '1'

     

    [TEP STOP]

     

    Hi,

    from where you got the error? Admin or catalog section. If it is from catalog, you may be using the old query. Make sure the table and columns match together. I mean, the name in the database must be the same as in the query.

     

    To anyone who knows php please.

    I have setup the links manager here: http://www.netpromoservices.com/links.php. Everything works good except that listing is ordered alphabetically, which make a link appears in the first page, and as data increase, link could pass to the second page. Some spiders does not cross over pages, so partners are telling me the link is removed, which is not true. I want to list the links by links_id rather than alphabetically.

    I posted the code here, if anyone can give a hand in how to change the sort, I really will appreciate.

    thanks

    far


  9. Hello Everyone,

    Not sure if VJ is still around, but I hope someone could help me out on this.

    BTW, this is a great contribution I'm using in 3 websites.

    Here is the issue, as it was written, it sort the links inside a category alphabetically, which means that as we increase the data, a particular link could be today in page 1, but tomorrow in page 2.

    As many link exchange websites are using spiders to check if the link is still up, the spider will look at page 1, but when the link is moved to page 2, it can't find it.

    This is happening to me now. I'm getting emails from partners notifying the link is broken.

     

    I was trying to get the links sorted by links_id, however, I can't get it works. I think that can be changed in this part of code, so if anyone can give a hand on this, I really will appreciate.

     

    thanks

    far

    // ===================================================show the links in a given category
    // ===================================================We show them all
       $listing_sql = "select " . $select_column_list . " l.links_id from " . TABLE_LINKS_DESCRIPTION . " ld, " . TABLE_LINKS . " l, " . TABLE_LINKS_TO_LINK_CATEGORIES . " l2lc where l.links_status = '2' and l.links_id = l2lc.links_id and ld.links_id = l2lc.links_id and ld.language_id = '" . (int)$languages_id . "' and l2lc.link_categories_id = '" . (int)$current_category_id . "'";
    
       if ( (!isset($HTTP_GET_VARS['sort'])) || (!ereg('[1-8][ad]', $HTTP_GET_VARS['sort'])) || (substr($HTTP_GET_VARS['sort'], 0, 1) > sizeof($column_list)) ) {
         for ($i=0, $n=sizeof($column_list); $i<$n; $i++) {
           if ($column_list[$i] == 'LINK_LIST_TITLE') {
             $HTTP_GET_VARS['sort'] = $i+1 . 'a';
             $listing_sql .= " order by ld.links_title";
             break;
           }
         }
       } else {
         $sort_col = substr($HTTP_GET_VARS['sort'], 0 , 1);
         $sort_order = substr($HTTP_GET_VARS['sort'], 1);
         $listing_sql .= ' order by ';
         switch ($column_list[$sort_col-1]) {
           case 'LINK_LIST_TITLE':
             $listing_sql .= "ld.links_title " . ($sort_order == 'd' ? 'desc' : '');
             break;
           case 'LINK_LIST_URL':
             $listing_sql .= "l.links_url " . ($sort_order == 'd' ? 'desc' : '') . ", ld.links_title";
             break;
           case 'LINK_LIST_IMAGE':
             $listing_sql .= "ld.links_title";
             break;
           case 'LINK_LIST_DESCRIPTION':
             $listing_sql .= "ld.links_description " . ($sort_order == 'd' ? 'desc' : '') . ", ld.links_title";
             break;
           case 'LINK_LIST_COUNT':
             $listing_sql .= "l.links_clicked " . ($sort_order == 'd' ? 'desc' : '') . ", ld.links_title";
             break;
         }
       }
    ?>


  10. The problem is that I don't have exchange_links_links on the latest contribution.. Maybe it was on an old one or I have something missing..

     

    has anybody installed these latest two contribution?

    I have solved the problem.

     

    if someone needs the solution. I will post it here tonight BST

     

    Salvo

     

     

    Hello Salvo,

    Could you please post the solution for this problem? I have been working for 2 days but I can't get the light.

    thanks

    far


  11. Hello MaxiDVD,

    I have updated the file per your code, but I continue getting this error.

     

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/apadire/public_html/demo/admin/checklinks.php on line 111

    Sorry, no records were found!

     

    Could you pleasetell me what I'm missing except the 2 codes you posted here.

    I write a new checklinks.php --- to admin

    and made a new file called exchanged_links_links.php --- to admin/includes/languages/english

     

    I appreciate your help

    Thanks

    far


  12. Thanks Olegario. I have used that contribution but it is not really what I want. I want to put an image in the product info page named "Printer Friendly version", open a popup when a visitor clicks with some information of the product, designed in a way to fit in a letter size paper, and designed with some kind of taste.

    Someone please help.

    I can collaborate with anyone who knows how to extract from the product info page the info. I can elaborate the design part.

    thanks

    far


  13. Hello Everyone,

    I have installed this mod, and everything looks good. No errors, etc, but when typed in the address bar

     

    /sitemap_categories.html -------> I got /index.php

    /sitemap_products.html ----------> I got index.php

    /sitemap_categories.php --------> index.php

    /sitemap_products.php -----------> index.php

    /index.html ------------------------> index.php

     

    So everything is redirected to index.php. The cart itself works as usual.

    here is the link

    http://www.apadirect.com/demo/index.php

     

    I have used the .htaccess file as indicated, but no sure if it is ok.

     

    Thanks for your time.

    Far


  14. Hello Linda and... everyone,

    I have installed this contribution and it is great! Just what I need because we sell in quantities. The feature to put the minimum quantity allowed in the Add Quantity to Cart is excellent.

    Now my problem, it is not a contribution problem, but it is more eye catching to the customer to display the end quantity price (products_discount4) and not the list price. I have tried for days to do that, but I don't know too much php and I can't get it.

    The idea could be to display the lower price in:

    1- category listing

    2- product listing

    3- featured products

    4- new products

    5- all products

     

    I know that last price is identified in the table by p.products_discount4, but I can't get it to work.

    Could you please, or someone, give some ideas to what string look for and how to change. I'm sure most people using this contr will love the idea to display the lower price.

     

    You can take a look here:

    http://www.actionprintinginc.com/store/index.php?cPath=41

     

    I appreciate any help.

    thanks

    far

×