Jump to content

ogwinilo

Members
  • Content count

    150
  • Joined

  • Last visited

Posts posted by ogwinilo


  1. I have already installed this contribution, now I want to duplicate it under a new name, e.g FORUM. Do I go through all the process of installing the current one? How do I run the news.sql on my database again?

     

    Thanks in advance

     

    Felix


  2. I have already installed this contribution, now I want to duplicate it under a new name, e.g FORUM. Do I go through all the process of installing the current one? How do I run the news.sql on my database again?

     

    Thanks in advance

     

    Felix


  3. I have combed through this thread and found similar problem but no suitable answer.

    1. Everything seems to work well, but on checkout_success page, I get a blank page after installing OPC. Even when I set it to false in admin to revert back to the previous, normal checkout process, I now get the blank page. I bring back back the original catalog/checkout_process file, and I get the same blank page.

    The message I get from the error log is;

    Fatal error: Call to a member function loadSessionVars() on a non-object in /home/user/public_html/yebo7.com/checkout_process.php on line 60

     

    Line 60 is somewhere here:

    One Page Checkout - BEGIN */

    if (ONEPAGE_CHECKOUT_ENABLED == 'True'){

    $onePageCheckout->loadSessionVars();

    $onePageCheckout->fixTaxes();

     

    /*

    * This error report is due to the fact that we cannot duplicate some errors.

    * please forward this email always if you recieve it

    */

    if ($order->customer['email_address'] == '' || $order->customer['firstname'] == '' || $order->billing['firstname'] == '' || $order->delivery['firstname'] == ''){

    ob_start();

    echo 'ONEPAGE::' . serialize($onepage);

    echo 'SESSION::' . serialize($_SESSION);

    echo 'SERVER::' . serialize($_SERVER);

    echo 'ORDER::' . serialize($order);

    $content = ob_get_contents();

    mail(ONEPAGE_DEBUG_EMAIL_ADDRESS, 'Order Error: Please forward to I.T. Web Experts', $content);

    unset($content);

    ob_end_clean();

    }

    }

    /* One Page Checkout - END */

     

     

    2. Secondly, do I have to install kgt_howto even though I'm not interested in coupons? Could it be that it's because I didn't install this?

     

    Please help!

     

    Felix


  4. Installing this contribution, Infobox Admin , I get this message;

    Fatal error: Call to undefined function _box() in /home/user/public_html/yebocom.com/includes/columns.php on line 23

     

    Has anyone encountered this and how did you solve it?

     

     

    Felix


  5. Thanks Chris, decided to revert to saved backup. The puzzling thing is that copying and pasting the site to another directory worked fine

    Felix,

     

    The answer is in your question. You installed a contribution, you should review that installation to ensure you did not miss anything and then try it again. I would start with line 23 of columns.php (which I have no idea what that file could be for)

     

     

     

    Chris


  6. Thanks, decided to do just that, the contribution used doesnt seem to be supported here. The puzzling thing is that copying and pasting the site to another directory works fine.

     

    Other than uploading the backup you made before you changed whatever it is you changed to cause the error, I really don't know.

     

    Neither the function nor the file it's missing from are part of "standard" osC, so they must be part of your template code (which I am completely unfamiliar with).


  7. Thanks for the response. I have tried this and looked at my account.php. Now I get this error message:

     

    Fatal error: Call to a member function add_current_page() on a non-object in /home/woiqqwab/public_html/yebocom.com/includes/application_top.php on line 348

     

    Would appreciate your help with this

     

    Felix

     

    The site isn't making any cookie with the osCid in it so the cart get's dumped.

     

    Check the cookie setting in the config file.

     

    Try these:

     

      define('HTTP_COOKIE_DOMAIN', '.YOUR_DOMAIN.com');
     define('HTTPS_COOKIE_DOMAIN', '.YOUR_DOMAIN.com');
     define('HTTP_COOKIE_PATH', '/');
     define('HTTPS_COOKIE_PATH', '/');

     

    It also appears your define for HTTP_SERVER has a slash after it when it shouldn't.

     

    It probably says:

     

      define('HTTP_SERVER', 'http://YOUR_DOMAIN.com/');

     

    Needs to be:

     

      define('HTTP_SERVER', 'http://YOUR_DOMAIN.com');


  8. I have installed this contribution, it works perfectly, well almost.

    When moving away from 'My Account' back to 'Home', I become instantly logged off, requiring that I log on again if I want to continue with whatever I want to do.

    How can I solve this?

    Surprisingly, when I copy my store to another directory, I don't have this problem

     

    Thanks in advance for any help

     

    Felix


  9. I have installed this contribution, it works perfectly, well almost.

    When moving away from 'My Account' back to 'Home', I become instantly logged off, requiring that I log on again if I want to continue with whatever I want to do.

    How can I solve this?

    Surprisingly, when I copy my store to another directory, I don't have this problem

     

    Thanks in advance for any help

     

    Felix


  10. I have installed the contribution and everything works well from the admin side.

    1. However, in my store front, there is nothing to suggest I installed this. Forgive my being new on this. But I have installed infobox in admin contribution which controls infoboxes from admin. This has introduced a 'columns.php, I believe to take the place of the right and left.php files. I wonder if this could be the reason and where to look at to have the blog to show up.

    2. On the login page on the breadcrumb of the navigation bar, it shows the news/blog menu item while im on the login page. Is it normal?

     

    Thannks in advance

     

    Felix


  11. Problem sorted, just reinstalled for the 5th time and this time it worked out.

     

    Now have just installed another add on, (supplier admin area), I get the following messages when browsing as a supplier

     

    Warning: require(fckeditor/fckeditor.php) [function.require]: failed to open stream: No such file or directory in /home/.../yebocom.com/myadmin/includes/functions/html_output.php on line 13

     

    Warning: require(fckeditor/fckeditor.php) [function.require]: failed to open stream: No such file or directory in /home/../yebocom.com/myadmin/includes/functions/html_output.php on line 13

     

    Fatal error: require() [function.require]: Failed opening required 'fckeditor/fckeditor.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/.../public_html/yebocom.com/myadmin/includes/functions/html_output.php on line 13

     

    What does this mean?

     

    Regards

     

     

     

    Now I only get this error message;

     

    Message: Access is denied.

     

    Line: 68

    Char: 131

    Code: 0

    URI: http://mysite//mynewlychangedadmin/fckeditor/editor/js/fckeditorcode_ie.js

     

    Still red crossed squares and nothing else

     

    Anyone?

     

    Thanks in advance


  12. I knew I messed up somehow, thanks for pointing that out, it's working now

     

    Thanks again G and all the best

     

    Felix

     

     

    '<a href="' . tep_href_link(FILENAME_WHOS_ONLINE) . '" class="menuBoxContentLink">' . BOX_TOOLS_WHOS_ONLINE . '</a>'). '<br><a href="' . tep_href_link(FILENAME_MAILBEEZ, '', 'NONSSL') . '">MailBeez</a><br>';

     

    Is there any reason why you did not follow the installation instructions? :-)

     

    '<a href="' . tep_href_link(FILENAME_WHOS_ONLINE) . '" class="menuBoxContentLink">' . BOX_TOOLS_WHOS_ONLINE . '</a><br>" .
    "<a href="' . tep_href_link(FILENAME_MAILBEEZ, '', 'NONSSL') . '">MailBeez</a><br>');

     

    Might be better.

     

    HTH

     

    G


  13. Hi, farbor!

     

    Unfortunatelly it is not so easy as it may apper on first look. Each total is calculated automatically by supplied module. We can't simple override that logic or we must make too many mocks in each order_total module. Your way is tempting, but I'm afraid it is not real in way OE works.

     

    To implement your way we should realise new field for a variable which will be control CCGV the way you described. After that we should somehow realise logic above... I can't found a solution to it yet. When I realise 2 that posts for other ot modules it took many time to understand how get this modules work automatically correctly.

     

    May be I'd like the other way. I just think about and I have no time to think carefully. We may change CCGC order total modules so, it will "see" admin or client side it working. On client side it works as usual, but on admin side we slightly change logic. We will use the varable you spoke and work according to this variable.

     

    But this way is only for orders created manually on admin. And we still need a feature that will automatically calculate totals for order which clients makes themselves. This is the real headache. But I think it is possible to implement. Hard, but real.

     

    Good idea with a variable!


  14. I'm using 2.2 Release Candidate 2a

     

     

    I don't seem to have boxes>tools.php.

     

    In catalog, it needed column left and right changes,

    filenames.php,

    database_tables.php,

     

    The tools.php in admin is like this;

    <?php

    /*

    $Id: tools.php 1739 2007-12-20 00:52:16Z hpdl $

     

    osCommerce, Open Source E-Commerce Solutions

    http://www.oscommerce.com

     

    Copyright © 2002 osCommerce

     

    Released under the GNU General Public License

    */

    ?>

    <!-- tools //-->

    <tr>

    <td>

    <?php

    $heading = array();

    $contents = array();

     

    $heading[] = array('text' => BOX_HEADING_TOOLS,

    'link' => tep_href_link(FILENAME_BACKUP, 'selected_box=tools'));

     

    if ($selected_box == 'tools') {

    $contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_BACKUP) . '" class="menuBoxContentLink">' . BOX_TOOLS_BACKUP . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_BANNER_MANAGER) . '" class="menuBoxContentLink">' . BOX_TOOLS_BANNER_MANAGER . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_CACHE) . '" class="menuBoxContentLink">' . BOX_TOOLS_CACHE . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_MAIL) . '" class="menuBoxContentLink">' . BOX_TOOLS_MAIL . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_NEWSLETTERS) . '" class="menuBoxContentLink">' . BOX_TOOLS_NEWSLETTER_MANAGER . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_SERVER_INFO) . '" class="menuBoxContentLink">' . BOX_TOOLS_SERVER_INFO . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_WHOS_ONLINE) . '" class="menuBoxContentLink">' . BOX_TOOLS_WHOS_ONLINE . '</a>'). '<br><a href="' . tep_href_link(FILENAME_MAILBEEZ, '', 'NONSSL') . '">MailBeez</a><br>';

    }

     

    $box = new box;

    echo $box->menuBox($heading, $contents);

    ?>

    </td>

    </tr>

    <!-- tools_eof //-->

     

     

    Thanks in advance

     

     

     

    Felix,

     

     

    What version of OSC are you using ?

     

    Have you edited the tools.php file while trying to install that contribution ? If so, check the code edits.

     

     

     

    Chris


  15. Now I only get this error message;

     

    Message: Access is denied.

     

    Line: 68

    Char: 131

    Code: 0

    URI: http://mysite//mynewlychangedadmin/fckeditor/editor/js/fckeditorcode_ie.js

     

    Still red crossed squares and nothing else

     

    Anyone?

     

    Thanks in advance

     

     

     

     

     

    Hi

     

    I have moved my test site from a directory further down (where FCKeditor was working perfectly), to the a domain in my root directory , did the config.php changes of absolute path as suggested elsewhere here, but I still get the following error message:

     

     

    Message: Access is denied.

     

    Line: 68

    Char: 131

    Code: 0

    URI: http://mysite//mynewlychangedadmin/fckeditor/editor/js/fckeditorcode_ie.js

     

     

    Message: 'FCK.EditorDocument.body' is null or not an object

    Line: 48

    Char: 1419

    Code: 0

    URI: http://mysite//mynewlychangedadmin/fckeditor/editor/js/fckeditorcode_ie.js

     

     

    What else do I need to do?

     

    Regards


  16. I have created a second shop in the root directory, copied from shop 1 two directories below this one. I have Fckeditor installed and Ultimate Seo Urls 5. From the shop 1, i have to turn off Seo Urls to get to my products and the FCKeditor works well there. However, in the second shop, copied from 1, Seo Urls are turned on and the products are accessible while I cannot get the Fckeditor to work there, infact, it just shows red crossed and nothing else. I have made the necessary configure changed in both admin and catalog in the second shop as well the .htaccess files. In the Fckeditor, i have made the necessary config.php changes. What else do I have to look at to have my shop 1 have the Seo Urls turned on and shop products and the second shop to have the Fckeditor working. Any help will be appreciated

     

    Regard

×