Jump to content

blurredreality

Members
  • Content count

    28
  • Joined

  • Last visited

Profile Information

  • Real Name
    Josh Oldham
  1. blurredreality

    One Page Checkout Support

    Could not log in! Although I could on the demo site - most odd. I don't know what page the error would be coming from - I mean I formatted the checkout.php page but I took care not to change any php coding. Also I would have thought this was to do with checkout_success.php and billing_address.php How odd. I appreciate your help anyway. If you can go further in helping even more - then excellent. Either way - appreciated buddy.
  2. blurredreality

    One Page Checkout Support

    Thanks for the response. I changed the code (although to & # 163; - don't know if that semi colon will be important for everyone) an the £ signs are displaying fine so thanks for that. I am currently trying to checkout using a Check/Postal Order module - which basically directs straight to checkout_success after confirmation. This happens completely regularly. I have checked what happens with each of the different Account Creation options selected (in each case I entered a password in the password fields). For required, as said, the order is made successfully, but no account is created. For create, the order is made successfully and a new account is created - although with a random password and not the one input by the customer. For optional - no account is created. I just can't figure it out!Hopefully it's something simple.
  3. blurredreality

    One Page Checkout Support

    I have a problem :-(. In testing creating a new account during the order process - it was discovered the account created did not get assigned with the password the user inputted - but instead with a randomly generated one. This was when the Account Creation setting was optional (I think!) I have since changed this to setting to required (as this is best for my store). However, now when you go through checkout (with a password e.t.c) entered, an order record is created (and order e-mail sent to customer), but an account is not created (nor is an account created email sent to the customer). I do not know where the source of this error could be coming from so I have held back posting any code. I hope you can help! PS: - Still having trouble with currency symbols - tried using "<?php header("Content-Type: text/html; charset=UTF-8\n");" at the start of the checkout.php page but it did nothing. I am also unsure as to where I would edit £ signs to & # 163; as discussed on Page 3 - plus apparently this solution would result in emails sent with the £ code as opposed to displaying £ signs. Only the order total module £ signs seem to be displaying incorrectly. Thanks in advance
  4. blurredreality

    Protect your site via htaccess - support

    Heya. Unfortunately it still doesn't work :( (the url rewrite stuff that is - the other ones seem to be effective as far as I can tell). I have also realised I do have RC2a - not sure why I thought I didn't. Anyway - if anyone can help me figure this that'd be great. I'll leave it out there for now.
  5. blurredreality

    Protect your site via htaccess - support

    That's awesome thanks. Still can't get the pesky URL rewrite to work. I expect the problem to be quite nuanced and subtle so don't worry if you can't figure it out. This is the code I'm using: # Redirect index.php to domain.com RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\.php\ HTTP/ RewriteRule ^index\.php$ http://www.blurredreality.co.uk/ [R=301,L] #Redirect domain.com to www.domain.com RewriteCond %{HTTP_HOST} ^blurredreality.co.uk [NC] RewriteRule ^(.*)$ http://www.blurredreality.co.uk/$1 [L,R=301] RewriteBase / The url in the navigation bar doesnt change at all. Also those new additions you linked to block me from accessing the site (taking me to a 403 error page) - and also says "Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request." I have version 2.2 MS2 installed via Fantastico Deluxe in my host CPanel if that makes any difference. Maybe I have too old a version. Either way thanks for the help.
  6. blurredreality

    Protect your site via htaccess - support

    Jim that is absolutely brilliant thank you. I really appreciate the time you took to write that and I'm sure it'll benefit many others too. I really don't know what sort of a state my store would be in if it weren't for the help of people on these forums - it's all great :thumbsup: ! Anyway - I have one quick question about the first 2 additions - should I notice anything different in my browser navigation bar - i.e. should the addresses convert into the new format? I have modified the htaccess file in the catalog folder (I have a lot of pages in the root directory one level up as well) - modifying the base domain in each case - e.g. blurredreality.co.uk to www.blurredreality.co.uk isntead of blurredreality.co.uk/catalog to www.blurredreality.co.uk/catalog. Does this sound right or am I being incredibly stupid? If you can't help that is fine - worth putting it out there though. Thanks again Jim, Josh
  7. blurredreality

    Backup All Store Files In Zip Format

    No worries spooks - I'll make do and mend for now :thumbsup: - I'll keep an eye out for a fix though if you come up with one. Thanks for the help.
  8. blurredreality

    One Page Checkout Support

    Ooh also does anyone know why some of my prices are coming up as while some are displayed normally i.e. ? The erroneous ones are the Sub-total and Total values in the shopping cart box - and all of the values in the bottom "Add comments to your order" box. I would have thought it a simple problem but the individual prices in the shopping cart box look fine! Any help would be much appreciated. PS: This is a great contribution so thanks very much!
  9. blurredreality

    One Page Checkout Support

    Seeing as the shopping cart is shown on the checkout.php page, I figured I would like the user not to have to go to the shopping cart before going to checkout (I also would like it so that they did not simply stay on the same page, as setting Display Cart After Adding Product to false in Admin-Configuration-My Page currently does). So I found this simple change worked a treat on my store. Thans to Jan Zonjee who helped me figure out this change. You want to edit catalog/includes/application_top.php - around line 320- in the following way: I hope it helps anyone striving to get the smoothest checkout available! NB: For this method to work the Display Shopping Cart after Adding Product option on the admin configuration page has to be set to false!
  10. blurredreality

    Protect your site via htaccess - support

    I shall start (as lack of understanding was my motivation for starting this thread unfortunately). When messing with htaccess, for the reasonably naive OSc user it is quite daunting. I feel, while the mod is great, the instructions could be clearer. First of all, do I literally copy the whole of the code from the htaccess_protection.htm file into my htaccess file (every line, including the ones starting with # and the ones not starting with #) - obviously changing the red text into my address. Secondly - when editing my address in this code, do I edit it to my primary domain, or the domain I would use when specifying the secure address my store uses (e.g. would it be along the lines of http://www.mysite.co.uk OR https://secureXX.hostname.com/~username/ (given that I have a shared SSL certificate) ). Also do I need to include a /catalog at the end of these addresses. My final query would be as to where the IP addresses in the banned IP numbers text file have come from? Are they confirmed as dangerous? Thank you greatly to anyone who can help. My questions are probably very basic but where better a place to start in a support thread! I imagine there will be others like me out there who are apprehensive about messing anything up.
  11. I couldn't find one, so thought I would create a support group for the "Protect your site via htaccess" contribution. I found the contribution on spook's excellent overview topic of security fixes, found here. This is the contrib: http://addons.oscommerce.com/info/6066
  12. blurredreality

    Backup All Store Files In Zip Format

    Hey there this seems like a really good add-on - just having a few problems getting it going.. First of all I got the fatal error mentioned on page one - with the memory exhausted. I thought this was odd as I didn't particularly think I had that big a store section - but obviously I did! I then changed the backup_store_files.php as recommended to exclude the image folder - and indeed that worked in that I did not get taken to the Fatal Error page. Howevr, a file download box opened and then before any progress was made an error box popped up saying: "Internet Explorer cannot download backup_store_files.php from securexx.inmotionhosting.com. It is unable to open this Internet site - the required site is either unavailable or cannot be found. Please try again later" I have tried a few times and keep getting this. Hopefully it's something small that I've missed! -To clarify, my site has a shared ssl certificate, and the admin area has ssl turned on - and otherwise seems to be working fine. Just wondered if that may be the problem though?
  13. blurredreality

    [Contribution] STS v4

    Sorry, just a clarification that I no longer need help on this issue - I gave up using STS. Thanks anyway!
  14. blurredreality

    [Contribution] STS v4

    Hey thanks bkellum, done that and now get the following displayed when I try open my main store/catalog page in my browser: Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory. I have found this message comes up a lot. I tried following instructions to fix it, altering the php.ini file in the root directory (public_html). I also copied it into the catalog directory (public_html/catalog) and catalog admin directory. (public_html/catalog/admin). That just gave a really long string of code on the store page. I also tried to edit the .htaccess files as recommended (http://forums.oscommerce.com/topic/203498-server-requirement-error-register-globals-is-disabled-in-your-php-configuration-this-can-be-enabled-in-your-phpini-configuration-file-or-in-the-ht/) but the htaccess files in both my public_html and public_html/catalog directories did not have the text I am supposed to edit. Sorry to be a pain, but I really am quite clueless about php, and it is frustrating work. Can someone please try and help me, being as simple and clear as possible. Thanks.
  15. blurredreality

    [Contribution] STS v4

    Hello everyone. I have just tried to install STS 4.5.9 on my OScommerce site, following the instructions in the install.html document. However, when I set the Use Templates option to true for the Default module (in my admin section), when I refresh my store page afterwards I simply get a blank screen showing the following message on screen. (PHP_VERSION >= '4') ) { tep_gzip_output(GZIP_LEVEL); } } ?> Apologies if this has been dealt with elsewhere, I had a look through some of the previous pages of this topic and also tried googling the code listed, but found nothing. Any help would be much appreciated. I mean, basically I have a website set up, designed, css-ed and everything. I just need to add the odd 'buy now' buttons to link to the checkout etc, so yeah, hopefully this should set me in the right direction. Thanks everyone
×