Jump to content

Ivanio

Members
  • Content count

    6
  • Joined

  • Last visited

  1. Hello Steve, here is the code from lines 54-105 : function tep_db_perform($table, $data, $action = 'insert', $parameters = '', $link = 'db_link') { reset($data); if ($action == 'insert') { $query = 'insert into ' . $table . ' ('; while (list($columns, ) = each($data)) { $query .= $columns . ', '; } $query = substr($query, 0, -2) . ') values ('; reset($data); while (list(, $value) = each($data)) { switch ((string)$value) { case 'now()': $query .= 'now(), '; break; case 'null': $query .= 'null, '; break; default: $query .= '\'' . tep_db_input($value) . '\', '; break; } } $query = substr($query, 0, -2) . ')'; } elseif ($action == 'update') { $query = 'update ' . $table . ' set '; while (list($columns, $value) = each($data)) { switch ((string)$value) { case 'now()': $query .= $columns . ' = now(), '; break; case 'null': $query .= $columns .= ' = null, '; break; default: $query .= $columns . ' = \'' . tep_db_input($value) . '\', '; break; } } $query = substr($query, 0, -2) . ' where ' . $parameters; } return tep_db_query($query, $link); } function tep_db_fetch_array($db_query) { return mysql_fetch_array($db_query, MYSQL_ASSOC); } function tep_db_result($result, $row, $field = '') { return mysql_result($result, $row, $field); }
  2. Hello, i don't know where to post this Topic, so i post it here. No problem if the moderators move it in other place. I have installed different contribs: 1. STS 4.5.8 2. Simple Multiple Images (Unlimited) with Fancy Popups V1.1.5 + OSCThumb 3. RSS Feed v2.2 + RSS Feed v2.2a 5. X-sell v2.6updated 6. Country State selector ajax 1.5.5 + World Zones v2.8 + Limit Countries 2.2 7. Ultimate SEO URLS v2.8 8. Header Tags SEO v3.1.7 9. Sitemap SEO v1.5 10. SEO Assistant v2.2 11. Blacklist v1.1 12. NIF v1.1 13. Admin_level_account_with_categories_2.3.4 14. Anti Robot Registration Validation v3.1.1 15. TIM's Safer Database Input Method + Security Pro v1.0.2 + IP trap v4 + SiteMOnitor v1.9 16. QTPro v4.6.1 The problem is, when i go to edit some product, on the bottom of the product edit page appears an warning: and after it appear a list of products from the same category. I found this issue after installing QTPro, but then i have restored the site to the point 12 (the issue disappeared), then i have restored the site to the point 13 and the issue appears again. So i think the problem is in the instalation of Admin Level Accounts contribution. Anybody knows how to resolve this? thanks
  3. Hi Spooks, great contribution! HAve you got working it with oscThumbs contribution? I have installed STS contrib + Simple Multi Image (your contrib) + oscThumbs. All is working good, but when you pop'up the image in fancybox there no watermark on the picture. thanks
×