Jump to content

lacoz

Members
  • Content count

    41
  • Joined

  • Last visited

Everything posted by lacoz

  1. lacoz

    Header Tags SEO

    Strange is, that I was using the header tags for pretty long time without any issues (as a beginner I was very surprised, that I installed it successfully at first try). The error occured just after the update. Can You please suggest what should I look for in the forums? Is it the "Call to a member function add_current_page() on a non-object in" thread? Thanks again Jack.
  2. lacoz

    Header Tags SEO

    Ok the panic is over. After I searched through the forum, I tried to delete my cookies and somehow the front store showed up. But I still don´t know, why I wasn´t successful in updating my version of Header Tags. Does anyone have an idea what went wrong?
  3. lacoz

    Header Tags SEO

    Hi all, I need urgent help. Everything with this great contribution worked well, until I decided to update my version. I downloaded the latest 3.2.4 version and folloved the instructions in update docs in the file Update_from_V_3.1.8_to_V_3.1.9. Everything seemed to run smoothly - sql changes, file uploads, changes in admin/categories.php, all done. Then I went to my front store and all I got was this error: Fatal error: Call to a member function add_current_page() on a non-object in /.../www_root/includes/application_top.php on line 361 The line reads: $navigation->add_current_page(); I undid all the changes including the database changes (made a fresh backup prior to updating), but nothing changed. There is still the same error. Please do somebody have any suggestion?
  4. lacoz

    Header Tags SEO

    Will try that tonight thanks for the advice.
  5. lacoz

    Header Tags SEO

    Hi Jack, I tried to search this topic, but with no luck. Regarding the social bookmarks feature, I already figured out, how to select and display only some of them. The next thing I would like to do is to place them on a more visible place on the product_info page, lets say directly under the H1 heading with left alignment. Since my coding skills are very limited, I hope You or somebody else can help me with that. Thanks a lot.
  6. lacoz

    COD fee missing

    Hi there, I couldn´t find anything usefull in existing topics, so I have to ask. Is there a way to find out, if there is a minimum value in COD module required? I have a strange problem, that when I had the fee with value 1.66 everything worked ok. But then I lowered it to 0.70 and the COD fee doesn´t show up in the order total. Do You have any ideas? Thanks
  7. lacoz

    [Contribution] oscThumb

    Ok so I should install this addon instead of the Fancy Pics V1, or should I use only the product_info file?
  8. lacoz

    [Contribution] oscThumb

    Hi all. This problem was mentioned here before, but I wasn´t able to find a solution. I have the Fancy Pics V1 from spooks installed on my website (working perfectly). Then I installed the oscThumb contribution, without any errors, but it doesn´t seem to work. The settings in admin are looking OK, but no watermarks appear on the popup images, no files in the cache (folder writable), etc. I went through all the 16 pages of this forum, tried every suggestion (also that one with replacing the line 112 in product_info), and it still didn´t change. At least all my images are ok and not broken links, like other users referred. Do You have any ideas? Thanks
  9. lacoz

    Header Tags SEO

    I have only one language, which is showing in the page control. I entered the desired text in the title box and don´t have the default title checked nor have I the root checkbox checked. But it still adds the english word behore the title. I can send you a screenshot if it helps...
  10. lacoz

    Header Tags SEO

    If it doesn´t negatively affect the search-engine, then I don´t care. I just believed, that in the keywords there had to be only commas. After filling the tags, the extra commas that I mentioned before, wanished, but there are still unwanted spaces after the keyword (for example toys ,). Is this ok? And one more issue. I added the header tags seo code also to the conditios.php, shipping.php etc. pages. As I am located in Europe, I use no english version of the shop. So in conditions.php the title should be "Obchodne podmienky" (in slovak). But no matter what I do in the page control, there is allways just "Conditions" showing in the title (cleared the browser cache, ...). Do You have any ideas on this issue?
  11. lacoz

    Header Tags SEO

    Ok I did that, the tags are now filled. Now when I go to a product page, in the source in keywords there are also the "-" characters, which I have in the product names. How can I get rid of them?
  12. lacoz

    Header Tags SEO

    I have to admit that I am a beginner in stuff like this. Are there some instructions or guide on how to correctly use this contribution, what boxes should be checked in page control etc.?
  13. lacoz

    Header Tags SEO

    That says that the execution time exceeds, that why I decided to fill the tags manually hoping they would be more accurate...
  14. lacoz

    Header Tags SEO

    Ok I unchecked the root option and one of the two unwanted commas wanished. One extra comma is still there... I have also the Include: product checked. Could it be because of this? Update: I´ve reset the options, now the unwanted commas are gone, but there blank space after some keywords and not directly a comma. Hope this is ok for search-engines...
  15. lacoz

    Header Tags SEO

    Thanks for the contribution it is working perfectly. I have only one question regarding the meta keywords. If I fill them manually in admin/catalog/ filling different keywords for category, subcategory and product, the resulting keywords in the displayed product page source-code are divided with too many commas between the words (for example: toys, for kids, , , aged 3+, outdoor). Does this negatively affect the google search? If yes, how can I remove those unwanted commas? Thanks for any suggestions..
  16. lacoz

    Google XML Sitemap SEO

    Thanks for Your support I´ll try that...
  17. Thank You very much that solved my problem (as it was just a notice and not an error) :)
  18. Is there any way to block such notices? Because despite the notice the carousel and SEO URLs contributions are working properly...
  19. I have the latest Ultimate_SEO_URLSv22d_5 installed. Before installing the carousel the SEO URLs worked well. Also when I switch the carousel off, there is no error on my site.
  20. lacoz

    Google XML Sitemap SEO

    Hi there, I have a problem with this contribution. I have also the Ultimate_SEO_URLSv22d_5 installed, in which I defined, how special characters should be converted. But the googlexml-sitemap ignores them and leaves the url without the characters. Do You have any suggestions on this issue?
  21. Hi there, I have a problem with this contribution. It is indeed working well, but clashes with a Flash Carousel I have installed ( http://addons.oscommerce.com/info/6123 ) If the flash carousel is switched on, I get an error: Notice: Undefined variable: cName in .../includes/classes/seo.class.php on line 1006 The affected function is /** * Function to get the product name. Use evaluated cache, per page cache, or database query in that order of precedent * @author Bobby Easland * @version 1.1 * @param integer $pID * @return string Stripped anchor text */ function get_product_name($pID){ $result = array(); if ($this->attributes['SEO_ADD_CPATH_TO_PRODUCT_URLS'] == 'true') { $cName = $this->get_all_category_parents($pID, $cName); } switch(true){ case ($this->attributes['USE_SEO_CACHE_GLOBAL'] == 'true' && defined('PRODUCT_NAME_' . $pID)): $this->performance['CACHE_QUERY_SAVINGS']++; $return = (tep_not_null($cName) ? $cName . '-'. constant('PRODUCT_NAME_' . $pID) : constant('PRODUCT_NAME_' . $pID)); $this->cache['PRODUCTS'][$pID] = $return; break; case ($this->attributes['USE_SEO_CACHE_GLOBAL'] == 'true' && isset($this->cache['PRODUCTS'][$pID])): $this->performance['CACHE_QUERY_SAVINGS']++; $return = (tep_not_null($cName) ? $cName . '-'. $this->cache['PRODUCTS'][$pID] : $this->cache['PRODUCTS'][$pID]); break; default: $this->performance['NUMBER_QUERIES']++; $sqlCmd = $this->attributes['USE_SEO_HEADER_TAGS'] == 'true' ? 'products_name as pName' : 'products_name as pName'; $sql = "SELECT " . $sqlCmd . " FROM ".TABLE_PRODUCTS_DESCRIPTION." WHERE products_id='".(int)$pID."' AND language_id='".(int)$this->languages_id."' LIMIT 1"; $result = $this->DB->FetchArray( $this->DB->Query( $sql ) ); $pName = $this->strip( $result['pName'] ); $this->cache['PRODUCTS'][$pID] = $pName; $this->performance['QUERIES']['PRODUCTS'][] = $sql; $return = (tep_not_null($cName) ? $cName . '-'. $pName : $pName); break; } # end switch return $return; } # end function line 1006 is $return = (tep_not_null($cName) ? $cName . '-'. constant('PRODUCT_NAME_' . $pID) : constant('PRODUCT_NAME_' . $pID)); When the Carousel is turned off, the store loads without errors. Do You have any idea, why? Thanks for any ideas.
  22. lacoz

    ULTIMATE Seo Urls 5 - by FWR Media

    Hi there, I have a problem with this contribution. It is indeed working well, but clashes with a Flash Carousel I have installed ( http://addons.oscommerce.com/info/6123 ) If the flash carousel is switched on, I get an error: Notice: Undefined variable: cName in .../includes/classes/seo.class.php on line 1006 The affected function is /** * Function to get the product name. Use evaluated cache, per page cache, or database query in that order of precedent * @author Bobby Easland * @version 1.1 * @param integer $pID * @return string Stripped anchor text */ function get_product_name($pID){ $result = array(); if ($this->attributes['SEO_ADD_CPATH_TO_PRODUCT_URLS'] == 'true') { $cName = $this->get_all_category_parents($pID, $cName); } switch(true){ case ($this->attributes['USE_SEO_CACHE_GLOBAL'] == 'true' && defined('PRODUCT_NAME_' . $pID)): $this->performance['CACHE_QUERY_SAVINGS']++; $return = (tep_not_null($cName) ? $cName . '-'. constant('PRODUCT_NAME_' . $pID) : constant('PRODUCT_NAME_' . $pID)); $this->cache['PRODUCTS'][$pID] = $return; break; case ($this->attributes['USE_SEO_CACHE_GLOBAL'] == 'true' && isset($this->cache['PRODUCTS'][$pID])): $this->performance['CACHE_QUERY_SAVINGS']++; $return = (tep_not_null($cName) ? $cName . '-'. $this->cache['PRODUCTS'][$pID] : $this->cache['PRODUCTS'][$pID]); break; default: $this->performance['NUMBER_QUERIES']++; $sqlCmd = $this->attributes['USE_SEO_HEADER_TAGS'] == 'true' ? 'products_name as pName' : 'products_name as pName'; $sql = "SELECT " . $sqlCmd . " FROM ".TABLE_PRODUCTS_DESCRIPTION." WHERE products_id='".(int)$pID."' AND language_id='".(int)$this->languages_id."' LIMIT 1"; $result = $this->DB->FetchArray( $this->DB->Query( $sql ) ); $pName = $this->strip( $result['pName'] ); $this->cache['PRODUCTS'][$pID] = $pName; $this->performance['QUERIES']['PRODUCTS'][] = $sql; $return = (tep_not_null($cName) ? $cName . '-'. $pName : $pName); break; } # end switch return $return; } # end function line 1006 is $return = (tep_not_null($cName) ? $cName . '-'. constant('PRODUCT_NAME_' . $pID) : constant('PRODUCT_NAME_' . $pID)); When the Carousel is turned off, the store loads without errors. Do You have any idea, why? Thanks for any ideas.
  23. lacoz

    Cool Flash Carousel Menu

    Hi folks, I have a strange problem with this cool contribution. It runs perfectly, but only if i access the store like www.mydomain.com If i type the mydomain.com without the www in adress bar, the store itself loads correctly, but the carousel stays blank. Does anyone have a solution for this?
×