Jump to content

iflyamphib

Members
  • Content count

    50
  • Joined

  • Last visited

Everything posted by iflyamphib

  1. iflyamphib

    Recover Cart Sales

    Getting started early on new years resolutions, one of which to get RCS fully functional. Few months ago I migrated my sites (started over completely new) over to osc 2.3.1 1) I added the Multiple Dropdown Config addon (http://addons.oscommerce.com/info/6634) 2) Uploaded the RCS files to the appropriate locations 3) Added the sql for RCS 4) Found the forum reference to missing language file (stats_recover_cart_sales.php) and added that. That took care of the missing headers on the RCS report page. Sign in under my test account and abandon a cart, then sign out. Run the RCS report under the Tools menu works correctly. Emails are sent correctly, and shown as having contacted the customer. If I then sign back in as the customer and complete the transaction, the abandoned cart is removed from the RCS report under Tools. Here's where the last problem occurs: Under the Recovered Cart Sales Report (Under Reports), Examined Records and Recovered Sales are zero. Everything but this last step works.
  2. iflyamphib

    USPS Rate V4, Intl Rate V2 (official support thread)

    I have a client that has emailed trying to place an order for the last two days. This is on a existing 2.3 store with this module: Fatal error: Class 'httpClient' not found in /home/recmob/public_html/seareyspecialist.com/includes/modules/shipping/usps.php on line 303 This appears to be where it connects to the usps servers. Strange part is that I have placed test orders and have breezed right on through and cannot replicate this. Is this a possibility where the usps server is unavailable at the time the order is being placed?
  3. iflyamphib

    Header Tags SEO

    Jack, I have the latest 3.2.8 version installed and am seeing something odd. I have two sites, one copied to the other with only products changed, so the code is the same. On the index.php page where the page title is set, when the browser loads the page the first two letters are dropped. For instance the page title could 'ABC Widgets', but what displays in the browser tab is 'C Widgets'. I initially thought the text was too long and shortened it, but that didn't help. The other site (with a longer title name) displays properly. Any thoughts? Jim
  4. iflyamphib

    USPS Rate V4, Intl Rate V2 (official support thread)

    Jetta - First thank you for your devotion to increasing OSC's capability and an awesome contrib. I installed this tonight without any issues, however I think I might have found an issue in regards to your answer above. I have a very large item (a wood crate) that is used for shipping a particular item on my site. When I check every USPS box to restrict those ship methods on that item, save the item, and then reIoad the item, I notice one of those methods is then unchecked. I've verified this on several items. Is there a fix that would allow one to disable all methods for a particular item?
  5. iflyamphib

    USPS shipping module install

    I just installed this 2 weeks ago and didn't have any issues with the install or getting it working. However I am disappointed that after the install, the only USPS method of shipping that comes up on checkout is 'Library Mail'. There isn't any method of selecting shipping options to have available (Priority, Express, etc) in the module, as with Fedex for example. If anyone has anything better to use with a 2.3 site I'd appreciate it!
  6. iflyamphib

    multi orders updates annoucement

    I installed this contrib last night from the download on a 2.3 test site. Are all of the above corrections reflected in the downloaded code? I have everything working, however the email that is sent to the customer shows up as this: Subject line says "Setting" Ultralight Aircraft Sails (The stores name) ------------------------------------------------------ EMAIL_TEXT_ORDER_NUMBER 1 EMAIL_TEXT_INVOICE_URL http://www.ultralightaircraftsails.com/account_history_info.php?order_id=1 EMAIL_TEXT_DATE_ORDERED Saturday 07 April, 2012 EMAIL_TEXT_COMMENTS_UPDATE EMAIL_TEXT_STATUS_UPDATE
  7. iflyamphib

    Quantity Price Breaks

    I'd like to install this contrib but I'm confused. Reviewing the install.html file it says: Quantity Price Breaks Per Product (QPBPP) for osC 2.3.1 Following that just below, it states: - This document describes updates to files based on the full package dated July 22, 2009 (version 1.3.6 / osC 2.2 RC2a) - The following contents is ONLY valid for oscommercial 2.3.1 Does this mean this package (as uploaded) only changes files based on the 2.2 install, or is this a full package for 2.3? I never had this on my 2.2 site, so not sure how to proceed...
  8. iflyamphib

    Booking addon

    If this not appropriate to post this here, then I apologize. I was also wondering is something like this existed for another business I'm entertaining starting. While googling the terms 'oscommerce customer scheduling' I came across this url and it looks like what I might want, and possibly you too: www.phpjabbers.com/time-slots-booking-calendar/ I am not affliated with this at all, just trying to help out in any way I can, for those whom have helped me I am greatful! Jim
  9. Good evening. I've installed a clean (not upgrading) version of 1.7 for osc 2.3.1 this afternoon. With both test urls: http://www.siteurl.com/&test=%22%3EXXX and http://www.siteurl.com/?test="><script>eval(window.name)</script> I receive the following: 403 Forbidden You don't have permission to access / on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. If I remove the portion after the .com, the test site loads / functions properly. The database tables have been created properly and are viewable from Php Admin. I've gone through the install manual twice to verify placement of the files and code within the modified files. I can add myself (ip from the Who's Online) and ban myself, and then receive the email successfully (using the contact form only). Nothing is logged to the PHPIDS Log report however. Should it be when manually banning an IP? The host is HostGator. Server running php 5.2.17 with PDO enabled (viewed from previous posts) This is a new test site where I have been adding contributions to have as a 'master' for upgrading / creating other sites. Is this a hosting issue? Thank you for any light anyone can shed on this. Jim
  10. iflyamphib

    [Contribution] ABF Freight Systems Support Thread

    Just installed this ABF contribution and signed up with ABF for an account. Also registered for 'Transparent Links' as required. Appropriate data entered for the catalog item. When I add the item to the cart and checkout, I receive the following error message (in debug mode): We're sorry, but an error occured while calculating your shipping prices. CONSIGNEE CITY and STATE required. (53)http://www.abfs.com/xml/aquotexml.asp?DL=2&AcctNum=******&Password=******&ShipCity=MALABAR&ShipState=FL&ShipZip=32950&ShipCountry=US&ShipPay=Y&ShipAff=Y&Acc_PALLET=Y&ConsCity=COCOA&ConsState=&ConsZip=32927&ConsCountry=US&Wgt1=1300&Class1=200&nmfcitem1=011760&nmfcsub1=00&ShipMonth=11&ShipDay=5&ShipYear=2009&Acc_RDEL=Y Astericks for acct # and password are inserted here just for the forum, the error does show them in debug mode. It seems to me that all the information is there, both for 'ship from' city / state and 'ship to' city / state.
  11. iflyamphib

    [Contribution] MATC

    2 questions regarding this contrib: 1) On checkout, bottom of page (as another poster indicated) I have the transparent button, and the standard button showing. I'm not sure where to look in the code for this. Anyone? 2) After setting the controls in admin and running test orders, I have found that this does not work using Firefox, however it does work using IE. Is there any workaround for use with Firefox?
  12. iflyamphib

    Fraudlabs Contribution

    I could not find a support thread for this contrib. I installed this contrib (http://addons.oscommerce.com/info/6954/v,22) on a dev site to test. I have the following conflict and am not sure how to fix this. When installed and placing a test order, I receive the following error: 1 Warning: Cannot modify header information - headers already sent by (output started at /home/recmob/public_html/CodeTest/includes/modules/fraudlabs/fraudlabs_process.php:56) in /home/recmob/public_html/CodeTest/includes/functions/general.php on line 33 Even with the above error (which the client sees), the order itself goes through and is recorded. Line 33 in general.php is: header('Location: ' . $url); If I comment out line 33, and reload the page (or a new test order entirely), the page is blank upon submitting the order - yet the order does go through. Looking at file: /fraudlabs_process.php:56 The only line in the file that deals anything with headers is line 54: list($headers, $output) = explode("\r\n\r\n", $buffer); If I comment that line out and test, then the order upon checkout displays as it should, the order in admin shows as it should, but then of course the Fraudlabs result does not work at all. Can anyone offer any hints?
  13. iflyamphib

    Fraudlabs Contribution

    That seemed to have worked, but in a nutshell, why? Do you also use this contrib germ? Thank you for assisting with this!
  14. iflyamphib

    Fraudlabs Contribution

    Thanks for the try, that was one I wasn't aware of. Unfortunately that didn't do it. No whitespace at either end of the file, and also checked line for line. Jim
  15. iflyamphib

    Article Manager v1.0

    Please disregard post - operator error! Contrib works beautifully and is a worthy option to add to any site.
  16. iflyamphib

    Article Manager v1.0

    I have a few questions regarding this contrib. Installed and no errors showing in either catalog side or admin side. I created a Topic called Website and a Topic Heading called New Website, with the Topic Description: Anything related to the www.recreationalmobility.com website. I then created a new article called: 'New Website Up & Running' and published the article. So far so good. In the Articles info box, I see: New Articles All Articles All Topics Website Articles RSS Feed 1) Selecting New Articles, the result is: New Articles Displaying 1 to 1 (of 1 articles) Result Pages: 1 Below is a list of articles with the most recent ones listed first. New Website Up & Running... by Jim Ratte Topic: Miscellaneous Articles Published: Tuesday 13 October, 2009 Displaying 1 to 1 (of 1 articles) Result Pages: 1 Where is the Topic: Misc Articles coming from? When creating a Topic, the label 'Misc Articles' default loads, however after updating / saving I would think this would change. 2) When selecting All Articles, the result is: All Articles Current Articles Displaying 1 to 1 (of 1 articles) Result Pages: 1 Below is a list of articles with the most recent ones listed first. New Website Up & Running... by Jim Ratte Topic: Miscellaneous Articles Published: Tuesday 13 October, 2009 Displaying 1 to 1 (of 1 articles) Result Pages: 1 3) When selecting All Topics, the result is: All Article Topics Website ( 0 ) Anything related to the www.recreationalmobility.com website. Shouldn't the (0) above actually be a 1? 4) If I select Website (listed under All Topics), the result is: New Website Anything related to the www.recreationalmobility.com website. There are currently no articles in this topic. Shouldn't the article 'New Website Up & Running' be listed here? Have I missed something in the installation I am not aware of? Or is this proper behavior and I'm just not understanding it :) Site is live if you wish to see the above behavior (www.recreationalmobility.com)
  17. iflyamphib

    Recover Cart Sales

    I finally ended up pulling the installing of version 2.30 out of the site. I installed an older version (2.23a) dated Dec '08 and all is well. The email comes through as it should, pulling the info from the database. As noted in a previous thread, there is some code that needs to be adjusted for the 'reply to' email address. The emails I received while testing, if the customer were to hit 'reply to' would never make it back. Reference below: View PostAntiqueStoreBuilder, on Sep 6 2006, 07:50 PM, said: I fiddled around with my problem and came up with the following solution that fixed my issue - it should work for you: In admin/recover_cart_sales.php I changed: tep_mail('', $outEmailAddr, EMAIL_TEXT_SUBJECT, $email, STORE_OWNER, EMAIL_FROM); to: tep_mail('', $outEmailAddr, EMAIL_TEXT_SUBJECT, $email, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS); This should take your email address info (Store_Owner & Store_Owner_Email_Address) from global settings. Hope that helps... Note, "EMAIL_FROM" also comes from global settings and is configured in the same place as the STORE_OWNER_EMAIL_ADDRESS setting. (admin->store configuration). Either will work if correctly configured.
  18. iflyamphib

    Recover Cart Sales

    The default text message is already in another file. Email_Text_1 for instance, does not seem to show up anywhere in other files - or relate to another field in the database. So how is it supposed to pull info from the database? Perhaps it is simple, if you know code :) As a small biz owner you have to wear multiple hats, and coding isn't my specialty :)
  19. iflyamphib

    Recover Cart Sales

    Steve, Great little search tool, thanks! Which version of RCS are you running? I did find the text in two files, in both English and the Dutch recover_cart_sales.php However I may have to hope the author reply's to this issue. I have no idea what to do with it. Here's the code portion from the English file: // E-mail Processing - Requires EMAIL_* defines in the // includes/languages/english/recover_cart_sales.php file $cquery = tep_db_query("select * from orders where customers_id = '".$cid."'" ); $email = '<span style="font-family: Verdana, Arial, sans-serif; font-size: 11px;">'; $email .= EMAIL_TEXT_1; $email .= EMAIL_TEXT_2; if( EMAIL_USE_HTML == 'true' ) { $email .= EMAIL_TEXT_ACCOUNT . ' <a href="' . tep_catalog_href_link(FILENAME_CATALOG_ACCOUNT, '', 'SSL') . '">' . tep_catalog_href_link(FILENAME_CATALOG_ACCOUNT, '', 'SSL') . '</a>' . "\n\n"; //$email .= EMAIL_TEXT_SHOPPINGCART . ' <a href="' . tep_catalog_href_link(FILENAME_CATALOG_SHOPPING_CART, '') . '">' . tep_catalog_href_link(FILENAME_CATALOG_SHOPPING_CART, '', 'SSL') . '</a>' . "\n\n"; } else { $email .= EMAIL_TEXT_ACCOUNT . ' ' . tep_catalog_href_link(FILENAME_CATALOG_ACCOUNT, '', 'SSL') . "\n\n"; //$email .= EMAIL_TEXT_SHOPPINGCART . ' ' . tep_catalog_href_link(FILENAME_CATALOG_ACCOUNT, '', 'SSL') . "\n\n"; } $email .= "\n" . EMAIL_TEXT_3 . "\n\n" . $mline . "\n\n" . EMAIL_TEXT_4 . "\n\n";
  20. iflyamphib

    Recover Cart Sales

    Steve, Thanks for looking at this. The file is there, code below. The odd thing about this one particular file though is that in the contribution download, the file is actually named recover_cart_sales.php.2.23a If left named this way, the code crashes. Renaming the file, (removing the .2.23a off of the end) the file works, except for the emailed portion. Where is this email_text_1 etc coming from? Jim <?php /* $Id: recover_cart_sales.php,v 1.6 2005/08/16 20:56:39 lane Exp $ Recover Cart Sales v2.22 ENGLISH Language File Recover Cart Sales contribution: JM Ivler © Copyright © 2003-2005 JM Ivler / Ideas From the Deep / OSCommerce http://www.oscommerce.com Released under the GNU General Public License Modifed by Aalst (recover_cart_sales.php,v 1.2 .. 1.36) aalst@aalst.com Modifed by willross (recover_cart_sales.php,v 1.4) reply@qwest.net - don't forget to flush the 'scart' db table every so often Modifed by Lane (stats_recover_cart_sales.php,v 1.4d .. 2.22) lane@ifd.com www.osc-modsquad.com / www.ifd.com */ define('MESSAGE_STACK_CUSTOMER_ID', 'Cart for Customer-ID '); define('MESSAGE_STACK_DELETE_SUCCESS', ' deleted successfully'); define('HEADING_TITLE', 'Recover Cart Sales v2.22'); define('HEADING_EMAIL_SENT', 'E-mail Sent Report'); define('EMAIL_TEXT_LOGIN', 'Login to your account here:'); define('EMAIL_SEPARATOR', '------------------------------------------------------'); define('EMAIL_TEXT_SUBJECT', 'Inquiry from '. STORE_NAME ); define('EMAIL_TEXT_SALUTATION', 'Dear ' ); define('EMAIL_TEXT_NEWCUST_INTRO', "\n\n" . 'Thank you for stopping by ' . STORE_NAME . ' and considering us for your purchase. '); define('EMAIL_TEXT_CURCUST_INTRO', "\n\n" . 'We would like to thank you for having shopped at ' . STORE_NAME . ' in the past. '); define('EMAIL_TEXT_BODY_HEADER', 'We noticed that during a visit to our store you placed ' . 'the following item(s) in your shopping cart, but did not complete ' . 'the transaction.' . "\n\n" . 'Shopping Cart Contents:' . "\n\n" ); define('EMAIL_TEXT_BODY_FOOTER', 'We are always interested in knowing what happened ' . 'and if there was a reason that you decided not to purchase at ' . 'this time. If you could be so kind as to let us ' . 'know if you had any issues or concerns, we would appreciate it. ' . 'We are asking for feedback from you and others as to how we can ' . 'help make your experience at '. STORE_NAME . ' better.'."\n\n". 'PLEASE NOTE:'."\n".'If you believe you completed your purchase and are ' . 'wondering why it was not delivered, this email is an indication that ' . 'your order was NOT completed, and that you have NOT been charged! ' . 'Please return to the store in order to complete your order.'."\n\n". 'Our apologies if you already completed your purchase, ' . 'we try not to send these messages in those cases, but sometimes it is ' . 'hard for us to tell depending on individual circumstances.'."\n\n". 'Again, thank you for your time and consideration in helping us ' . 'improve the ' . STORE_NAME . " website.\n\nSincerely,\n\n" ); define('DAYS_FIELD_PREFIX', 'Show for last '); define('DAYS_FIELD_POSTFIX', ' days '); define('DAYS_FIELD_BUTTON', 'Go'); define('TABLE_HEADING_DATE', 'DATE'); define('TABLE_HEADING_CONTACT', 'CONTACTED'); define('TABLE_HEADING_CUSTOMER', 'CUSTOMER NAME'); define('TABLE_HEADING_EMAIL', 'E-MAIL'); define('TABLE_HEADING_PHONE', 'PHONE'); define('TABLE_HEADING_MODEL', 'ITEM'); define('TABLE_HEADING_DESCRIPTION', 'DESCRIPTION'); define('TABLE_HEADING_QUANTY', 'QTY'); define('TABLE_HEADING_PRICE', 'PRICE'); define('TABLE_HEADING_TOTAL', 'TOTAL'); define('TABLE_GRAND_TOTAL', 'Grand Total: '); define('TABLE_CART_TOTAL', 'Cart Total: '); define('TEXT_CURRENT_CUSTOMER', 'CUSTOMER'); define('TEXT_SEND_EMAIL', 'Send E-mail'); define('TEXT_RETURN', '[Click Here To Return]'); define('TEXT_NOT_CONTACTED', 'Uncontacted'); define('PSMSG', 'Additional PS Message: '); ?>
  21. iflyamphib

    Recover Cart Sales

    I have installed (I believe correctly!) RCS version 2.23a I have set up a test account through the site (dev site), abandoned a cart, then run the report under the Tools menu. The abandoned cart shows up properly, and I click the send email button. I receive the email, but something isn't right as it shows as follows: EMAIL_TEXT_1EMAIL_TEXT_2EMAIL_TEXT_ACCOUNT http://recreationalmobility.com/CodeTest/account.php'>http://recreationalmobility.com/CodeTest/account.php EMAIL_TEXT_3 1 x Beloved 1 x SWAT 3: Close Quarters Battle EMAIL_TEXT_4 Code Testing http://recreationalmobility.com I don't understand where or how the info is pulled into the email that is sent.The dev site is installed within a folder called CodeTest under root. Files have been checked three times they are within the correct places, and the correct code changes made. I've looked through the entire thread and do not see where anyone has had this issue. Can anyone help please? I'm so close! :)) Jim
  22. What's on your mind?

  23. Installed Recovered Cart Sales on my dev site a few days ago. Recovered Cart Sales shows up in the Config Info Box and works just fine. Recovered Cart Sales in the Tools section produces the following error: Warning: require(includes/classes/recover_cart_sales.php) [function.require]: failed to open stream: No such file or directory in /home/recmob/public_html/CodeTest/admin/recover_cart_sales.php on line 28 Warning: require(includes/classes/recover_cart_sales.php) [function.require]: failed to open stream: No such file or directory in /home/recmob/public_html/CodeTest/admin/recover_cart_sales.php on line 28 Fatal error: require() [function.require]: Failed opening required 'includes/classes/recover_cart_sales.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/recmob/public_html/CodeTest/admin/recover_cart_sales.php on line 28 I've been through the install doc and verified twice now that all files are in the proper place. I have also tried going back to the original files and starting over. The error remains the same however. My dev site is in a folder called CodeTest. I've made sure the file being called is both in root and under the CodeTest folder. Have tried an absolute path too, but not sure I had that right. Can anyone shed some light on this please? Jim
  24. iflyamphib

    Pulling my hair out on this - help!? :)

    Oops, not sure how that happened. I clicked on the support url within the contribution install file. When the thread came up I hit New topic, assuming that meant 'within that thread'.
  25. iflyamphib

    Parse error: syntax error?

    Got it fixed. Guess I just needed a break. Not knowing php at all and looking at similar code in the file helped :)
×