Latest News: (loading..)

Frisser

Members
  • Content count

    30
  • Joined

  • Last visited

1 Follower

About Frisser

Profile Information

  • Real Name
    Wilfred Helmig
  1. The filter works great - but only if I select 5 options (colour blue, size XXL, brande Y etc.), if I select a 6th selection it becomes very slow (high load on my MySQL server). It's always the 6th (and later off course). I've tried to optimize the code (not really necessary) but can't find why the sixth selection (and later) is a problem. Anyone any idea why this is?
  2. Problem solved, not really a very clean solution - but I used a pager script (so not the internal split page function). Well it works and it also looks better :) I noticed this problem also on other sites so it's a bit of a bug.. really would be nice if it could be fixed (after 3 days I gave up and used this solution).
  3. The problem is with multiple checkboxes. So it you choose a checkbox the URL will be: products_filter.php?f4[0]=name1&cPath=29&sort=6a If I go to page 2 the [0] is gone and I see this: products_filter.php?f4=Array&cPath=29&sort=products_name&page=2 Is it not possible to change [] to () like: products_filter.php?f4(0)=name1&cPath=29&sort=6a this should work if you go to page2?
  4. Excellent contribution! Have a 'small' problem. If I filter a few products and the page is split in different pages the second, third etc. goes to: products_filter.php?f4=Array&cPath=29&sort=products_name&page=2 The part f4=Array is wrong. it should be: products_filter.php?f4[0]=testname&cPath=29&sort=products_name&page=2 Is it only me with this problem?
  5. New problem. I have 2 shipping methods for 2 countries. In Internet Explorer if I fill in the billing address it won't update the shipping methods. Only when I select country to a different country a couple of times it updates the shipping method. Also if I update the cart it will update the shipping method. Anyone?
  6. Yes... please have anyone got a solution for this. I have also worked on this for hours!
  7. I think there is no problem with Oscommerce > MS2.2 RC2a
  8. Problem is with the confirmation() in the payment module. in includes/checkout/payment_method.php I changed this to this
  9. Does anyone have a fix for this problem? Maybe disable the check for the payment modules?
  10. Yes I have the same problem. And not with every payment module. Don't have a problem with moneyorder but with cop I have the same problem... really need a fix for this!
  11. Does anyone have a solution for this? So if someone have installed the Discount Coupon codes module please set the Max Use of Number Available to 1 and see if you can use it only once or unlimited... I think it's not working.
  12. Yes - in Checkout.php I changed this: success: function (data){ $this.html(data); onePage.addCountryAjax($('select[name="country"]', $this), 'state', 'stateCol') }, to this success: function (data){ $this.html(data); onePage.addCountryAjax($('select[name="country"]', $this), '', '') },
  13. It's a bit complicated and you have to modify the code a bit. But in short: - create a copy of your sts_template.html to checkout.php.html (test if this is working - if not use a newer version of STS) - Before the </head> put this piece of code: <link rel="stylesheet" type="text/css" href="http://www.yoursite.com/ext/jQuery/themes/smoothness/ui.all.css"> <script type="text/javascript" language="javascript" src="http://www.yoursite.com/ext/jQuery/jQuery.js"></script> <script type="text/javascript" language="javascript" src="http://www.yoursite.com/ext/jQuery/jQuery.ajaxq.js"></script> <script type="text/javascript" language="javascript" src="http://www.yoursite.com/ext/jQuery/jQuery.pstrength.js"></script> <script type="text/javascript" language="javascript" src="http://www.yoursite.com/ext/jQuery/jQuery.ui.js"></script> <script type="text/javascript" language="javascript" src="http://www.yoursite.com/includes/checkout/checkout.js"></script> - Before the </body> put this piece of code (it's the same code in checkout.php): <!-- dialogs_bof //--> <div id="loginBox" title="Log Into My Account" style="display:none;"><table cellpadding="2" cellspacing="0" border="0"> <tr> <td class="main"><?php echo ENTRY_EMAIL_ADDRESS;?></td> <td><?php echo tep_draw_input_field('email_address');?></td> </tr> <tr> <td class="main"><?php echo ENTRY_PASSWORD;?></td> <td><?php echo tep_draw_password_field('password');?></td> </tr> <tr> <td colspan="2" align="right" class="main"><a href="<?php echo tep_href_link(FILENAME_PASSWORD_FORGOTTEN, '', 'SSL');?>"><?php echo TEXT_PASSWORD_FORGOTTEN;?></a></td> </tr> <tr> <td colspan="2" align="right"><?php echo tep_image_button('button_login.gif', IMAGE_BUTTON_LOGIN, 'id="loginWindowSubmit"');?></td> </tr> </table></div> <div id="addressBook" title="Address Book" style="display:none"></div> <div id="newAddress" title="New Address" style="display:none"></div> <!-- dialogs_eof//--> And then it should work! I have modified a lot - but I think this is the basic instructions.
  14. I have a problem with the Discount Coupon Codes Module. Don't know if I'm the only having this problem. The 'Max Use' and 'Number Available' isn't working. It works when I disable One Page Checkout - but not when I enable it. If I set Max Use to 1 and I use the coupon unlimited. I really appreciate if someone could check if I did something wrong - or is this a general problem?
  15. Sorry about the last post. The code in the checkout.php.html is: <!-- dialogs_bof //--> <div id="loginBox" title="Inloggen" style="display:none;"><table cellpadding="2" cellspacing="0" border="0"> <tr> <td class="main"><?php echo ENTRY_EMAIL_ADDRESS;?></td> <td><?php echo tep_draw_input_field('email_address');?></td> </tr> <tr> <td class="main"><?php echo ENTRY_PASSWORD;?></td> <td><?php echo tep_draw_password_field('password');?></td> </tr> <tr> <td colspan="2" align="right" class="main"><a href="<?php echo tep_href_link(FILENAME_PASSWORD_FORGOTTEN, '', 'SSL');?>"><?php echo TEXT_PASSWORD_FORGOTTEN;?></a></td> </tr> <tr> <td colspan="2" align="right"><?php echo tep_image_button('button_login.gif', IMAGE_BUTTON_LOGIN, 'id="loginWindowSubmit"');?></td> </tr> </table></div> <div id="addressBook" title="Address Book" style="display:none"></div> <div id="newAddress" title="New Address" style="display:none"></div> <!-- dialogs_eof//-->