Jump to content

Josaram

Members
  • Content count

    60
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Jolyn
  • Location
    Alberta, Canada
  1. Josaram

    InternetSecure - possible fix found

    Okay, so I've been running internetsecure for over 6 months, and have had on off problems with their module working, then not working and not getting the customer order - just hte payment information. Anyhow, I found out that InternetSecure uses the same configuration as the Authorize.net Direct module, and can be switched to point to Internetsecure. Their technical team assured me this was correct. So...for more detailed info - go to the merchant area of your internetsecure account, help files, and view the Authorize.net Emulation Now for setting this up, you have to change the authorizenet_direct.php module - use search to find the instances of https - and change the authorize.net address to the internetsecure address - if I remember, there are about 5 instances of this address, and all have to be changed and uploaded to work. Then in your admin panel, turn on the authorize.net module - and set the parameters as follows (at least this worked for my server and configuration)... Enable Authorize.net Module True Login Username <PUT YOUR INTERNETSECURE MERCHANT ACCT # HERE> Login Transaction Key <LEAVE BLANK> cURL Setup Not Compiled cURL Path <LEAVE BLANK> Transaction Mode Production Transaction Method Credit Card Processing Mode Authorize And Capture Sort Order Of Display 4 Customer Notifications True Accepted Credit Cards Amex, Discover, Mastercard, Visa Authorizenet - Payment Zone --none-- Authorizenet - Set Order Status default Enable CCV code True And so far, all my payments seem to be captured correctly. Now you DO have to have SSL enabled for this module, as the credit card number is now collected on your payment information page, but the number is still sent instantly to internetsecure for processing, and the number is not stored on your server. So although I've only been running this a couple days, it looks like a possible fix or way to get around the flakiness of the internetsecure payment module. I love many more of the features of internetsecure over psigate, but I've kept my psigate account for the last six months, because I didn't want to cancel it until I knew if I could get internetsecure to run consistently enough. I'll continue to watch this method for probably another month or so before I commit to this. So hopefully this will help another frustrated internetsecure customer out there...
  2. Josaram

    Help with InternetSecure Set Up

    Okay, I've isolated the product string I need to edit. So hopefully someone can help me to edit this speifically. It is currently showing as: tep_draw_hidden_field('Products', ''.$price.'::1::'.$uid.'::'.STORE_NAME.''.$trx_currency.''.$test_status.'') But I need to include the variables in this order: <input type=hidden name="Products" value="Price::Qty::Code::Description::Flags"> Anyone know what the variables are that I need to enter to make this work? Variable for price is already there, so I need Variable for quantity Variable for code/model number Variable for description/product name Or where I can find what the variables are classified as?? Any help would be appreciated...
  3. Josaram

    Help with InternetSecure Set Up

    I've got the newest contribution of internet secure running, but it does not pass my product numbers, product name, etc to the payment processing page, just the final total. Does anyone know where or how I can these variables to be passed? Any help would be appreciated so that I can get this going.
  4. Josaram

    InternetSecure on MSv1.2 store

    I am wanting to get internet secure up and going for my site. I've installed the basic contribution - but as already know it doesn't account for attributes - and that worked fine. Then I installed the contribution to fix the attribute problem (so it will send additional pricing for the attributes to the internet secure site and add it to the total) However, this doesn't work, and I suspect it is because the code is set to MS2.2 instead of my older version. I think I need to make it link to the appropriate classes etc to my version. My question is, does anyone which file lists all the classes and codes for how oscommerce sees each factor: price, attribute, product model, etc - so that I can compare mine listing to the code I need to edit?? I've done well getting this store going without a lot of knowledge of php, and I've been learning all along, but this one has me stumped. Any help would be appreciated.
  5. I am very interested in using e-select from moneris, but curious is there is already a module to integrate it. Here is e-select website: http://www.moneris.com/index.php?context=/...com_eselectplus I found this contribution, but so far, haven't had success opening it or finding a readme.txt file to tell me if this is the payment module I am looking for... http://www.oscommerce.com/community/contri...ons,1592/page,3 If anyone has any experience with e-select or this contribution, I'd love to hear what you have to say...
  6. I have installed the 'Searching 404 page' contribution found here: http://www.oscommerce.com/community/contributions,940 But it asks to add some errordocument lines to a .htaccess file. Does anyone know the direct path to the particular .htaccess file - as so far I have found at least 2 of these files on different paths. If someone could also let me know exactly where to insert those three lines in the .htaccess file, I would really appreciate it... Thanks in advance for any help anyone can give
  7. Hello everyone, I am trying to intall the 'searching 404 page contribution' and everything is looking fine, except trying to install the code to direct the webserver. I am running MS1 loaded, have followed the readme.txt files, but can't find which .htaccess file I need to add this too (I have found three files, but not sure which one, or how to insert the code into it): ErrorDocument 404 /catalog/404.php ErrorDocument 500 /catalog/404.php ErrorDocument 401 /catalog/404.php If anyone can post the whole path to the .htaccess file, as well as where to insert this code in the file, I'd really appreciate it. Any help would be appreciated - otherwise all the rest of the contribution seems to have worked well up to this point.
  8. Josaram

    Help with shipping through Canada Post

    My store is also Canadian, and I tried the Canada Post module, but never got it to work. Instead, I now offer flat rate shipping fees based on item weight, and so far, it's been pretty accurate. If I have a very light item that packs large, I just cube its weight in my product description entry so that it will still accurately affect Canada Post rates. Just let me know if anyone wants the table rate I've been using (only have it set up for Canada Post Expedited within Canada) but so far so good - I'm sure I'll still get a couple orders that cost more than what the customer is charged, but I'm currently getting about $0.50-$1.00 extra in shipping fees. The other key to ensure your weights accurately reflect the item and how Canada Post will classify it. Jolyn email: info@nuanceoccasions.com
  9. Josaram

    Bug in Loaded 5?

    It's already a known bug - patch 2 for loaded 5 corrects this issue with the "New Products" not going through to checkout. If using the loaded version, check here for updates and bug reports: http://www.phesis.co.uk/
  10. I'm running MS1 loaded v.5 and all process seem to be working well, until I enter a discount code on the payment processing page - then I get this error message: 1064 - You have an error in your SQL syntax near '<= '0' where products_id = '36'' at line 1 update products set products_status <= '0' where products_id = '36' [TEP STOP] I've managed to get my store pretty much set up, even though I'm not very familiar with code. Could anyone point me to what this message may mean, and how to go about correcting it?? Thanks for any assistance.
  11. Thank you for your reply, I'll give that a try this weekend!! :D
  12. Thanks to this site, without knowing much code, I've managed to get my store up and running, and nearly completed. I'm trying to install the Customer Specific Discount v1.1 - as I don't want to change product price classes, I just want a flat discount per customer class. I'm running the CVS-2.2 and the only other modification was the store pick-up contribution - I really haven't changed very much. Anyhow, I've installed the two files, and ensured they were in place, I've edited the code (copy and paste) according the contribution files. I've double checked all those files, and code, and things seem to be exactly how they should be. When I go to the admin/customers area, and click a customer to edit, I ge the following error message: 1054 - Unknown column 'c.customer_discount' in 'field list' select c.customers_gender, c.customers_firstname, c.customers_lastname, c.customers_dob, c.customers_email_address, a.entry_company, a.entry_street_address, a.entry_suburb, a.entry_postcode, a.entry_city, a.entry_state, a.entry_zone_id, a.entry_country_id, c.customers_telephone, c.customers_fax, c.customers_newsletter, c.customer_discount, c.customers_default_address_id from customers c left join address_book a on c.customers_default_address_id = a.address_book_id where a.customers_id = c.customers_id and c.customers_id = '3' [TEP STOP] The only part of the install instructions I haven't done anything with (because I don't understand what to edit), is this line from the contribution README.TXT: You need to add one field to the customers table. Here is the SQL statement that would accomplish this : ALTER TABLE customers ADD customer_discount DECIMAL(5,2) DEFAULT '0' NOT NULL; Could someone please tell me in plain english what code I need to remove or change and in what files those are located in??? I would appreciate any help that could be provided to a newbie to code. Thanks! Jolyn
×