Jump to content

evanism

Members
  • Content count

    2
  • Joined

  • Last visited

Profile Information

  • Real Name
    rumplestiltskin
  1. evanism

    Google XML Sitemap SEO

    Hi all, a bit of a confusing issue I hope the collective wisdom can solve. Using the latest install, which was working smoothly, suddenly fails with: - the deletion of the Google XML SEO link from admin->Config (and the row in the configuration_group table as well!) - failure of generation bombing out with..... <b>Warning</b>: fopen(/sitemapproducts.xml) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in <b>/home/xxxx/public_html/xxxxxxx/googlesitemap/sitemap.class_Alternate.php</b> on line <b>354</b><br /> ERROR: Google Product Sitemap Generation FAILED! - all the others fail too, with the same error. - all the xml files are set to 0777 for good measure - diagnostics point to a permissions issue, but they have not changed, and are on max What is REALLY odd is this was working for weeks then suddenly dies. I "fixed" it be re-installing everything from scratch, confirmed it worked by hand, ran a few crons to test and then left it thinking it was a glitch in the matrix..... now, it pops right back - exact same issue. What freaks me out is that the row is deleted from configuration_group table.... I cant find any code that would be doing this, and the failure is seemly utterly random. Thanks friends, Ev
  2. evanism

    Google XML Sitemap SEO

    or you could just run: delete from configuration where configuration_group_id = '289'; delete from configuration_group where configuration_group_id = '289'; and then rerun the SQL from the package. I also found that the admin>config > Google XML SEO just "disapeared". Very odd. Rerunning the above fixed it quick smart. Evan
×