Jump to content

flatcat

Members
  • Content count

    28
  • Joined

  • Last visited

1 Follower

Profile Information

  1. flatcat

    Header Tags SEO

    Very minor bug. The social bookmark images show an extra slash before the image in the source view. Found if I edited the includes/modules/header_tags_social_bookmarks.php as follows it fixes it: sample code: changed . . <td><a rel="nofollow" target="_blank" href="http://digg.com/submit?phase=2&url=<?php echo $URL . '&title=' . $TITLE; ?>"> <?php echo tep_image(DIR_WS_IMAGES . '/socialbookmark/digg.png', 'Add ' . $NAME . ' to Digg'); ?></a></td> . . to . . <td><a rel="nofollow" target="_blank" href="http://digg.com/submit?phase=2&url=<?php echo $URL . '&title=' . $TITLE; ?>"> <?php echo tep_image(DIR_WS_IMAGES . 'socialbookmark/digg.png', 'Add ' . $NAME . ' to Digg'); ?></a></td> . . Doesn't affect the display of the icon, it's just that I still can't get google to index my site and it was one of the things it complained about. If no one else is having this issue then I obviously have my config file set up differently.
  2. flatcat

    Contribution: Auto Backup Database

    It seems years of collecting data with user tracking bloated the database considerably. On closer investigation it looks like the purge did not work, so records were emptied from the database via phpmyadmin. The autobackup now works on the much smaller database. Many thanks for your help and suggestions.
  3. flatcat

    Contribution: Auto Backup Database

    That addon was also installed before the autobackup (or possibly around the same time). It seems to run up until it has 7.9MB of sql and then it conks out with the error described. (It used to end up with about 60MB gzipped). It may easily be something altered on the server. Any suggestion where and what I can change server-wise? Through control panel for instance. I don't really think it is caused by your contribution, but yours is the one it shows up on. Any help appreciated :)
  4. flatcat

    Contribution: Auto Backup Database

    User tracking has been on there for years, way before I added Autobackup. It happens when the autobackup starts up
  5. flatcat

    Contribution: Auto Backup Database

    After using this successfully for a number of months I am suddenly getting this error: Warning: mysql_query() [function.mysql-query]: Unable to save result set in /home/*********/admin/includes/functions/database.php on line 45 2008 - MySQL client ran out of memory select customer_id,click_id,full_name,session_id,ip_address,time_entry,time_last_click, last_page_url,page_desc from user_tracking I have run a check on Mysql database via cpanel and all looks OK. (Have also purged all records past last 72 hours in user_tracking) Any ideas?
  6. flatcat

    Contribution: Auto Backup Database

    Hi, Is there an easy way to limit the number of archive backups stored? I have been deleting the older archives via the admin panel but it would be nice if you were able to do so automatically. Example: backup every hour, archive every day and only store last two archived backups. Great mod by the way. Thanks
  7. flatcat

    [CONTRIBUTION] CCGV (trad)

    Don't know if this will work for everyone, but it certainly worked for me: In includes/functions/sessions.php if you find the following code function tep_session_register($variable) { global $session_started; if ($session_started == true) { if (PHP_VERSION < 4.3) { return session_register($variable); } else { if (isset($GLOBALS[$variable])) { $_SESSION[$variable] =& $GLOBALS[$variable]; } else { $_SESSION[$variable] = null; } $GLOBALS[$variable] =& $_SESSION[$variable]; } } return false; } then replace it with function tep_session_register($variable) { global $session_started; if ($session_started == true) { return session_register($variable); } else { return false; } } Haven't found any adverse effects yet but ... use at your own discretion (my site is very, VERY heavily modded, so it may not apply to all)
  8. flatcat

    [CONTRIBUTION] CCGV (trad)

    It is redundant, so should be commented out. Still, it might help someone in troubleshooting.
  9. flatcat

    [CONTRIBUTION] CCGV (trad)

    Don't know if this helps or not, but in the /INCLUDES/MODULES/ORDER_TOTAL/OT_COUPON.PHP file there are two lines commented out - line 85: // $image_submit = '<input type="image" name="submit_redeem" onClick="submitFunction()" src="' . DIR_WS_LANGUAGES . $language . '/images/buttons/button_redeem.gif" border="0" alt="' . IMAGE_REDEEM_VOUCHER . '" title = "' . IMAGE_REDEEM_VOUCHER . '">'; and line 87: // $selection_string .= ' <td align="right">' . $image_submit . '</td>'; By removing the "//" the REDEEM button suddenly appears on the payment page... They might be meant to be commented out, but it also might help someone in troubleshooting.
  10. flatcat

    Product Image Deleter

    To help those whose hosts still run PHP 4 In image_delete.php replace require('includes/application_top.php'); with require('includes/application_top.php'); // for PHP 4 versions if (PHP_VERSION < 5) { function scandir($dir) { $dh = opendir($dir); while (false !== ($filename = readdir($dh))) { $files[] = $filename; } sort($files); return $files; } }
  11. flatcat

    Product Image Deleter

    Looks like a good idea but it seems to be missing the function scandir() (Fatal error: Call to undefined function: scandir() in ......)
  12. flatcat

    Paypal Wpp Uk Bypassing Delivery Page

    Hi, Did you ever get an answer to this? I have the same problem and had to put in a very dirty fix - not really a solution
  13. flatcat

    Automated Auction Process

    Click here for an example
  14. flatcat

    Automated Auction Process

    If the auction data is in the table, and the products_id is 0, then it means it can't match the title of the auction listing on your site with the title of the auction listing on ebay. You have to have an auction listing on your site before it can make the match, so yes, you do need to make an auction first (via the auction listings in the admin area). Once you have made this listing you can use the tool to make the ebay listing or just do it manually (or if you already have the ebay listing done, just verify the titles are exactly the same) You should now empty your auction_data table and try again. Hopefully it should all now work. Remember, the listing must be on your site before you update or else it won't be able to match the titles. Hope this is clear.
  15. flatcat

    Automated Auction Process

    Take a look in your database under the auction_data table. Just because the it says there are no auctions doesn't mean it didn't find them. If the items are listed there (and the products_id is 0, meaning no match on the title), then empty the database table and update again. If the title in your AAP listing is **exactly** the same as the ebay title (with no funny characters - mine didn't like the ampersand for instance) then it should now work OK. If the page goes completely blank - nothing in the browser window at all - then I would suggest the code was corrupted somewhere. Obvious, I know, but it is surprising how many times a ";" or a "{" gets left out during a cut-and-paste. Hope this helps
×