Jump to content

EIF

Members
  • Content count

    25
  • Joined

  • Last visited

Profile Information

  1. EIF

    Header Tags SEO

    Thanks! I compared both files. Mine was a little messed up. It works now. Great contribution!
  2. In my .htaccess file I added the following code: Options +FollowSymLinks <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteRule ^(.*)-p-([0-9]+).html$ product_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-c-([0-9_]+).html$ index.php?cPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING} RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING} </IfModule>
  3. I read this threat, but can't find the answer for my problem. This contribution works fine, setting the url format on Standard. Switching to Rewrite however, navigation fails. Clicking on a product, the site navigates to the root. (local it goes to http://localhost. The shop is in http://localhost/shop) Clicking on a product in the specials box, I get returned 'object not found' error. I do not have any redirect javascripts running. Can someone please help me out?
  4. EIF

    Header Tags SEO

    I still can't figure out what is wrong, after reading the trouble shoot? I set the permissions right, but stil can't edit the product title tag, description tag or keywords tag by myself. Can someone please help me out?
  5. EIF

    Header Tags SEO

    I installed this contribution and it works great, except one thing. When you add a new product, you can fill in the 3 fields: Product title tag, Product description tag, Product keyword tag. After doing that, I save/add my new product. But when going back to edit the product, all the filled in tags are gone. I do can automatically fill in the 3 fields with the product title. I also do can automatically fill in the description tag. But I want to add/edit those tags by my self. What is it, why I can't save the manually added tags?
  6. This contribution runs perfectly now, but now I want to install Ultimate SEO URL, version 2-2.2d-10. These two are conflicting with each other. Can't add products to the cart anymore from the listing. Or when in the product_info, I can, but when go to another product, the cart is empty again. Does someone has experience with both contribution and can help me out?
  7. I want to install this must have contribution. But also have the "product listing enhancement" installed (http://addons.oscommerce.com/info/6051) These two are conflicting with each other. Can't add products to the cart anymore from the listing. Or when in the product_info, I can, but when go to another product, the cart is empty again. Does someone has experience with both contribution and can help me out?
  8. The what's new box has changed in this contribution. Instead random selected products, it shows new products in an array with a default direction. For example: show pic 1, pic 2, pic, and so on. Perfectly for the main index page. But when the vistor navigate to products, the what's new box starts over again, beginning showing pic 1 in the samen default direction. Then the vistor navigate further to another product and again the what's new box starts over again, beginning with pic 1. When navigating quite fast, always the samen product will show up in the what's new box. I want this contribution the what's new box displays products at random. Can someone help me out?
  9. The product_listing show the medium sized image when it is an additional image. The first image you add to your product, the product_listing picks the small image.... I want also the first image to be the medium sized one, for that products which do not have additional images.
  10. What do I need to change to get de medium sized images in the productlisting, leaving the small images in the "What's new" box?
  11. An easy one (?) but I don't get it... How do I get the price next to the add_cart image? (I only display the small by now)
  12. When I delete the _over image, the details and buy now button levels again. This contribution uses the following code in html_output.php. Does someone what to change to correct this problem? //// // The HTML form submit button wrapper function // Outputs a button in the selected language function tep_image_submit($image, $alt = '', $parameters = '') { global $language, $button_class;$image_src = tep_output_string(DIR_WS_LANGUAGES . $language . '/images/buttons/' . $image); $iefix = '<a href="javascript:void(0)">'; //set to $iefix = ''; if your using an xhtml doctype list($width, $height) = getimagesize($image_src); $idx = strrpos($image,'.'); $id = substr ($image,0,$idx); $hover_image = tep_output_string(DIR_WS_LANGUAGES . $language . '/images/buttons/' . $id . "_over" . substr ($image, $idx)); $hover = file_exists($hover_image); $image_submit = '<input type="image" src="' . $image_src . '" border="0" alt="' . tep_output_string($alt) . '"'; if ($hover) $image_submit = $iefix . '<img alt="" src="' . $hover_image . '" style="display:none" /><input type="submit" value="" class="' . $id . '"'; if (tep_not_null($alt)) $image_submit .= ' title=" ' . tep_output_string($alt) . ' "'; if (tep_not_null($parameters)) $image_submit .= ' ' . $parameters; $image_submit .= '>'; if ($hover && $iefix) $image_submit .= '</a>'; if ($hover) $button_class .= '.' . $id . ' { border: none; background: url("' . $image_src . '") no-repeat top left; width:' . $width . 'px; height:' . $height . 'px; cursor:pointer;} input.' . $id . ':hover, a:hover input.' . $id . ' { border: none; background: url("' . $hover_image . '") no-repeat top left; } '; return $image_submit; } //// // Output a function button in the selected language function tep_image_button($image, $alt = '', $parameters = '') { global $language, $button_class; $image_src = tep_output_string(DIR_WS_LANGUAGES . $language . '/images/buttons/' . $image); list($width, $height) = getimagesize($image_src); $idx = strrpos($image,'.'); $id = substr ($image,0,$idx); $hover_image = tep_output_string(DIR_WS_LANGUAGES . $language . '/images/buttons/' . $id . "_over" . substr ($image, $idx)); $hover = file_exists($hover_image); $button = '<img alt="" src="' . $hover_image . '" style="display:none" /><img src="' . DIR_WS_IMAGES . 'pixel_trans.gif' . '" class="' . $id . '" alt="' . tep_output_string($alt) . '"'; if (tep_not_null($alt)) $button .= ' title=" ' . tep_output_string($alt) . ' "'; if (tep_not_null($parameters)) $button .= ' ' . $parameters; $button .= '/>'; if ($hover) { $button_class .= '.' . $id . ' { border: none; background: url("' . $image_src . '") no-repeat top left; width:' . $width . 'px; height:' . $height . 'px; cursor:pointer;} a:hover img.' . $id . ' { border: none; background: url("' . $hover_image . '") no-repeat top left; } '; return $button; } else { return tep_image(DIR_WS_LANGUAGES . $language . '/images/buttons/' . $image, $alt, '', '', $parameters); } }
  13. Hmmm, I see already changed it to 0px. But now I remembered when it went wrong. I installed the contribution "pure css button image swap". When I restore my backup, the detail button levels with the buy now. This contribution messed the thing up.
  14. I have the same problem as No. 2. I use Firebug, but I'm not that proffesional in programming. How do I know what to change to lever both pics?
  15. Maybe a noob question, but how can I get the 'buy now' and 'details' on one line in Internet Explorer? In Firefox is looks perfectley, but in IE the 'details' pic posistions 3 pixels or so higher then the 'buy now' pic.
×