Jump to content

Kingdom3D

Members
  • Content count

    56
  • Joined

  • Last visited

1 Follower

About Kingdom3D

  • Birthday 04/15/1966

Profile Information

  • Real Name
    Tim Cole
  • Website
  1. Kingdom3D

    Page titles not showing properly

    Ooops! Sorry for the post in the wrong section.
  2. Kingdom3D

    Page titles not showing properly

    I've installed STS v4 with Header tags. Now My page titles are not displaying right. 1. On my "About Us" page (which I added manually) the page title displays the osCommerce header text variable - "HEAD_TITLE_TAG_ABOUTUS" instead of the defined header text - "About Us" as defined in my includes/languages/english/about_us.php. I've cross referenced the other information page code to verify that the filename designations and the title text defines are coded right. 2. On rest of pages, except the final product pages, it shows "osCommerce" in place of my store name in the page title. Example: For a category page the title show: "My Category - osCommerce". How do I replace the "osCommerce" reference with my store name? Here is the site I'm working on: GloryArt.net Any Help is greatly appreciated.
  3. Kingdom3D

    1 template for all product info content

    Thanks - I'll download the new service pack and give it a try.
  4. Kingdom3D

    1 template for all product info content

    I'll do a compare to see what turns up. Only 2 other contribs installed - HeaderTag and PayPay IPN.
  5. Kingdom3D

    1 template for all product info content

    I've got the catalog/includes/modules/sts_inc/product_info.php. I don't have the one in the /modules/sts/ folder. The closest one there by name is sts_product_info.php.
  6. Kingdom3D

    1 template for all product info content

    Thanks for the quick reply. I started with the "product_info.php_26.html" example, made my custimizations and saved it as "product_info.php.html". As for the Character Set, I checked the sample index.php.html as well as mine, and neither have it defined in the header. The html for my "product_index.php.html is short so here it is: (I've highlighed the template tag in red) ----------------------------------------------------------------- <?php DEFINE ('STS_CONTENT_END_CHAR', '$'); ?> <table border="0" cellpadding="3" cellspacing="0" width="100%"> <tbody> <tr> <td valign="top"> $startform$ <table style="width: 100%; text-align: left;" border="0" cellpadding="6" cellspacing="2"> <tbody> <tr> <td style="vertical-align: top;">$productname$<br /> $productmodel$</td> <td width="200" style="vertical-align: top;"><div align="center"> $regularprice$</div></td> </tr> <tr> <td style="vertical-align: top;">$productdesc$</td> <td width="200" style="vertical-align: top;"><div align="center"> <p>$imagesmall$</p> <p>$optionchoices$</p> <p>$addtocartbutton$</p> </div></td> </tr> <tr> <td colspan="2" style="vertical-align: top;"> <div align="center">$imagelarge$</div></td> </tr> <tr> <td colspan="2" style="vertical-align: top;"><div align="center">$optionchoices$?????$addtocartbutton$</div></td> </tr> </tbody> </table> $endform$ </td> </tr> </tbody> </table> -----------------------------------------------------------------
  7. I've spend 4 hours trying to accomplish what I know should be a simple task according to the pdf manual for this contribution (which I greatly appreciate!). Should be an easy answer . . . I've installed STS v4 and HeaderTagController contrib. All three levels of templates are enabled in the Admin>Modules>STS panel. I'm using a single template for the store and only need 1 template to format the product info content for all the products (small shop right now). Here's where I've placed my index template files: Index Template: sts_tempates/store/index.php.html, sts_templates/store/sts_template.html Product Info Template: sts_templates/store/Content/product_info.php.html Here are my settings for each of the 3 levels in the sts module in the admin panel: Default: Default template (v1.0.5) Use Templates? true Code for debug output: debug Files for normal template: sts_user_code.php;headertags.php Template folder: store Default template file: sts_template.html Use template for infoboxes: false Index: Index template (v1.0.3) Use template for index page: true Files for index.php template: sts_user_code.php;headertags.php Check parent templates: true Products info: Product info templates and content templates (v1.0.6) Use template for product info page: true Enable STS3 compatibility mode: false Files for normal template: sts_user_code.php;headertags.php Files for content template: sts_user_code.php;product_info.php.html The index and default templates work, the product_info content template does not display. Where have I gone wrong? I know I could manually just edit the actual product_info.php in the cart directory, but then I'm stuck with one product_info layout forever. Any Help is very much appreciated.
×