Jump to content

meshdesign

Members
  • Content count

    63
  • Joined

  • Last visited

2 Followers

Profile Information

  • Real Name
    Daniel Hodkinson
  1. I have been setting this up for a few hours now and it has been a massive help to me. However i have run into one problem i could use a bit of help with, on the old product listing I had an IF code whereby if a product was in category X it wouldn't show the add to cart button, instead it would show a call us for details button, as shown below: if($cPath == 425){ $lc_text = '<a href="' . tep_href_link(FILENAME_CONTACT_US) . '">' . tep_image_button('call-button.png', TEXT_CALL_FOR_PRICE) . '</a>'; //$lc_text = TEXT_CALL_FOR_PRICE; } else{ $lc_text = '<a href="' . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $listing[$x]['products_id']) . '">' . tep_image_button('button_buy_now.gif', IMAGE_BUTTON_BUY_NOW) . '</a> ';} break; I believe this works similar to how if the price is 0.00 then the POA is shown and the add to cart button is replaced with details button, could somebody help me where to start with this, i've been messing about for a few hours but i'm struggling to get the results i need. Thanks Dan
  2. meshdesign

    "Dynamenu" for osCommerce

    yeah it turns out it wasnt the CSS of it, i added manual links for Home and Exclusives in the template file of dynamenu, Firefox didnt see a problem with this but it offset everything by about 100px in IE7, so i had to add the links in the STS template instead! it took me until i found a working version of dynamenu in IE7 to know it couldnt be CSS! Dan
  3. meshdesign

    "Dynamenu" for osCommerce

    i cant be the only one with this problem so i'm wondering what i have done wrong? i thought maybe i had changed my css so i inserted the original css but the same problem occurs.. i have trawled through pretty much every page of this forum to no avail so i am really stumped as to the problem. if anybody can offer me any help it would be amazing! thanks
  4. meshdesign

    "Dynamenu" for osCommerce

    hi all, got a big problem with ie7 and dynamenu with the sub-menu positioning. When the first sub-menu flies out it appears in at the right position with left:0; but appears in a random place at the top, it also seems dependant on how far down the screen you have scrolled. i presume it is to do with: .vertsubmenu { /* Behaviour of sub-menu - leave as is for proper operation of submenus */ position: absolute; left: 0px; top: 0px; visibility: hidden; } but for all the deeper levels of sub-menus they work fine. it works fine in firefox and chrome, the domain is here if you want to see what it looks like, i am going to keep playing about with the css but i have the client on my back so if anybody could help me out it would be much appreciated! thanks Dan
  5. meshdesign

    "Dynamenu" for osCommerce

    Great cotribution, i have been playing about with it for quite a while. However i have a bit of an issue i could do with peoples help on. I am using the vertical fly out which works great but the sub-menu goes behind a swf that i have on my home-page, and i can't figure out why. I have tried fiddling about with the z-index but that doesnt seem to sort anything, and it is only this one swf it is falling behind. I have had to turn off the dyna menu for now as i can't have my customers using it like that, but the site can be seen at my site it is the big swf in the middle of the page. thanks for any help dan
  6. meshdesign

    "Dynamenu" for osCommerce

    got another quick question, managed to get my site working locally, but the vertical and horzontal fly out dont display properly in wamp server - had a quick look through the pages but couldnt see anything, anybody else had this problem? dan
  7. meshdesign

    "Dynamenu" for osCommerce

    Hi all, is it possible with dynamenu to customise it to go between 2 of the options. i.e. i have a category with 3 sub categories - is it possible to have the first level as a tree and then the second level as a drop down menu. i will be trying to figure this out myself but i first need to find out how to split my sql file so i can test it locally :) thanks for any advice Dan
  8. meshdesign

    Store Mode (Open | Closed | Maintenance)

    I need to start from scratch with store mode as i am currently having problems with adding items to my cart. I backed up the database but have never had much luck restoring it and have never really had to, is there a find and replace i can do on the SQL file which will go through and remove the store mode sql additions? Regards Dan
  9. Hi all, trying to get to grips with the latest protx form contribution. (couldnt find a proper forum thread, please give me a link if there is one) 1. i am in the testing phase and i have got it into a position where the order goes through and myself and the customer receives a confirmation email from SAGEPAY. 2. However when i click the proceed button on sagepay it does not re-direct me to the confirmation page - just back to the start of the checkout procedure with the items still in my basket. 3. orders are not saved to the database 4. transactions are not shown in my sagepay (but i'm 99% sure this is a sagepay issue) I am not PREAUTH enabled, and am unsure whether that is a reason behind it. If anybody could advise me it would be the most appreciative i've been for a long long time :D as i have customers breathing down my neck wondering why they can't order anything yet, Kind Regards Daniel Hodkinson
  10. 2. Windows XP 3. no error messages 4. you can download the file at CSV File here 5. with a few products that i upload it removes the product name - there are about 19 items and they all seem to be ones that have 0's in front of them that then get removed in the csv script. the items are (without the 0's) 13099102 13099132 521 531 99971 30091 31331 37331 40301 40401 90201 90202 900961 90170102 90170106 90170132 90180102 90180106 90180132 i also have a problem with my tax rate not being added on in the checkout, is that more likely to be an oscommerce problem or something to do with easy populate as i saw something about checking EP_PRICE_WITH_TAX but not sure where to find it or if that has anything to do with it? thanks for any help Dan
  11. ok i see it: 1. I have set EP_SHOW_EP_SETTINGS to true, but i dont understand what is needed for "then copy the settings & server info that are displayed on the EP main page into your post." 2. I am running Windows XP 3. no error messages 4. you can download the file at CSV File 5. i had one problem where it repeated the sub-categories over and over, found that i had to change the category length which solved that problem, now i have a problem where it is repeating one of the main categories over and over, it may be to do with the product description which is around 500 characters, i'm not sure. you can see my problem here.
  12. trying to get involved with easy populate, i had one problem where it repeated the sub-categories over and over, found that i had to change the category length which solved that problem, now i have a problem where it is repeating one of the main categories over and over, and it is is only 4 characters in length. you can see my problem at My Site if you could offer any help it would be much appreciated, i have looked through the troubleshoot and searched google but can't find anything. Thanks Dan
  13. meshdesign

    [Contribution] MATC

    thanks for this, great contribution. as i already had something installed in id 73 in the sql file i took a gamble and replaced all of the numbers with 74, still worked perfectly. Excellent Work Dan
  14. meshdesign

    UK-Based: Default osCommerce Installation.

    Just read through this whole thread and its been a major help, i am one of the ones modifying files so as not to lose my data. The step by step guides at the start were fantastic i was wondering if a couple more could be done to help me: - Add UK currency. - Add UK tax information. This would be a major help to me as i am going live soon. Also a quick opinion, as i only plan to sell in the uk, is it worth keeping all of those zones and countries or should i get rid of them all bar the uk? Thanks Dan
×