Jump to content

eyal_barouk

Members
  • Content count

    33
  • Joined

  • Last visited

Posts posted by eyal_barouk


  1. Hi,

    I can't seem to get ULTIMATE Seo Urls 5 to work for me. (RCA2)

    installer.php went fine and all code replaced and uploaded.

     

    If "Choose URL Rewrite Type = rewrite" - (I understand that I have to use rewrite because I have Header tags SEO installed) the page gives an error : "Redirect Loop"

    If "Choose URL Rewrite Type = standard" the I get the "FWR MEDIA - Page not found" message.

     

    When Setting Enable SEO URLs?=false, I get products missing images and 0.00 for prices

    This is the second attempt of installing it and with the same results.

    Confused,

    Thank you,

    Eyal


  2. Hi,

    I'm in the process of installing this impressive contribution and I have general problem:

     

    My store is Multilanguage store (hebrew,english,arabic)

    1.The site always reverts back to the English language. I can start with Hebrew on a such as:

    http://www.my_store.com/catalog/index.php?language=en

    but when clicking a category link the path changes to:

    http://www.my_store.com/catalog/index.php?cPath=1

    At this point the language is still Hebrew, but if I wait for a while an hit "Refresh" the store will jump back to English, regardless of Default language settings.

    2.

    As a result of 1. wouldn't that cause me trouble with google indexing? - If a page will always be indexed without the ?language= parameter Customers will never be able to reach my Hebrew or Arabic pages directly from the Google search.

     

    So:

    I would like to display all links with the language parameter, no matter where:

    http://www.my_store.com/catalog/index.php?...amp;language=he

     

    Can this contribution help me with that?

    I have posted this question in two more places but got no answer and a little at lost here.

    Please,

    Thank you,


  3. Hi Jack,

    I have a general question, which I'm not sure where to place. I have tried on the General forum but got no replies. Since you are involved in so many contributions, and since you reply in such great patience, I thought you might be able to shed some light on the matter. I don't believe this wasn't mention before but I have been looking and looking and couldn't find the right answer/contribution.

     

    I have a Multilanguage store (hebrew,english,arabic - soon) with three problems.

     

    1.The site always reverts back to the English language; I can start with Hebrew, for instance:

    http://www.my_store.com/catalog/index.php?language=he

    but when clicking a category link the path changes to:

    http://www.my_store.com/catalog/index.php?cPath=1

    At this point the language is still Hebrew, but if I wait for a while an hit "Refresh" the store will revert back to English, regardless of Default language settings.

    2.

    As a result of 1 - wouldn't that cause me trouble with google indexing? - If a page will always be indexed without the ?language= parameter Customers will never be able to reach my Hebrew or Arabic pages directly from the google search.

    3.

    I guess this is also true for sitemaps. I have tried the google XML siute map but I understand that it doesn't produce the language parameter too (I created the special language-xml file manually based on the xml sitemap ).

     

    So:

    I would like to display all links with the language parameter, no matter where or when:

    Can Ultimate Seo Urls 5 solve my troubles?


  4. You have to enter text in the boxes for Page Control->index.php t have text show up on the home page. And beside each checkbox in page control, there is a box for the sort order. You have to enter a number in each one you have selected.

     

    Jack

    Got it to work! and I see the category name combined with the title.

    I didn't realize that I need to select "Show all pages" to display the sort order boxes for index.php

     

    Thank you again for your time and fine contributions.


  5. If you see the correct information in admin, then the problem is either in the index.php file changes or the includes/header_tags.php file. Since both of those are supplied, it should be a simple matter of determining which.Jack

    I even went and completely replaced my modified index.php and includes/header_tags.php with original ones from the package - still no go.

    In "Page control", if I remove the "Default Tags -> title:" for the index.php then I see ONLY the category name in the title.

     

    In Page control, for index.php, enable "category" checkbox and insert an order (1,2,3,4, etc...) for each box you have checked.

    All the boxes are checked in the page control but I'm sorry, I didn't get the "insert an order (1,2,3,4, etc...)" part.

     

    Thank you so much for your help & patience!


  6. Category name doesn't show in the page title.

    Set the admin->"Display Category Parents in Title and Tags to Full Category Path, clear your browsers cache and click around a few categories. They should display. if you are using a url rewriter contribution, try turning that off tempoairly so you can better see the path.

     

    Jack

    Thanks you Jack. I have done what you suggested but still I don't see the category name title.

    I have just noticed that my index page has the -- in the title too, so some description is missing there too, I think.

    With that, the product page, product_info.php?cPath=24&products_id=67 for instance, is showing the full title (with product name) as expected.

     

    thanks,


  7. Hi,

    I have installed Header Tags SEO V 3.0 from catalog_for_new_shop_only_RC2

    I have this great contribution up and running. All my tags are filled and the 'test' runs fine.

     

    Problem: I don't see the category name in the title when showing the category root on the client side. instead I get: --

    I checked the categories_description table and all the tag fields are filled.

     

    I have tried all of the admin->"Display Category Parents in Title and Tags" options but it doesn't seem to matter.

    I checked and rechecked the installation and all seems fine.

     

    Can you please advise? I'm not sure where else to look.

    Thank you,

    my shop if you may http://www.colors-etc.com/catalog


  8. You just need to compare each line to the stock osCommerce and see what is added. Header Tags adds cd.categories_htc_title_tag, cd.categories_htc_desc_tag, cd.categories_htc_keywords_tag, cd.categories_htc_description, so far as I recall. Thee could be more. The Categories Images Box adds c.categories_image_front, to the same SQL.

    Regards

    Jim

    Got them to work together! It was actually pretty easy once I started reading the code instead of blindly bulk copy/paste it as I did with all the other contributions I have installed.

    Thank you so much for your help.


  9. You can't just duplicate that code and expect it to work. You have to merge the changes in each line into the original code. Take the Contributions one at a time and compare the changes to the original code, then make the changes in your copy.

     

    Regards

    Jim

    Hi Jim, thank you for this quick reply.

    I did take it one at a time and I only got stuck in this part.

    I found that, on the part I have posted, (Removed?) that each contribution works fine on it's own but not together. I have to admit that I gave up after a short struggle - I didn't want to mess up the code not being sure exactly what it does; plus, I thought maybe some one else got this problem and so maybe an official solution might be posted to the community benefit.

    My Problem is not a critical because I don't update the tags from the category section anyway. Just wondered for perfection sake.


  10. Hi,

    I have it installed and running - I love it. very nice!

     

    I'm having trouble using this contribution along with the excellent Header tags SEO module http://addons.oscommerce.com/info/5851/v,22

     

    Mainly (but not sure) in admin/categories.php

    After installing both contributions I get the code around line 976:

    if (isset($HTTP_GET_VARS['search'])) {
      $search = tep_db_prepare_input($HTTP_GET_VARS['search']);
    
    /*** Begin Header Tags SEO ***/
    /*	  $categories_query = tep_db_query("select c.categories_id, cd.categories_name, c.categories_image, c.parent_id, c.sort_order, c.date_added, c.last_modified, cd.categories_htc_title_tag, cd.categories_htc_desc_tag, cd.categories_htc_keywords_tag, cd.categories_htc_description from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_id = cd.categories_id and cd.language_id = '" . (int)$languages_id . "' and cd.categories_name like '%" . tep_db_input($search) . "%' order by c.sort_order, cd.categories_name");
    } else {
      $categories_query = tep_db_query("select c.categories_id, cd.categories_name, c.categories_image, c.parent_id, c.sort_order, c.date_added, c.last_modified, cd.categories_htc_title_tag, cd.categories_htc_desc_tag, cd.categories_htc_keywords_tag, cd.categories_htc_description from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.parent_id = '" . (int)$current_category_id . "' and c.categories_id = cd.categories_id and cd.language_id = '" . (int)$languages_id . "' order by c.sort_order, cd.categories_name");
    /*** End Header Tags SEO ***/
    
    // Categories images box
      $categories_query = tep_db_query("select c.categories_id, cd.categories_name, cd.categories_description_front, c.categories_image, c.categories_image_front, c.parent_id, c.sort_order, c.date_added, c.last_modified from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_id = cd.categories_id and cd.language_id = '" . (int)$languages_id . "' and cd.categories_name like '%" . tep_db_input($search) . "%' order by c.sort_order, cd.categories_name");
    } else {
    // Categories images box
      $categories_query = tep_db_query("select c.categories_id, cd.categories_name, cd.categories_description_front, c.categories_image, c.categories_image_front, c.parent_id, c.sort_order, c.date_added, c.last_modified from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.parent_id = '" . (int)$current_category_id . "' and c.categories_id = cd.categories_id and cd.language_id = '" . (int)$languages_id . "' order by c.sort_order, cd.categories_name");
    }

    In this state I get an error about the "else" command being out of place. I have ended up //unmarking the Header Tags SEO part in these lines.

    Is there a solution for this?

    Thanks you,

    Eyal


  11. Hi

     

    First off great mod, thanks a lot!

    I have found an error in the catalog/includes/modules/categories_images.php file though that I thought you should be aware of.

     

    Thank you matthell,

    I have installed your solution, but not sure what the problem was, and what it came to solve :-)

    Can anyone explain? I don't see any noticeable change in my Category Images behaviour.

    No disrespect, but I would like to know if the author approves of this fix.

    Thank you,


  12. I didn't put that in because there's not much room to show text in the Grid mode. Figures someone would want it. So, find this code in catalog/includes/modules/categories_images.php (Lines 69-71)

    			  $info_box_text .= $category['name'];
    		  $space_above = true;
    		} //if (CATEGORIES_IMAGES_BOX_SHOW_NAME

    and insert this code just after that

    	  
    		// Show the products description if selected in Admin
    		if (CATEGORIES_IMAGES_BOX_SHOW_DESCRIPTION == 'True') {
    		  if ($space_above == true) {
    			$info_box_text .= '<br>';
    		  } // if ($space_above
    		  $info_box_text .= $category['description'];
    		} //if (CATEGORIES_IMAGES_BOX_SHOW_DESCRIPTION

    and you should have your description text. I'll add this to a new version as soon as I get a chance.

     

    Regards

    Jim

     

    Great! Thank you so much Jim.

    You were right, I have way to much text going on in my grid now. Time to rephrase some descs I guess...

     

    I would only suggest, if you will allow me, to place the new code after the link closing tag:

     

    $info_box_text .= $category['name'];
    $space_above = true;
    } //if (CATEGORIES_IMAGES_BOX_SHOW_NAME			
    
    		$info_box_text .= '</a>';
    // Show the products description if selected in Admin
    		if (CATEGORIES_IMAGES_BOX_SHOW_DESCRIPTION == 'True') {
    		  if ($space_above == true) {
    			$info_box_text .= '<br>';
    		  } // if ($space_above
    		  $info_box_text .= $category['description'];
    		} //if (CATEGORIES_IMAGES_BOX_SHOW_DESCRIPTION

     

    so the description will not show as a link.

     

    Thanks again,

    Eyal.


  13. Hi,

     

    I have installed and have it working. Looks great!

     

    Problem: I don't see the description for the category image.

    Oh' to answer my own question with another one:

    I couldn't see the description because I was in "Box style = Grid"

    Switched to "Box style = Rows" and I can see the desc.

    Is there a way to display desc in the grid mode?

    Thanks,


  14. I have "display prices with tax"=true on both store and customer group

    Group's tax exempts is set to false.

    And still it doesn't work - baffled.

    Got it to work!!! Thank you so much for your time and patience.

    There is no problem. I just didn't set the tax areas corectly.

     

    SPPC and OsCommerce Rocks!

    With love,


  15. What have order total modules have to do with taxes? Settings for taxes are the very first part in editing settings for customer groups:

    Show prices with/without tax:	  This Setting only works when 'Display Prices with Tax'
    	is set to true in the Configuration for your store and Tax Exempt (below) to 'No'.
    Tax Exempt:

    I have "display prices with tax"=true on both store and customer group

    Group's tax exempts is set to false.

    And still it doesn't work - baffled.


  16. Did you check the settings for customer groups in the admin? There are settings for "show tax" per customer group in there.

     

    Thank you for your answer Jan.

    What I did:

    1. In Customer groups setting, edited the group and selected: "Set order total modules for the customer group" and checked all boxes.

    2. I went to the customer details. In there I selected "Use settings from Configuration" for all modules.

    Still no luck. The tax still doesn't show.


  17. Hi,

    I have installed SPPC 4.2.2 - it is working fine on all levels. but ever since that I have lost the visibility of the VAT tax attached to each product.

    I am stuck with this for a long time now and cannot figure it out. I went through everything and read several articals, but nothing.

     

    Please, can you help? I'm Desperate!

     

    Thank you for all the great work!


  18. Hi,

    I have installed and working on v 2.2:

    1. Printable Catalog Printable Catalog v3.0 MS2

    2. SPPC 4.2.2

     

    My problem:

    When a user,who is not in the Retail group, prints a catalog he will always get the Retail group prices in his print.

    I am talking only on the printable Catalog, not the cart or any order total - they work fine as far as I can see. (I don't see the TAX ever since I have installed SPPC but that's for another topic...)

     

    Can you recommend a fix or another contribution that will print a nice catalog?

    I need the print for my Salesmen to hand over to customers.

     

    Thanks you so much in advance, especially the amazing contributors!

    I wish I was at a level to solve this myself; I tried but got confused and scared.

     

    yours humbly,

     

    Eyal

    How about an Open Source Car?


  19. See?

     

    Same problem

     

    I would love to be able to combine it with the printable catalog, which now shows only retail prices, no matter which customer group is logged in.

    I would like to use the printable catalog for the convenience of our sales team, so they can login as the customer/group and have his catalog ready to print or mail with the groups prices.

    Thank you so much,

    Eyal

×