Jump to content

ecartz

♥Ambassador
  • Content count

    3,760
  • Joined

  • Last visited

  • Days Won

    64

Reputation Activity

  1. Like
    ecartz got a reaction from Jack_mcs in how to bypass create_account_success.php   
    Or just duplicate the create_account page.  The new, not core, file could have completely arbitrary logic. 
  2. Like
    ecartz got a reaction from undersiege in error 500 Admin HTTP Authentication   
    You want the username/password that you set in your host server panel to be the same as the username/password set in the store admin.  Because when you authenticate through the host method, it will try to apply the same username/password to the store admin.  If they are set the same in both places, it will log you in.  If not, you have to log in twice.  Once with each credentials. 
    Then you are on the second part of the advice:  "contact your host to do it for you" since they won't let you do it yourself. 
  3. Like
    ecartz got a reaction from undersiege in error 500 Admin HTTP Authentication   
    Yes.  It's safer for the files not to be writable.  But then you have to manually keep them in synch. 
    Try 444. 
  4. Like
    ecartz got a reaction from undersiege in error 500 Admin HTTP Authentication   
    It wants you to make the admin/.htaccess and admin/.htpasswd_oscommerce files writable. 
    If you don't do that, don't click the checkbox. 
  5. Thanks
    ecartz got a reaction from Heatherbell in Customize colors and shipping on the site   
    The error is saying that you can't do
    const FOO = array( ); in older versions of PHP. 
    I strongly recommend against trying to edit Phoenix to work prior to PHP 7.  It's not going to be just one or even a hundred problems.  It's a constant battle to keep pace.  Because we will keep making changes using the new PHP functionality. 
    If PHP 5.5 or older is a real requirement, you're better off with some version of 2.3.4.  But really, the better solution is almost certainly just to use PHP 7.  Then you can use the code as written. 
  6. Like
    ecartz got a reaction from undersiege in Customize colors and shipping on the site   
    I'm not specifically familiar with that error, but my first guess would be that you are using an older version of PHP.  Phoenix is PHP 7+. 
    Note that you seem to be looking at the wrong file.  The error is talking about the language file but you are posting code from the code file. 
  7. Thanks
    ecartz got a reaction from Heatherbell in Customize colors and shipping on the site   
    The error is saying that you can't do
    const FOO = array( ); in older versions of PHP. 
    I strongly recommend against trying to edit Phoenix to work prior to PHP 7.  It's not going to be just one or even a hundred problems.  It's a constant battle to keep pace.  Because we will keep making changes using the new PHP functionality. 
    If PHP 5.5 or older is a real requirement, you're better off with some version of 2.3.4.  But really, the better solution is almost certainly just to use PHP 7.  Then you can use the code as written. 
  8. Thanks
    ecartz got a reaction from mariolensa in Lost styling in Catalog   
    Looking in your HTML, one problem is
    <link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css"> The // should have an https: in front. 
    There's also something wrong with how your Javascript is loading.  Did you perhaps delete or otherwise modify permissions of the ext directory?  It either needs to be readable or you need to move the Javascript out of it. 
  9. Thanks
    ecartz got a reaction from mariolensa in Lost styling in Catalog   
    Maybe.  But are the directories?  Try this link:  https://www.folkmusic.net/catalog/ext/bootstrap/css/bootstrap.min.css
  10. Like
    ecartz got a reaction from Demitry in checkout_success.php form and related modules   
    The point of the way that the wishlist module does things is that both modules require the same parameters.  You just want a different behavior depending on which button is clicked. 
    Add it as a footer script.  Either with a separate header tag module or simply by adding the appropriate block directly.  An example of adding modal HTML as a footer script directly:  https://github.com/gburton/CE-Phoenix/blob/65ba42f1d45be6b2e34b5af549812057dc4bb102/includes/modules/content/product_info/templates/tpl_cm_pi_gallery.php#L80
  11. Like
    ecartz got a reaction from hungryfrank in Phoenix 1.0.5.5 admin/products_expected.php   
    I would think that that would make the page not work properly.  You might be better off replacing it with
    AND products_date_available IS NOT NULL And higher in the page, replace
    tep_db_query("update products set products_date_available = '' where to_days(now()) > to_days(products_date_available)"); with
    tep_db_query("UPDATE products SET products_date_available = NULL WHERE NOW() > products_date_available");  
  12. Thanks
    ecartz got a reaction from raiwa in Google recaptcha v2 stopped working   
    I don't know anything about the App, but apparently this is a general problem:  https://github.com/google/recaptcha/issues/359
    There are workarounds/solutions posted in the GitHub issue. 
  13. Like
    ecartz got a reaction from valquiria23 in Change index page   
    Searching Google with "site:apps.oscommerce.com Featured Products" finds 2.3.x and Bootstrap versions.
  14. Thanks
    ecartz got a reaction from nedragdnuos in From Frozen to Phoenix   
    I would also point out that the original question was not if people should stop updating when they test an update and find it breaks an App (what most of the discussion suggests) but whether, starting now, someone should install 1.0.5.5 or some older version.  It is certainly possible that there are Apps that are broken in 1.0.5.5 that are not broken in 1.0.5.0, but it is not definite that the (unknown) Apps that the asker needs are more broken in 1.0.5.5 than in 1.0.5.0.  And it may be that some of things that that particular shop needs are easier to do in 1.0.5.5 than 1.0.5.0. 
    In my opinion, it would be better to start with 1.0.5.5 first and figure out what is and is not possible with that rather than start with the assumption that 1.0.5.0 (or some other version) would be better. 
  15. Thanks
    ecartz got a reaction from raiwa in Google recaptcha v2 stopped working   
    I don't know anything about the App, but apparently this is a general problem:  https://github.com/google/recaptcha/issues/359
    There are workarounds/solutions posted in the GitHub issue. 
  16. Thanks
    ecartz reacted to burt in From Frozen to Phoenix   
    I'm constantly surprised and sometimes astonished at the words that come out of shopowners...
    What you guys are implying is that it is too much work to apply a 1 or 2 or 5 or 10 minute upgrade to your shop, because you have used addons that change core code or may break.  Would that be a fair assessment?
  17. Thanks
    ecartz reacted to burt in From Frozen to Phoenix   
    That's precisely the point of the versioning - make a decision to use a software/version and then use it until one wants (or needs) to upgrade/change.
    As for being held back by addons - the whole point of ALL that Matt and I do is to make things easier for addon makers and by extension that makes life easier for shopowners.  Admittedly we have some addon makers who don't subscribe to the ethos of recoding things in a way that does not require core code change.
    As I say, I find it astonishing that anyone would be upset about forward movement.
  18. Like
    ecartz got a reaction from Mac2256 in Notice: Undefined variable error   
    Did you update from a previous version?  In the address_format table, change the things that say $firstname $lastname to just say $name instead. 
  19. Thanks
    ecartz got a reaction from raiwa in Admin : categories.php slow loading   
    MySQL also has cache settings in mysql.conf or whatever. 
    Have you tried turning on query logging and testing the queries in phpMyAdmin?  The logging tells you what queries the page is generating.  Then run the queries in phpMyAdmin to see which are slow. 
    With a large products_to_categories table, you might add a UNIQUE index on categories_id, products_id (in that order).  Because the categories page queries from a category usually.  So the primary key is backwards for its needs.  That usually won't matter, but it might in your circumstance. 
  20. Like
    ecartz got a reaction from TomB01 in FedEx - Web Services v9   
    If it is traversable, then replacing line 313 with
    $cost = (reset($rateReply->RatedShipmentDetails)->ShipmentRateDetail->TotalNetCharge->Amount)/MODULE_SHIPPING_FEDEX_WEB_SERVICES_CURRENCY; might work. 
    Setting it to List and explicitly casting to array might work. 
    foreach ((array)$rateReply->RatedShipmentDetails as $ShipmentRateDetail) I'm not sure what line that is, but it is before 313 and I just added (array) to it. 
    In a test store (not a live store, as it would break it), you could add
    var_dump($rateReply->RatedShipmentDetails); exit(); just before line 313 and see what it says.  Try twice, once each for domestic and international. 
     
  21. Like
    ecartz reacted to burt in Upgrading to the latest version   
    Yes, assuming this is your record shop we are talking about, it is a *very* old version of oscommerce (I'm surprised it is still working at all!). 
    If you have budget it may be advisable to get some quotes from the good developers here to upgrade you to the latest version (it need not cost that much actually, depending on what extras you need, it could be as little as an hours work).  Post at https://forums.oscommerce.com/forum/79-commercial-support-inquiries/ to get some quotes.  
  22. Like
    ecartz reacted to burt in Upgrading to the latest version   
    It's a matter of time, and my time is limited.
    Club Members come first, non club members can wait until I have more time.
  23. Like
    ecartz got a reaction from Mac2256 in Admin dashboards disappeared, help!   
    It looks like the Javascript is broken.  In admin/includes/configure.php make sure that ENABLE_SSL is set to true and that both the HTTP_SERVER and HTTPS_SERVER are https:// URLs for admin and catalog.  Also check that admin/includes/modules has stuff in it. 
    In general check the error logs to see if you're getting any informative errors. 
    In your browser, try looking at the Javascript console to see if it has informative errors. 
  24. Thanks
    ecartz got a reaction from mujahid in problem in search with letters like 'union' keyword in OSCommerce   
    As I said, that's not an osCommerce file.  So I have no idea how it works.  You could try finding whatever is breaking things in it.  Or you could contact whomever installed it or provided it to fix its behavior.  It's called a connector, so the problematic code may be outside the file in the thing to which it connects.  Which might not be available to you. 
    The only real suggestion I can make is to try commenting out the php_value line and see what happens.  If that fixes the problem, then you can work out which is more important, malware protection or searches for union.  And perhaps contact whomever provides it for support. 
  25. Thanks
    ecartz got a reaction from mujahid in problem in search with letters like 'union' keyword in OSCommerce   
    Well, if you look in the .htaccess, it says /home/lkay/domains/socomtactical.net/public_html/qshield/WafConnector.php
    The other is probably in the public_html directory. 
    Neither of those is standard.  The latter is probably an SEO App for osCommerce.  The former is probably a malware blocker of some sort, not related to osCommerce at all. 
×