Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

CutieCute2

Members
  • Content count

    98
  • Joined

  • Last visited

Everything posted by CutieCute2

  1. CutieCute2

    Checking File Permissions

    Hi Geoffrey and other "permissions checker" fans. You must all be busy? My problem isn't a big one so I'm still hoping to solve it. To reiterate my problem and question....... When I upload new products, the uploaded images have a 777 permission instead of 644. The option of updating all permissions with Geoffrey's Permission Checker seems better than changing the permissions of each new image, however, I require a 700 permission for my sitemonitor.php file so I have to change that manually. I have tried to create an individual checker thingy for sitemonitor.php by changing sitemap to sitemonitor. It all appears and looks good but doesn't change the permissions. Could someone please tell me the lines I need to change?
  2. CutieCute2

    Checking File Permissions

    So, in order to have the site_monitor.php file set to 777, I need to duplicate another entry such as the one for IP_trap.php I have duplicated info at lines: 175 483 591-595
  3. CutieCute2

    Checking File Permissions

    I've made some progress creating a special entry for sitemonitor. I've tried twice, once duplicating the IP_trap (15) and once duplicating the sitemap (16) info to sitemonitor (17), and both times the sitemonitor appears on the first page but after I click on "check" or "update", nothing happens. The default permission is 700, but the check shows 644 OK. Thanks.
  4. CutieCute2

    SiteMonitor

    Thanks again for your continued support Jack.
  5. CutieCute2

    SiteMonitor

    Hello all. Is it possible to make some changes so that the site monitor addon can check more files? For example, check the files on a html website on the same domain name or even check another shop on the same hosting account? Ideally, is it possible (and practical) to have one site monitor add on installed to check all files in a hosting account? -------------------- The reason I ask is to be able to check several shops within one hosting account with one click and more importantly, just set one crontab and get one email informing the status of muliple sites.
  6. CutieCute2

    Checking File Permissions

    (EDITED) As I posted the solution to my own question from yesterday and asked my next question, you posted both solutions. Thanks Geoffrey Walton!!!
  7. CutieCute2

    Checking File Permissions

    Hi Geoffrey, I have a crontab set up to execute admin/sitemonitor.php but after I update my php files to 644, I get a message (execute) "permission denied". When I change this file to 700, it works. My problem here is that after I update my permissions in the administration panel, I need to go to my hosting control panel everytime to change my admin/sitemonitor.php permission setting. I guess the only solution to this is to individualize the admin/sitemonitor.php permission like you have done to configure.php and IPtrap.php???
  8. CutieCute2

    Checking File Permissions

    Hi all and thanks Geoffrey for a great contribution. My question:- How can I change the default permissions which appear just before I click on update? Details:- When I add a new product, the images are uploaded with a 777 permission. There might be an easier way to change these permissions but about once a week, I just use this addon and update image permissions to 644. To my annoyance, I have to change ALL the default permissions to my desired permission EVERYTIME. Also, It's been mentioned in the previous page or two that some of the suggested permissions are strange. This problem can be eliminated if the contribution user can change the default permissions themselves to their desired settings. Thanks.
  9. CutieCute2

    SiteMonitor

    Hi Jack, I've set up the cron job and I get an email saying:- /bin/sh: home/www/ (myurl) .com.au/buy/admin/sitemonitor.php: Permission denied I've checked my .htaccess files but don't know how to fix it. If this problem has been discussed before, let me know and I'll look for it. Cheers, Christina
  10. CutieCute2

    No SiteMonitor in Left Column

    See this thread for the solution to my problem and other discussions for this contribution. Site Monitor Thread
  11. CutieCute2

    SiteMonitor

    I'm not an expert at this but try copying the the V2.9 files over the old ones. Make sure the code to be inserted the other 3 files are the same in both versions too.
  12. CutieCute2

    SiteMonitor

    The other version does refer to previous versions and probably had it written somewhere and I missed it. So Sorry, my Bad. Although, opening up the catalog folder and seeing the choice is much better. But as you mentioned, if someone has the same problem as I had, hopefully they can find this thread.
  13. CutieCute2

    SiteMonitor

    Hi Jack, Problem solved. I had contributions 7729 and 4441 downloaded to my computer. I was using 7729 which is for OSC V2.3. When I opened 4441, I saw the two versions and realized there was a seperate version for V2.2. I've made good progress since then. Thanks for a great contribution and for your advice.
  14. CutieCute2

    SiteMonitor

    Thanks for you post. I can confirm that (DIR_WS_BOXES . 'blablabla.php');, does create a fatal error message (DIR_WS_BOXES . 'tools.php');, (DIR_WS_BOXES . 'tools.php');, Creates the tools link twice. and (DIR_WS_BOXES . 'sitemonitor.php');, produces nothing at all. I think I have a basic problem so I've tried to understand the basic operations of the (your?) addon contribution. When the admin index page is loaded it calls (pardon my amature languague) the admin/includes/column_left.php which lists all the links to be placed in the left column. (as above). The line (DIR_WS_BOXES . 'tools.php');, calls the admin/includes/boxes/tools.php file which contains something like HEADING_BOX_TOOLS which call the word "Tools" from the admin...english.php . All the above is true for the sitemonitor link but nothing is displayed. I even cut the contents of boxes/sitemonitor.php and pasted into boxes/tools.php but the word Tools disappeared from the list of links in the left column. I've been wanting a contribution like this for the last year but just came across it recently. It's such a shame I can't use it.
  15. CutieCute2

    SiteMonitor

    Thanks for taking the time to try to help me. When i said "admin menu list" I meant the column on the left side of the admin page. I've been through the first four steps a number of times to see if I'm making a mistake, but still no luck. Are you saying if my admin/includes/column_left.php file includes require(DIR_WS_BOXES . 'sitemonitor.php'); with no other changes, I would be able to see something in the left column? How about require(DIR_WS_BOXES . 'blablabla.php'); ? If this is not the case, my curiosity still lies in the question. If one wanted to create a new line (with or without a link to click on) in the left column on the admin page, which file or files would need to be modified? How would this be done?
  16. CutieCute2

    SiteMonitor

    I've spent a few hours looking at the files trying to work out how things work but didn't make much progress at all. If one wanted to create a new line (with or without a link to click on) in the admin menu list, which file would need to be modified? How would this be done? Or Is the one line placed in "admin/includes/leftcolumn.php" and the seperate file like sitemonitor.php produce the text in the admin menu?
  17. CutieCute2

    SiteMonitor

    Nothing is there to click on. OSC V2.2. I have tried new and old versions of sitemonitor, tried to install it on a site with security pro, one without then I made a fresh OSC shop and tried it there. I have no clue as to what's wrong. Thanks
  18. CutieCute2

    No SiteMonitor in Left Column

    Hey Chris. Thanks for your fast response. I don't think this is my problem. I have :- require(DIR_WS_BOXES . 'sitemonitor.php'); require(DIR_WS_BOXES . 'configuration.php'); require(DIR_WS_BOXES . 'catalog.php'); require(DIR_WS_BOXES . 'modules.php'); require(DIR_WS_BOXES . 'customers.php'); require(DIR_WS_BOXES . 'taxes.php'); require(DIR_WS_BOXES . 'localization.php'); require(DIR_WS_BOXES . 'reports.php'); require(DIR_WS_BOXES . 'tools.php');
  19. CutieCute2

    No SiteMonitor in Left Column

    I've installed sitemonitor V2.8 for the first time and had the same obstacle. OSC V2.2. Thanks in advance for any advice.
  20. CutieCute2

    SiteMonitor

    Hi all and thanks Jack for all your work. I've tried this (SiteMonitor V2.8) on two of my sites but I can't figure it out. The first four steps seem basic like any other addon contribution so I can't figure out what I've done wrong. For step 5, I logged into the admin and looked at the left for SiteMonitor but nothing. Can anyone offer any dvice?
  21. You were probably only one step away from getting it to work. Why don't you try to install it again?
  22. I usually (always?) go for the most recent version of an add-on because I assume it's the most advanced. In this case, it was a Polish version of Ultimate URLs. Since my site appeared to work well, I applied the add-on to a number of my other osc shops. After I found the admin section was in Polish, I started the process of trying to uninstall the Polish language and install the English version. Initially, I removed the two maiin files and selected uninstal in the admin panel but the Polish was still there and the site was still using Ultimate URLs so I assumed it had something to with the cache or the language being in the database. Anyway, after deleting and uploading the English version of the two files, selecting uninstall in the admin and checking the front end of my site a number of times eventually the Polish disappeared. After installing the English files once again, the English suddenly appeared in the admin. I couldn't work it out step-by-step because what worked one time, didn't work the next. All I can say is keep trying and you CAN get rid of the Polish and get English. Sorry, I can't be more help.
  23. I installed the Polish version to all 5 of my sites. I've managed to change back one (My plants shop) after some anxious moments. My site disappeared but I did a save then an old reinstall then the new reinstall and not only did my site come back but the admin section was English too. Bonus! I guess I'll just do the same with my other 4 sites tomorrow. Thanks heaps Jack.
  24. Yes. It's all in Polish but I realized the uninstall is the bottom one. Now to try to install your English version. Thanks.
  25. I've reloaded includes/classes/seo.class.php but I still see Polish????????
×