Jump to content

raiwa

♥Ambassador
  • Content count

    4,002
  • Joined

  • Last visited

  • Days Won

    135

Posts posted by raiwa


  1. Uploaded Update

    Version 1.0.14

    - Added line to reset attributes variable between each product in order e-mail

    Attributes were concatenated through all products in order confirmation mail.

    This update changes this file:
    includes/modules/payment/stripe_sca.php
    but the entire contents of the ext and includes folders in the update can be copied to the catalog root of the store.


  2. If your 2.2.MS2 store has not been somehow updated/patched for higher PHP levels, it won't run higher than with PHP 5.2.

    So the fix would be to ask your host if they can switch back to PHP 5.2.

    2.2MS2 is very, very outdated, it's time to consider to upgrade to Phoenix.


  3. 27 minutes ago, Tiffany_Waggoner said:

    This store is an exact clone of a previous working store, with the only difference of the stylesheet, but obviously something major is broken.

    It seems you moved the store to another server with a higher PHP level which is not compatible with your store version. Or your host changed the PHP level to a higher version.

    For more precise advice you should tell us:

    • the exact OsCOmmerce version you are using
    • the PHP version you are actuall y running
    • the PHP version you were running before

    See also:

    How to get the help you need.


  4. Featured Products CE v2.1.1.

    Tested and working with Phoenix 1.0.5.1.

    One small Notice error in: admin/featured_products.php can be fixed like this:

    change line 122 to:
     

              echo tep_draw_input_field('expdate', (isset($fInfo->expires_date) ? substr($fInfo->expires_date, 0, 4) . '-' . substr($fInfo->expires_date, 5, 2) . '-' . substr($fInfo->expires_date, 8, 2) : ''), 'class="form-control" id="expdate"');

    "isset" instead of "tep_not_null"


  5. As the updated for Phoenix 1.0.5.1 will take longer as expected, I uploaded the intermediate update for Phoenix 1.0.5.0.

    This version is not compatible with Phoenix 1.0.5.1 !!!

    Purchase without account 4.1.0

    Changes Version. 4.1.0
    - updated for Phoenix 1.0.5.0
    - hooked all modifications on admin side
    - one hook call needed to be added in admin/orders.php and checkout_process.php

    5 versions included:
    Phoenix 1.0.2.0 and lower: (old review write page "reviews_write_pwa.php")
    Phoenix 1.0.2.1 and higher: (new reviews module "ext/modules/content/reviews/write_pwa.php")
    Phoenix 1.0.2.6 and higher:  (restyled checkout success modules")
    Phoenix 1.0.4.0 and higher:  (updated review stars in admin/reviews.php")
    Phoenix 1.0.5.0:  (hooked all modifications in admin)


  6. 6 hours ago, cinolas said:

    So I found what the problem was, or how to fix it anyway. I'll post it here in case it's of any use to anyone.

    In shopping_cart.php around line 56 there's the line:

    
    while (list($option, $value) = each($products[$i]['attributes'])) {

    This is where my problem was. It wasn't doing the WHILE statement for some reason, even though that very same syntax is used around line 116 and that second instance of it works fine.

    So the solution to my problem was to replace the first WHILE (around line 56) with a FOREACH statement. I don't know why this works when the WHILE doesn't, but it does for me:

    
    foreach ($products[$i]['attributes'] as $option => $value) {

    And now my attributes display again. SOLVED!

    Thanks for the help!

    This is unrelated to QtPro. It's related to other modifications in the file:

            while (list($option, $value) = each($products[$i]['attributes'])) {
    		 if (2 == $customer_id) {	
    			echo "inside SECOND while<br>";
    		  }
    		  $products_name .= '<br /><small><i> - ' . $products[$i][$option]['products_options_name'] . ' ' . $products[$i][$option]['products_options_values_name'] . '</i></small>';
            }

    The original core and qtpro code uses already "foreach..."


  7. 23 hours ago, radhavallabh said:

    Hi , Thank you for this wonderful addon;

    I use Oscommerce 1.0.5.0 Phoenix with multiple languages- English, German, Spanish

    I face a issue the products shown in the recently viewed are in all 3 languages together..

    When I view the catalog in English----The recently viewed addon shows a product in english, german and spanish in 3 separate boxes of the row.

    Please help on how to fix it;

    Regds./

    radhavallabh

    Hello,

    I checked on my multilanguage test store and all shows correct.

    Can you please post a screenshot and/or PM the link to the store.

    rgds
    Rainer


  8. 35 minutes ago, cinolas said:

    That would be a nightmare @raiwa, my installation is highly customized. I understand that the problem is in my customizations, and not in your code. As such, your help is beyond supporting your contribution. My problem is seemingly simple though: The attribute data is in the database, I just need to make it display on the page.

    I don’t mean to revert on the whole site, only on the page where you have the issue. As you have it already quite localised, it shouldn’t bee so much. I can’t help you further not knowing your mods.


  9. There is no problem using $_POST.

    I thought you were using the wrong Phoenix version.

    If your version states it is for GOLD, there is no reason to update. Use all files and code from your original package.

    I believe you have a problem with additional modifications or another add on you have in your store.

    Revert temporary all other mods and try to find what produces the problem

     


  10. 4 minutes ago, ce7 said:

    @raiwa

    Hi Rainer

    I installed this addon on CE, it was working, and when something wrong with configuration, fixed it, and after that, two situation happened.

    one is like this
    image.png.8881c20ecb291bb2f1e3bb3d7fb963eb.png

    the other one is installed but nothing show on the front page at all.

    Can you please kindly tell me what possible reason to cause this?

    Many thanks! Lyn

    Sorry, I do not understand. Please be more precise. Which OScommerce and Store hotline exact versions ?


  11. Hello Nicolas @cinolas,

    Please use the correct version for GOLD. The latest Phoenix version is not compatible with GOLD

    The highest available version for GOLD is the version included in QTpro CE Phoenix 6.0.0.

    Please use the files in the folder "2.3.4.(1.) EDGE"

    - check the modifications in the shopping cart section in includes/application_top.php
    - check and remove temporary other third party modifications/addons

    Sorry, I have no Gold test installation any more, so I can't give more specific advice. But I know that it works without problems with Gold.

    rgds
    Rainer

×