Jump to content

raiwa

♥Ambassador
  • Content count

    3,369
  • Joined

  • Last visited

  • Days Won

    114

Everything posted by raiwa

  1. Yes, and I sent the answer with results yesterday.
  2. Hello Dave, There were a lot of things which didn't work in the older version. I have not too much experience in php programming and it took me about 3 months to modify the existing version to work and a hughe amount of try and error :rolleyes: . Then I stripped off all the additional code for the contributions I use, tested this on a virgin osc2.2 test installation and posted this as the new version 5. I added support for some additional contributions (which I separated in the last 5.1 version in a new separate package here: http://addons.oscommerce.com/info/8578 More contributions will be added there in the future when I have time to write the install instructions. So if you use other contributions which you want's to work with iOSC, you have to add/adapt the necessary code to iOSC yourself. Allthough it would be very apreciated if you upload your solutions to the above mentioned package. For the Ultimate SEO URLs v2.2d issue I'm very sorry but I can't help you with this. I don't have this version installed on my test shop, no time to do it, and not enough knowledge to give you advise from 'theory'. Maybe someone else can help you. sorry and best regards Rainer
  3. Hello, I try to recompile a list of files which can be envolved in this bug: .htaccess includes/modules/ultimate_seo_urls5/page_modules/mobile_catalogue.php includes/modules/ultimate_seo_urls5/page_modules/mobile_product_info.php mobile/includes/classes/mobile_redirect.php mobile/includes/configure.php mobile_catalogue.php mobile_product_info.php includes/application_top.php So I would ask you to send me these files (or the relevant parts of code) to: info@sarplataygemas.com I'll try these files in my test shop and see if I can find the bug. Best regards Rainer
  4. Hello, I tried to modify seo urls 2.2 by Chemo to work with the mobile site, but it was impossible(at least for me) because there are not separate page files (like in Ultimate Seo Urls 5 PRO) which can be adapted for new pages, but only one script for all redirects. So it is much more complicate and I had no success. In any case it's not so much job to change to Ultimate Seo Urls 5 PRO. regards Rainer
  5. Sorry not in all files, only in product_info.php and in mobile_product_info.php., so I checked and saw that in the categories the link is also wrong: mc instead of c. Then it's not this. I could reproduce your error for the categories when the wrong code in mobile catalogue.php is placed: // set the link for classic site $classic_site = str_replace('mobile_catalogue.php', 'index.php', $_SERVER['REQUEST_URI']); instead of this which is necessary if you use Ultimate Seo Urls: // set the link for classic site if (USU5_ENABLED != 'true') { $classic_site = DIR_WS_HTTP_CATALOG . 'index.php?' . tep_get_all_get_params(); } elseif (strpos($_SERVER['REQUEST_URI'], 'mobile_catalogue.php') == TRUE) { $classic_site = str_replace('mobile_catalogue.php', 'index.php', $_SERVER['REQUEST_URI']); } Sorry that I posted the standard code in a former message. If this doesn't help I only can recomend to download the last version and review the upgrade steps for older versions (4.x) which are now included. Or did you upload all new files and overwite your complete old version? regards Rainer
  6. Hello, in my page module files (all of them, the original files as well as the 3 modified files for the mobile pages) this line reads like this: ->separateUriText( $this->linktext( $this->linkTextOrder( $link_text ) ) ), $this->dependencies[$this->key]['marker'], $this->keys_index[$this->key], $target_language_code ) ); $this->linktext( $this->linkTextOrder( $link_text ) instead of: $this->linktext( $link_text ) regards Rainer
  7. Hello, Then it seems you have an older version of ULTIMATE Seo Urls installed. Please updat to: ULTIMATE Seo Urls 5 ( r205 ) I wrote this at the beginning of the installation instruction: This is for: ULTIMATE Seo Urls 5 ( r205 ) - by FWR Media http://addons.oscommerce.com/info/6768 It is tested with: Ultimate Seo Urls 5 PRO ( r205 ) uploaded by FWR Media the 21 Mar 2011 Older versions may work, but have not been tested regards Rainer
  8. Hello again, another possible reason for the redirect error: make shure you have included in: mobile_catalogue.php this new code: // set the link for classic site $classic_site = str_replace('mobile_catalogue.php', 'index.php', $_SERVER['REQUEST_URI']); and not the old code from mobile_products.php: $PCSITE = DIR_MAIN_HTTP_CATALOG . FILENAME_DEFAULT . '?' . tep_get_all_get_params(); regards Rainer
  9. Hello, I checked your site and found that the redirect code works for all other pages which are nor related to categries and products. So I think it has to do with the redirect code in application_top or the modifications for ULTIMATE SEO URL. Please post your code in mobile_footer.php and the redirect code in your application_top.php file. And check again the Installation for ULTIMATE SEO URL. You can also download the newest version iOSC 5.1, uploaded yesterday, which includes detailed update instructions for version iOSC 4.1. For the AJAX problem I have to recognize that I didn`t check the AJAX enabled mode because I found it not too useful for mobile devices because some may not have java script installed/enabled. When I checked it now a little bit I found the solution for the jumping to mobile_index.php: In: catalog/mobile/includes/classes/categories_js.php change: FILENAME_DEFAULT to FILENAME_CATALOG in line 25 and 33 The problem is that the 'New Products' and 'Promotions' entry will not show at the top of the categories. Also the 'show more results' link at the bottom doesn't work. So for now you should disable AJAX and I'll see if I find a solution for this in the future and include it in the next update. Best regards Rainer
  10. Best regards Rainer If you use OSC 2.3: the iOSC 5.x contribution is written and tested for OSC 2.2 only. So you may find help for this error here: http://forums.oscommerce.com/topic/376276-headers-already-sent/page__st__20__hl__+iosc#entry1651869 regards Rainer
  11. Please review your installation it should work. Give more detailed information of the link if you can't find the solution. Best regards Rainer
  12. Hello, try this: Edit your php.ini and set output_buffering to 4096 hope this helps Rainer
  13. Hello, you have to install the support for ULTIMATE SEO URL which is included in iOSC 5.0 in 'aditional contributions'. Then it will redirect correct. regards Rainer
  14. Hello, try this: <p>Some text ........ <sub>[b]<a href="' . ((mobile_session() == 'mobile_"the_mobile_page_where_your_link_is_placed".php') ? FILENAME_MOBILE_CONDITIONS . '#Sameday' : FILENAME_CONDITIONS . '#Sameday') . '">(see terms and conditions)</a>[/b]</sub></p> change: mobile_"the_mobile_page_where_your_link_is_placed".php to the name of the Mobile file where your link is placed. hope this helps Rainer
  15. Hello, For the first 2 files you should add the following to the redirect code you copied to catalog/includes/application_top.php: find: if ($url_basename == 'recently_viewed.php') { $mobile_site = str_replace('recently_viewed.php', 'mobile_index.php', $_SERVER['REQUEST_URI']); } add below this: if ($url_basename == 'shop_by_price.php') { $mobile_site = str_replace('shop_by_price.php', 'mobile_catalogue.php', $_SERVER['REQUEST_URI']); } if ($url_basename == 'ask_a_question.php') { $mobile_site = str_replace('ask_a_question.php', 'mobile_contact_us.php', $_SERVER['REQUEST_URI']); } As you said you have these 2 contributions installed which have no correspondence in the mobile version. So now from the page "shop_by_price" will be redirected to "mobile_catalogue" and from "ask_a_question" will be redirected to "mobile_contact_us". For the third error "mobile_reviews.php" it seems you made a mistake copying the name of the file or you have the name changed in your shop. The original filename is: "product_reviews.php", not "reviews.php". So the redirect searches for a file called "mobile_reviews.php" instead of "mobile_product_reviews.php". 3 solutions: 1. change the filename of "reviews.php" to "product_reviews.php" (don't forget to correct it in "includes/filenames.php" too). OR 2. change the filename of "mobile_product_reviews.php" to "mobile_reviews.php" (don't forget to correct it in "mobile/includes/configure.php" too). OR 3. add this in includes/application_top.php at the same place where you added it for the first 2 pages. if ($url_basename == 'reviews.php') { $mobile_site = str_replace('reviews.php', 'mobile_product_reviews.php', $_SERVER['REQUEST_URI']); } Hope this helps raiwa
  16. raiwa

    The Feedmachine Solution

    Hello again, I got a while to add some more concrete recomendations: 1.- for the brand tag: It seems you don't use manufacturers in your shop. See Step 4 in the instructions and use a fix brand for all products: 'brand' => array('output' => 'My Own Brand', //Put here your proper Brand 'type' => 'VALUE', ), 2.- for the google category tag, Missing recommended attribute: google product category: It seems you didn't link ALL your shop categories to google categories. See Step 6 in the instructions and add the links for the missing categories: function FM_RS_google_categories_us_en($product) { $output_field_category = ($product['parent_id'] > 0) ? $product['parent_id'] : $product['categories_id']; return (($output_field_category == 1) ? 'Google > Category > Tree1' : (($output_field_category == 2) ? 'Google > Category > Tree2': (($output_field_category == 3) ? 'Google > Category > Tree3': (($output_field_category == 4) ? 'Google > Category > Tree4': (($output_field_category == 5) ? 'Google > Category > Tree5': (($output_field_category == 6) ? 'Google > Category > Tree6': (($output_field_category == 7) ? 'Google > Category > Tree7': (($output_field_category == 8) ? 'Google > Category > Tree8': (($output_field_category == 9) ? 'Google > Category > Tree9': (($output_field_category == 10) ? 'Google > Category > Tree10': (($output_field_category == 11) ? 'Google > Category > Tree11': (($output_field_category == 12) ? 'Google > Category > Tree12': (($output_field_category == 13) ? 'Google > Category > Tree13': (($output_field_category == 14) ? 'Google > Category > Tree14': (($output_field_category == 15) ? 'Google > Category > Tree15': (($output_field_category == 10000) ? '': (($output_field_category == 10000) ? '': (($output_field_category == 10000) ? '': (($output_field_category == 10000) ? '': (($output_field_category == 10000) ? '': '')))))))))))))))))))); } 3.- for the google category tag Unknown 'google product category' value: In the lines you don't use leave the right side blank like here: (($output_field_category == 12) ? '': 4) for the mpn tag, Missing recommended attribute: mpn(4 warnings): it seems you didn't fill out the 'model' field for 4 products. If you still get errors, please quote the code of your configuration file, or mail it together with your feed file. My mail: info@sarplataygemas.com regards Rainer
  17. raiwa

    The Feedmachine Solution

    Hello, sorry but it seems you didn't adjust the configuration file for your needs. Read the instructions for these tags where you get the errors. regards Rainer
  18. raiwa

    The Feedmachine Solution

    Hello, The feed generated by this contribution is text format as you see by the extention ..h-feed-us-en.txt First be shure you didn't change the file extension from: ..h-feed-us-en.txt to..h-feed-us-en.htm or ..h-feed-us-en.html in line 17 of the configuration file: 'filename' => 'google-product-search-feed-us-en.txt', If this is ok try this: In Google Merchant Center, go to Data Feeds, then edit the configuration of your data feed, change: file format from "automatic detection" to "text". Some terms may be different, I translated this from spanish version. If this doesn't help, send me your feed configuration file and your data feed, I'll see what I can do. My mail: info@sarplataygemas.com regards Rainer
  19. raiwa

    The Feedmachine Solution

    New version uploaded here: http://addons.oscommerce.com/info/7130 Version 2.1 added: color tag: - function added to read color values from product options size - function added to read size values from product options Includes caracter stripping, for example if reference numbering like 1-black, 2-white etc. is used. regards Rainer
  20. raiwa

    [CONTRIBUTION] Sloppy Words Cleaner

    Hello, I think this is possible, but it goes far over my php programming capacities. As I corrected before the chaotic entries manually one by one, i didn't worry about this. Of course it would be nice if someone out there with enough programming skills could add this. Best regards Rainer
  21. raiwa

    The Feedmachine Solution

    The new vesion: Google Product Search Feed 2.0 (Feedmachine Configuration) has been uploaded here: http://addons.oscommerce.com/info/7130 In a standard OSCommerce instalation, there are no fields included to extract the following google feed tags: - gender - age_group - color - size - material - pattern These tags are now required for apparel products in US and maybe in future in other countries too. The fields can be individually activated in admin/configuration to show only on admin site (enough to be included in google feeds) or admin + catalog (product_info.php only). There are alternative instructions to include fix values for all products of your shop, or category based values for the 'gender' and 'age_group' tags. Hope this helps Rainer
  22. raiwa

    The Feedmachine Solution

    Hello, It seems you use the weight based shipping cost of OSCommerce, so I do the same. As far as I know there is no way to extract the shipping cost information, as OSCommerce dosn't calculate the cost until an item is added to the shopping cart, at least. At least my programming knowledge doesn't go far enough to do this. The solution I use is to include the shipping weight tag in the google feed and set up a weight based shipping table in Google tax and shipping config. This assigns a weight based shipping cost to each item, even it can't calculate real shipping costs for a purchase of several items. Actually I'm working on an update which will include a solution for the new in US-feeds required gender, age group and color tags for apparel products. Hope it will be ready for upload in a couple of weeks. regards Rainer
  23. raiwa

    The Feedmachine Solution

    Hello again, The decimals doesn't matter because they will be rounded to 2 decimals in google shopping. About the ftp upload , I have the same problem and didn't get it to work neither. I use the "Sheduled Upload" feature in the Google Merchant Center - Data Feeds, just where you define your feeds. regards Rainer
  24. raiwa

    The Feedmachine Solution

    Hello, I had the same problem and can give you a help with a user function which calculates the price incl. tax in a diferent way than the standard functions includedd in feedmachine. I discovered that at least in my case the problem is caused by zones which have diferent tax rates assigned in the same country. Like in Spain: Ceuta, Melilla and Canarian Islands. So here the solution: If you use only one configuration file, paste this function in the function area of the configuration file (between: //FEED FUNCTIONS BEGIN and //FEED FUNCTIONS END): function FM_RS_final_price_with_tax($product) { return ($product['products_price']) * (1+((tep_get_tax_rate($product['products_tax_class_id'])/100))); } If you use more than one configuration file which needs to use the function, paste it in: catalog/admin/feedmachine_loadingbay.php Then in the configuration file CHANGE THIS (instead of "FINAL_PRICE_WITH_TAX" you may have another keyword there): 'price' => array('output' => 'FINAL_PRICE_WITH_TAX', 'type' => 'KEYWORD', ), TO THIS: 'price' => array('output' => 'FM_RS_final_price_with_tax', 'type' => 'FUNCTION', ), That's it. Here another small function to add the unit to weight if you use it: function FM_RS_shipping_weight_and_unit($product) { return $product['products_weight'] . ' kg'; } AND 'shipping_weight' => array('output' => 'FM_RS_shipping_weight_and_unit', 'type' => 'FUNCTION', ), Same installation like the price with tax. Hope this helps regards Rainer
  25. raiwa

    [CONTRIBUTION] Sloppy Words Cleaner

    Hello, I had the same problem with german umlauts and spanish accents. Even worse, the add-on didn't do any change on special characters. So after a huge amount of try and error, I'm not a programmer, I found a solution which maybe is not too elegant, but works. I uploaded it as version 1.5 here: http://addons.oscommerce.com/info/5550 -- v1.5 === Support for special characters like ä,é,ç for german, spanish, french, and skandinavian languages added. 1. New function to convert special characters to lower case added. 2. New function to convert letters following special characters to lower case added (Müller instead of MüLler, Fernández instead of FernáNdez). 3. New function to convert special characters in first letter of words to upper case(Úbeda instead of úbeda). Special characters for other languages like czech or serbo-croat can be added. 4. Some more details are changed to older versions: a. RemoveShoutingCN for the company is commented out. Reason: Company names have a huge amount of possible combinations of upper and lower case which in my opinion can not be included all in the exceptions list. b. "True" statement added to firstname, lastname "RemoveShouting", this activates the exception lists for names. c. Some more exceptions added to name and address for german, spanish and french language. 5. Support added for add-ons: "DHTML State Selection for 2.3.1" http://addons.oscommerce.com/info/8028 "DHTML State Selection" (v2.2) http://addons.oscommerce.com/info/6975 "NIF" http://addons.oscommerce.com/info/1778 best regards Rainer
×